patchelf v0.9 corrupts cross built aarch64 elfs

Bug #1786369 reported by Florian Delizy on 2018-08-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
patchelf (Ubuntu)
Undecided
Unassigned

Bug Description

patchelf corrupts ELF when run from a x86_64 host onto an ARM elf sofile.

This is a problem of version 0.9 and has been corrected on 0.10 according to this thread: https://github.com/termux/termux-packages/issues/1706

I have personally tested 0.9 and 0.10 on my setup, 0.9 does corrupt files, 0.10 does not.

Please update the patchelf package to 0.10 (latest master from patchelf sourcecode, as no release have been tagged so far). The current version is pretty much unusable for ARM/Android devs.

Thanks,

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers