README has wrong location for local user new pastebin conf files

Bug #1446433 reported by Paulo Marcel Coelho Aragão on 2015-04-21
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
pastebinit
Medium
Unassigned
pastebinit (Ubuntu)
Medium
Unassigned

Bug Description

File /usr/share/doc/pastebinit/README says:

"To enable support for private pastebins, first you will need to know the fields
that are in use by the pastebin when posting data.

Add a file in the ~/pastebin.d or /etc/pastebin.d/ directory"

but the right directory to add local user pastebin conf files is:

~/.pastebin.d

This extract from /usr/bin/pastebinit confirms it:

    def preloadPastebins():
        # Check several places for config files:
        # - global config in /etc/pastebin.d
        # - for source checkout, config in the checkout
        # - user's overrides in ~/.pastebin.d
        # Files found later override files found earlier.
        pastebind = {}
        for confdir in ['/usr/share/pastebin.d', '/etc/pastebin.d',
                        '/usr/local/etc/pastebin.d',
                        os.path.expanduser('~/.pastebin.d'),
                        os.path.join(
                            os.path.dirname(
                                os.path.realpath(__file__)), 'pastebin.d')]:

ProblemType: Bug
DistroRelease: Ubuntu 14.10
Package: pastebinit 1.4-3
ProcVersionSignature: Ubuntu 3.16.0-34.47-generic 3.16.7-ckt8
Uname: Linux 3.16.0-34-generic x86_64
ApportVersion: 2.14.7-0ubuntu8.4
Architecture: amd64
CurrentDesktop: XFCE
Date: Mon Apr 20 22:25:10 2015
InstallationDate: Installed on 2014-11-25 (146 days ago)
InstallationMedia: Xubuntu 14.10 "Utopic Unicorn" - Release amd64 (20141022.1)
PackageArchitecture: all
SourcePackage: pastebinit
UpgradeStatus: No upgrade log present (probably fresh install)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in pastebinit (Ubuntu):
status: New → Confirmed
Rolf Leggewie (r0lf) on 2016-02-29
Changed in pastebinit (Ubuntu):
importance: Undecided → Medium
Changed in pastebinit:
importance: Undecided → Medium
status: New → Triaged
Stéphane Graber (stgraber) wrote :

Just pushed a fix to bzr now, thanks

Changed in pastebinit:
status: Triaged → Fix Committed
Rolf Leggewie (r0lf) wrote :

1.5 has been released which fixes this issue. Thank you for reporting.

Changed in pastebinit:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pastebinit - 1.5-1

---------------
pastebinit (1.5-1) unstable; urgency=medium

  * new upstream release
    - add https support. Closes: #799580, closes: #708206.
    - add support for hidden pastes. Closes: #670485.
    - correct mistake in README. LP: #1446433
  * drop all Debian patches since they were applied upstream
  * control: update to Debian standard 3.9.7
  * copyright: update copyright to 2016

 -- Rolf Leggewie <email address hidden> Tue, 01 Mar 2016 20:18:36 +0800

Changed in pastebinit (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers