partman-uboot needs to exist for check script for supporting manual partitioning

Bug #431206 reported by Michael Casadevall on 2009-09-17
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
partman-uboot (Ubuntu)
Medium
Michael Casadevall
Karmic
Medium
Michael Casadevall
ubiquity (Ubuntu)
Medium
Michael Casadevall
Karmic
Medium
Michael Casadevall

Bug Description

ubiquity on dove currently has a partman-auto action which causes /boot partition to exist and be formatted as ext2, but unfortunately a separate check script is needed for the existence of this partition to be enforced by partman. This package needs to be created, and to be properly installed on live system.

STEPS TO REPRODUCE:
1. Start an armel+dove image
2. Run ubiquity to the partitioning screen
3. Create any partition layout with / not being ext2, and /boot not existing

EXPECTED BEHAVIOR:
1. ubiquity throws a warning that their is no /boot

tags: added: armel
Loïc Minier (lool) wrote :

Michael, could you look into this dove-specific package?

Thanks,

Subscribing ubuntu-release for feature freeze exception:

Justification for FFE:
partman-uboot is a armel+dove specific installer component required for proper behavior in the partitioner due to the requirements needed to bring up the system form the uboot bootloader.

Jonathan Riddell (jr) wrote :

I've accepted the package into universe. It'll need a MIR presumably.

Loïc Minier (lool) on 2009-10-16
affects: Ubuntu Karmic → partman-uboot (Ubuntu Karmic)
Changed in ubiquity (Ubuntu Karmic):
assignee: nobody → Michael Casadevall (mcasadevall)
importance: Undecided → Medium
milestone: none → ubuntu-9.10
status: New → Triaged
Steve Langasek (vorlon) wrote :

included in ubiquity 2.0.1; closing.

Changed in ubiquity (Ubuntu Karmic):
status: Triaged → Fix Released
tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers