exit with error if encryption is selected

Bug #985526 reported by Fabio Marconi on 2012-04-19
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
partman-target (Ubuntu)
Undecided
Unassigned

Bug Description

Hello
I started an installation of today's build from live session.
I select to encrypt my home
It propose to exit with an error or continue without guarantee. (ubi-usersetup exit with error...)

If I don't select to encrypt my home, it works.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: ubiquity 2.10.14
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic 3.2.14
Uname: Linux 3.2.0-23-generic x86_64
ApportVersion: 2.0.1-0ubuntu5
Architecture: amd64
CasperVersion: 1.315
Date: Thu Apr 19 11:59:02 2012
InstallCmdLine: noprompt cdrom-detect/try-usb=true file=/cdrom/preseed/ubuntu.seed boot=casper initrd=/casper/initrd.lz quiet splash -- maybe-ubiquity
LiveMediaBuild: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120419)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Fabio Marconi (fabiomarconi) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/985526

tags: added: iso-testing
Stéphane Graber (stgraber) wrote :

Is it happening reliably for you?

I just tried here in a VM with the same image, also installing in Italian and I can't reproduce the crash.

Are you installing from the CD or using a usb stick? A quick look at your syslog suggests you didn't use a usb stick but I'd prefer to be sure.

Colin Watson (cjwatson) on 2012-04-19
affects: ubiquity (Ubuntu) → partman-target (Ubuntu)
Changed in partman-target (Ubuntu):
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package partman-target - 77ubuntu2

---------------
partman-target (77ubuntu2) precise; urgency=low

  * Exit 0 at the end of finish.d/clear_partitions, so that partman-commit
    will carry on even if the final rmdir fails (which is a bug in itself,
    but shouldn't blow away the whole install; LP: #985526).
  * Use 'umount -l' in finish.d/clear_partitions, to work around an as yet
    unidentified race that keeps the filesystem busy (LP: #946663).
 -- Colin Watson <email address hidden> Thu, 19 Apr 2012 11:54:45 +0100

Changed in partman-target (Ubuntu):
status: Fix Committed → Fix Released
Fabio Marconi (fabiomarconi) wrote :

fix confirmed
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

tags: added: verification-done
EC120 (ec120) wrote :
Simon Butcher (sbutcher) wrote :

I had this issue in the 12.04 final, my /home partition is not-encrypted AFAIK, and i chose not to format my /dev/sda6 home partition. however in the installer, home was pre-selected for encryption in the options, and greyed out (had no choice but to continue).
Continuing the installation resulted in the above error.

bealer (robertbeal) wrote :

This is happening to me too. I've tried downloading the iso image again and used multiple usb keys, along with both unetbootin and Startup Disk Creator for making the bootable USB.

I am unable to select that I don't want my home directory encrypted, even when it's a new user I'm creating.

At current I can't install 12.04.

EC120 (ec120) wrote :

to add bit more info, I am doing a clean install of 12.04 (both 32 and 64 bit) on a single primary partition, formatted as ext4. I select to encrypt the home directory and then I get the screen mentioned above.

www.stooorage.com/show/1184/6048402_capture_26042012_164139.jpg

then I click [Continue anyway] button and installation seem to finish normally and everything works, so it is probably not broken but I don't know 100%.
The only thing I have unusual perhaps, is that I don't use swap partition on any of the computers. Not sure if that can have anything to do with the issue.

Barney (barneys) wrote :

Bug still present. Scenario as follows:
Clean install of 12.04 LTS (AMD64) via desktop installer on bootable USB key, created with Startup Disk Creator
Install to primary partition formatted as Ext4
Progress until user setup
Select encrypt home partition
Error ubi-usersetup crashed with exit error code...
Selecting <Cancel> returns to live desktop
Shutdown without issue

Fabio Marconi (fabiomarconi) wrote :

while your symptoms sound similar, you're likely experiencing an unrelated issue. Please file a new bug for it using the command 'ubuntu-bug xorg' (and a photo if any corruption is seen).

Fabio Marconi (fabiomarconi) wrote :

substitute xorg with partman-target
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Thanks Fabio. Will do.
Barney

On Mon 30 Apr 2012 08:56:07 BST, Fabio Marconi wrote:
> substitute xorg with partman-target
> ---
> Ubuntu Bug Squad volunteer triager
> http://wiki.ubuntu.com/BugSquad
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers