unable to complete Software RAID installation

Bug #202372 reported by Bill Smith on 2008-03-15
4
Affects Status Importance Assigned to Milestone
partman-target (Ubuntu)
High
Evan

Bug Description

I'm using the Hardy Alpha-6 Alternate CD to try to install a simple Software RAID mirror, same as I've done several times before in Ubuntu 7.04, 7.10 (as well as OpenSuSE 10.3). I create the 'physical disk for raid' partitions but then when I select 'Setup Software RAID' it gives the following error:

  Failed to remove conflicting files
  The installer needs to remove operating system files from the install target,
  but was unable to do so.

FYI - These are two known-good freshly-wiped hard drives.

If this really is a bug in the scripts it should be easy to recreate. I tried to create a 30 GB 'md0' with ext3, bootable, mounted as "/", and also a 10 GB 'md1' swap (I know, it's overkill).

P.S. I know that 7.04 and 7.10 both have problems with their GRUB scripts which prevents one from booting from only 1 disk in a mirror, and I'm hoping to do a fresh install of my main machine after Hardy is released. But this depends on Hardy having working GRUB scripts, which is what I was trying to test. I didn't expect to get stuck at the install...

Florent (florent-giard) wrote :

Exactly same bug with Hardy Alpha-6 AMD64 Alternate CD, but my raid configuration is more simple :

sda: sda1: 1GB /boot, sda2: 1BG swap , sda3: 80GB Raid
sdb: sdb1: 2GB not use, sdb2: 80GB Raid

'Setup Software RAID':

  Failed to remove conflicting files
  The installer needs to remove operating system files from the install target,
  but was unable to do so.

After this, i have done the install with ubuntu-7.10-alternate-amd64.iso with the same configuration and all is ok.

My sata controller is the nvidia nforce4 and all raid option in bios are disabled.

Ralph Janke (txwikinger) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage . I have classified this bug as a bug in ubiquity.

Evan (ev) on 2008-03-21
Changed in ubiquity:
assignee: nobody → evand
importance: Undecided → High
milestone: none → ubuntu-8.04
Evan (ev) wrote :

Could both of you please attach /var/log/syslog from such an install attempt after you see the "Failed to remove conflicting files" message? Please be sure to back up any important data before you do this.

Bill Smith (bsmith1051) wrote :

This bug appears to be fixed in the new Hardy beta! Unfortunately, I'm still having the same long-term problem with the drives not booting after a drive failure (and which is already reported by many people in bug 120375),
http://bugs.launchpad.net/ubuntu/+bug/120375

Steve Langasek (vorlon) wrote :

Thank you for taking the time to report this issue and help to improve Ubuntu.

Based on the last comment in this bug report, I am marking this bug as "fix released" since the issue reported seems to be resolved with 8.04 beta and beyond.

Changed in partman-target:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers