The installer needs to remove operating system files from the install target, but was unable to do so. The install cannot continue

Bug #186711 reported by Dave Wagner on 2008-01-28
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Wubi
Undecided
Unassigned
partman-target (Ubuntu)
High
Unassigned
Hardy
Undecided
Evan

Bug Description

Binary package hint: debian-installer

Boot method: Grub to HD-Media
Image version: http://cdimage.ubuntu.com/daily/current/hardy-alternate-i386.iso
Date: Monday January 28, 2008 ~12:00pm

Machine: White box
Partitions: I didn't think to get this while in the install environment, hope this will do.
Filesystem Type 1K-blocks Used Available Use% Mounted on
/dev/sdc1 ext3 9637912 2806560 6341776 31% /
varrun tmpfs 1037428 88 1037340 1% /var/run
varlock tmpfs 1037428 0 1037428 0% /var/lock
udev tmpfs 1037428 112 1037316 1% /dev
devshm tmpfs 1037428 0 1037428 0% /dev/shm
lrm tmpfs 1037428 34696 1002732 4% /lib/modules/2.6.22-14-generic/volatile
/dev/sda2 reiserfs 300044852 64690596 235354256 22% /home
/dev/sdb1 ext3 79150660 6392132 68737864 9% /media/arch
/dev/hdc2 ext3 480197164 124551020 355646144 26% /media/backup

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot: [O]
Detect network card: [O]
Configure network: [O]
Detect CD: [O]
Load installer modules: [O]
Detect hard drives: [O]
Partition hard drives: [E]
Install base system: [ ]
Clock/timezone setup: [ ]
User/password setup: [ ]
Install tasks: [ ]
Install boot loader: [ ]
Overall install: [ ]

Comments/Problems:

This appears to be the same bug reported for ubiquity #186147.

After setting up partitions I get the error "The installer needs to remove operating system files from the install target, but was unable to do so. The install cannot continue". I am able to go back and repartition and after some trial and error figured out that by not mounting any other partitions aside from swap and /, I am able to successfully get past this portion of the install process (more bugs to come though for other parts).

Dave Wagner (cptnwinky) wrote :
Dave Wagner (cptnwinky) wrote :
Dave Wagner (cptnwinky) wrote :
Dave Wagner (cptnwinky) wrote :
Dave Wagner (cptnwinky) wrote :
Colin Watson (cjwatson) wrote :

I can't quite see what's going on here. Evan? It might help to add a bit more logging on the failure paths ...

Changed in debian-installer:
assignee: nobody → evand
Colin Watson (cjwatson) on 2008-01-29
Changed in partman-target:
milestone: none → hardy-alpha-4
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package partman-target - 52ubuntu3

---------------
partman-target (52ubuntu3) hardy; urgency=low

  * Updated translations.
  * Rework clear_partitions to not try to remove active mountpoints (LP:
    #186711).

 -- Evan Dandrea <email address hidden> Wed, 30 Jan 2008 12:39:17 -0500

Changed in partman-target:
status: New → Fix Released
Stéphane Maniaci (stephh) wrote :

Is it fixed in the latest CD image ?

I get the same error with the current image (on 29/01/08).

Stéphane Maniaci (stephh) wrote :

And also on the 30th's desktop cd image :'( .

Stéphane Maniaci (stephh) wrote :

Ok, found how to see the version of packages on CD, fixed in the latest one. Sorry

Agostino Russo (ago) on 2008-01-31
Changed in wubi:
status: New → Fix Released
Sven Boden (svenboden) wrote :

I still get the problem on the hardy daily (i386) cd of 31/01/08... as in the test http://iso.qa.ubuntu.com/qatracker/result/1258/54

"I fill in all of the data of the installer, I manually partition.

After pressing the final install button, I get first "Removing conflicting operating system files" but this hangs for at least a couple of minutes. I then press skip on the dialog and I get "The installer needs to remove operating system files from the install target, but was unable to do so. The install cannot continue.".

This was on a dual boot system, and if I reboot I get a grub 15 error, and the windows boot partition is completely erased."

Changed in partman-target:
status: Fix Released → New
Colin Watson (cjwatson) wrote :

This was probably a separate bug. There have been several fixes since then - changelog excerpts follow:

partman-target (54ubuntu1) hardy; urgency=low

  [ Colin Watson ]
[...]
  * Don't clear partitions marked "do not use" (LP: #198106).
[...]

 -- Colin Watson <email address hidden> Mon, 03 Mar 2008 22:49:56 +0000

partman-target (52ubuntu6) hardy; urgency=low

  * Fixed major bug in 60clear_partitions and re-enabled it.

 -- Evan Dandrea <email address hidden> Wed, 20 Feb 2008 02:37:59 -0500

partman-target (52ubuntu4) hardy; urgency=low

  * Temporarily disable clear_partitions. It's removing directories on
    partitions that it should not be.

 -- Evan Dandrea <email address hidden> Fri, 01 Feb 2008 07:22:23 -0500

If you can still reproduce this with current daily builds, then please file a new bug and attach /var/log/syslog and /var/log/partman to it. Sorry for the inconvenience.

Changed in partman-target:
status: New → Fix Released
Herbert Post (roberine) wrote :

I also have this problem. It doesn't matter if I use Hardy 8.04.1 (AMD64) or Ibex alpha 5 (AMD64)
My system is setup with /, swap, /home, /media/Data and /media/Video all with JFS filesystem.
I recently did a complete new install with 8.04.1 using just JFS. Now I am trying to install Ibex a5
and my plan was to only format the / partition. Resulting in the above error message. If I now try to
install 8.04.1 I get the same error. With EXT3 I've never seen this problem.
I'm now installing Ibex A5 with just the / and SWAP enabled and this seems to work.

Derek7 (enrico-vittorini) wrote :

Trying to install kubuntu intrepid the installer stop on "Removing the conflicting.... etc". And stock on it!

After restarting Grub is erased... I hope the windows partition wasn't destroyed!!! fuck Kubuntu!

As a reaction to the previous 2 comments (#13 and #14), and as I have been personally frustrated myself with this error related to *buntu's installer unable to reuse an existing JFS /home partition, here's my hint on what it *should* usually do the trick when this happens.

1. Boot the LiveCD of your preferred flavor of *buntu/Mint, or any other LiveCD who has jfsutils -- you'll need either "fsck.jfs" or "jfs_fsck" (it's the same thing).

2. Make sure the JFS partition is *not* mounted.

3. Run whatever of the following two works -- assuming /dev/sda3 is the JFS home partition:
jfs_fsck /dev/sda3
or:
fsck.jfs /dev/sda3

4. Now try to mount the partition -- make sure the mounting point exist or replace it accordingly:
mount -t jfs /dev/sda3 /mnt/sda3

If you can cd to the mounted partition and the contents is fine, Ubuquity should be able to install and make use of it (you can umount it back).

Oh, prefixing with "sudo" might be needed in order to fsck, OK.

I've just been through this bug and it also wipes out my Windows XP partition (curiously it left one part of the Windows directory).

Clearly this bug is not fixed and is very damaging. Could it be reopened please?

Colin Watson (cjwatson) wrote :

I've reopened the bug, but it's unfortunate that none of the people who encountered it thought to attach log files to this bug. We may well need some before we can proceed.

Changed in partman-target:
importance: Undecided → High
milestone: hardy-alpha-4 → none
status: Fix Released → Incomplete
Colin Watson (cjwatson) wrote :

... and indeed I said in comment 12:

  "If you can still reproduce this with current daily builds, then please file a new bug and attach /var/log/syslog and /var/log/partman to it. Sorry for the inconvenience."

I'll waive the "file a new bug" bit for now, but do that in future - it really is easier for us to keep track of, which results in better results for all of you!

trylik (marek-nasionka) wrote :

i can confirm it too, i tried to install ubuntu 8.04 on my HDD after grub crashed

what do you need?

Evan (ev) on 2011-02-08
Changed in partman-target (Ubuntu):
assignee: Evan Dandrea (ev) → nobody
Gon Kyouka (gonkyouka) wrote :

happens in 12.04 as well

Brian Murray (brian-murray) wrote :

Gon please follow the instructions in comment #19 and file a new bug report and let us know what it is.

xor (xor) wrote :

Happens with 12.04 and XFS for me.

teledyn (garym-teledyn) wrote :

happened just now on trying to repair a 13.10 installation

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers