Ubuntu

Installer cannot use existent file system as root

Reported by netAction on 2007-12-07
26
Affects Status Importance Assigned to Milestone
partman-target (Ubuntu)
Medium
Evan Dandrea
ubiquity (Baltix)
Undecided
Unassigned

Bug Description

Binary package hint: ubiquity

I wanted to keep my ext3 file system with gigs of photos and other stuff. So I deleted everything of the old Ubuntu expect of my data.
But the installer of Gutsy refused installing on that partition. I had to make the file system smaller with gparted, build a new partition, install Ubuntu on that, move the data on the new partition, delete the old one and resize the new to full size. That sucks!

Evan Dandrea (ev) wrote :

This is targeted for Ubuntu 8.04 as the following specification:
https://blueprints.launchpad.net/ubuntu/+spec/ubiquity-preserve-home

Thanks!

Changed in ubiquity:
assignee: nobody → evand
importance: Undecided → Medium
status: New → Confirmed
Colin Watson (cjwatson) wrote :

partman-target (52ubuntu2) hardy; urgency=low

  [ Colin Watson ]
  * Set Vcs-Bzr for Ubuntu.

  [ Evan Dandrea ]
  * Added support for installing without reformatting existing partitions for
    the ubiquity-preserve-home specification (LP: #174619):
    - Remove critical system files from the existing filesystem before
      installing.
    - Preserve the UID and GID of the initial user, if possible. Requires a
      patch to user-setup.

 -- Evan Dandrea <email address hidden> Tue, 22 Jan 2008 16:06:55 +0000

Changed in ubiquity:
status: Confirmed → Fix Released
Benjamin Kay (benkay) wrote :

netAction, this bug was still open in ubiquity. Since the problem seems to have been fixed, I've closed it. Please reopen the bug if you feel otherwise.

Changed in ubiquity (Baltix):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers