RAID catch-22 on power5

Bug #84228 reported by Nick Moffitt on 2007-02-09
36
Affects Status Importance Assigned to Milestone
partman-md (Ubuntu)
Undecided
Colin Watson

Bug Description

Binary package hint: partman-md

On a power5 system, I went partway through a 20070201.1 alternate install and built RAID on the drives. When I went back to the install with Herd 3 after experiencing problems with the daily, I found myself in a catch-22 in partman-md.

I was unable to use the md device, unable to remove it (although it prompted me to remove an raid5 volume that appeared to be the one I made earlier) as it complained of /dev/md/0 not existing. I was of course unable to make a new raid volume as it could not find any unused raid partitions.

What's worse, the retry/cancel cycle would silently die when I tried to cancel, leaving me with a progress bar at 47% and no interface to continue.

I tried deleting and recreating the partitions, rebooting in between, but had no luck.

Colin Watson (cjwatson) wrote :

This mostly fixes it. There's another long-established problem that still arises if you use LVM on RAID - you get an error message about not being able to inform the kernel of changes to /dev/md0p1 - but you can safely select "Ignore" at that error message and continue.

partman-md (30ubuntu1) feisty; urgency=low

  * init.d/md-devices: Handle /dev/md* as well as /dev/md/* (LP: #84228).
  * Set Maintainer to <email address hidden>.

 -- Colin Watson <email address hidden> Tue, 27 Mar 2007 13:41:30 +0100

Changed in partman-md:
assignee: nobody → kamion
status: Unconfirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions