saucy server lvm installations fail to boot

Bug #1208401 reported by Para Siva
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
partman-lvm (Ubuntu)
Fix Released
Undecided
Dimitri John Ledkov

Bug Description

The lvm installations of amd64 and i386 images fail to boot and drop to initramfs shell with the following error messages with the images of 20130803 onwords:

Alert: /dev/mapper/utah--12256--saucy--server--i386--vg--root does not exist. Dropping to shell.

When compared to the earlier good images, i noticed libdevmapper-event is not getting installed in the failed ones as part of lvm2 dependency. Install log is attached from a failed installation.

Steps to reproduce:
1. Install utah using
   sudo apt-add-repository -y ppa:utah/stable
   sudo apt-get update
   sudo apt-get install utah

2. Now run
sudo -u utah -i run_utah_tests.py -i /path/to/saucy-server-amd64.iso -p lp:ubuntu-test-cases/server/preseeds/lvm.preseed lp:ubuntu-test-cases/server/runlists/lvm.run -x /etc/utah/bridged-network-vm.xml

3. It could be noted that the vm will fail to boot after the installation.

The impacted smoke tests are:
https://jenkins.qa.ubuntu.com/view/Saucy/view/Smoke%20Testing/job/saucy-server-amd64-smoke-lvm/91/
https://jenkins.qa.ubuntu.com/view/Saucy/view/Smoke%20Testing/job/saucy-server-amd64-smoke-multi-lvm/91/
https://jenkins.qa.ubuntu.com/view/Saucy/view/Smoke%20Testing/job/saucy-server-i386-smoke-lvm/89/
https://jenkins.qa.ubuntu.com/view/Saucy/view/Smoke%20Testing/job/saucy-server-i386-smoke-multi-lvm/87/

Revision history for this message
Para Siva (psivaa) wrote :
Revision history for this message
Glenn Aaldering (glennaaldering) wrote :

Thanks for this bug report.

I can confirm that the lvm installation of saucy64 can be fixed by booting a rescue cd and installing lvm2/libdevmapper-event1.02.1 by hand.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lvm2 (Ubuntu):
status: New → Confirmed
Revision history for this message
Andy Whitcroft (apw) wrote :

This is very confusing because lvm2 directly depends on that library. So if you have lvm2 installed you really should have libdevmapper-event1.02.1 installed:

    $ apt-cache show lvm2 | grep Depends
    Depends: libc6 (>= 2.14), libdevmapper-event1.02.1 (>= 2:1.02.74), libdevmapper1.02.1 (>= 2:1.02.77),
       libreadline5 (>= 5.2), libudev1 (>= 183), lsb-base, dmsetup (>> 2:1.02.47), initscripts (>= 2.88dsf-13.3), watershed (>= 2)

Can we get the installer logs from this install please.

Revision history for this message
Andy Whitcroft (apw) wrote :

After much debugging we have determined that this is due to lack of executable bits on the partman-lvm finish.d hook. Fix uploaded to debian.

affects: lvm2 (Ubuntu) → partman-lvm (Ubuntu)
Revision history for this message
Dimitri John Ledkov (xnox) wrote :

partman-lvm 86 is uploaded in debian, synced in debian and present on the 20130808 server image. Can you please retest, and let us know if it fixes the issue?

Changed in partman-lvm (Ubuntu):
assignee: nobody → Dmitrijs Ledkovs (xnox)
Revision history for this message
Para Siva (psivaa) wrote :

20130808 images do not have this issue, the installations succeed and the tests pass. Thanks for the fix.

Changed in partman-lvm (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers