preseeded LVM installation stops with question "partman/confirm_nooverwrite" while it is preseeded to true

Bug #1025580 reported by Jean-Baptiste Lallement
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
partman-lvm (Ubuntu)
Fix Released
Critical
Dimitri John Ledkov

Bug Description

Quantal Server and Alternate automated LVM installations [1] failed with:
Jul 17 09:00:51 debconf: --> METAGET partman/text/confirm_partitem_header description
Jul 17 09:00:51 debconf: <-- 0 The partition tables of the following devices are changed:
Jul 17 09:00:51 debconf: --> SUBST partman/confirm_nooverwrite ITEMS The partition tables of the following devices are changed: Virtual disk 1 (vda)
Jul 17 09:00:51 debconf: Adding [ITEMS] -> [The partition tables of the following devices are changed: Virtual disk 1 (vda)]
Jul 17 09:00:51 debconf: <-- 0
Jul 17 09:00:51 debconf: --> CAPB align
Jul 17 09:00:51 debconf: <-- 0 multiselect backup progresscancel align escape plugin-terminal plugin-detect-keyboard
Jul 17 09:00:51 debconf: --> INPUT critical partman/confirm_nooverwrite
Jul 17 09:00:51 debconf: <-- 0 question will be asked
Jul 17 09:00:51 debconf: --> GO

Tests start failing on 20120716 for alternate and 20120717 for server. Preseed didn't change.

Link to the test:
https://jenkins.qa.ubuntu.com/view/Quantal/view/ISO%20Testing%20Dashboard/job/quantal-alternate-amd64_lvm/54/
https://jenkins.qa.ubuntu.com/view/Quantal/view/ISO%20Testing%20Dashboard/job/quantal-alternate-i386_lvm/54/
https://jenkins.qa.ubuntu.com/view/Quantal/view/ISO%20Testing%20Dashboard/job/quantal-server-i386_lvm/51/
https://jenkins.qa.ubuntu.com/view/Quantal/view/ISO%20Testing%20Dashboard/job/quantal-server-i386_multi-lvm/51/

Revision history for this message
Jean-Baptiste Lallement (jibel) wrote :
Revision history for this message
Jean-Baptiste Lallement (jibel) wrote :
Revision history for this message
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1025580

tags: added: iso-testing
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in partman-lvm (Ubuntu):
status: New → Confirmed
description: updated
Changed in partman-lvm (Ubuntu):
assignee: nobody → Dmitrijs Ledkovs (dmitrij.ledkov)
importance: Undecided → Critical
status: Confirmed → In Progress
tags: removed: rls-q-incoming
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package partman-lvm - 79ubuntu2

---------------
partman-lvm (79ubuntu2) quantal; urgency=low

  * apt-installed exits with error code 1, if run during finish.d. Hence
    adding "|| true", similar to all the other partman-$fs, to prevent
    never ending "Setting up partitioning..." loop. (LP: #1025580)
 -- Dmitrijs Ledkovs <email address hidden> Tue, 17 Jul 2012 15:33:25 +0100

Changed in partman-lvm (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers