Installer fails to find a target when using authentication

Bug #568312 reported by Ara Pulido on 2010-04-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
partman-iscsi (Ubuntu)
High
Colin Watson
Lucid
High
Colin Watson

Bug Description

Binary package hint: partman-iscsi

Binary package hint: partman-iscsi

Using Lucid RC candidate 20100419.1

This is my ietd.conf in the target:

Target iqn.2010-01.com.example:storage.lun1
     IncomingUser ara ara
     OutgoingUser ara ara
     Lun 0 Path=/storage/lun1.img,Type=fileio
     Alias LUN1

If I install open-iscsi in the target, I confirm that I can log in correctly providing those authentication parameters.

When installing Ubuntu server in the initiator, however, when providing the login information, it returns an error about "no targets were found on 192.168.101.100". Bug 567196 prevents me for going any further.

I have looked at the logs, and no useful information is found. I will attach a screenshot of the tail of the log (syslog)

Ara Pulido (ara) wrote :
Ara Pulido (ara) wrote :

Unauthenticated installation, with the same configuration, worked fine.

tags: added: iso-testing
Colin Watson (cjwatson) on 2010-04-23
Changed in partman-iscsi (Ubuntu):
status: New → Triaged
importance: Undecided → High
assignee: nobody → Colin Watson (cjwatson)
Changed in partman-iscsi (Ubuntu Lucid):
milestone: none → ubuntu-10.04
Colin Watson (cjwatson) wrote :

When the installation reaches the hostname prompt, could you switch to tty2, 'nano /lib/partman/lib/iscsi-base.sh', put 'set -x' on the second line, save and exit, and then continue the installation attempt? Then attach /var/log/syslog again once it fails.

Ideally, do this with partman-iscsi 14 which with any luck will be in the archive tomorrow once somebody's reviewed it, but doing it with the current version 13 is fine too.

My own attempts to replicate this are being thoroughly confused by network configuration oddities, and I'd like a log from a more known-good setup.

Changed in partman-iscsi (Ubuntu Lucid):
milestone: ubuntu-10.04 → none
status: Triaged → Incomplete
milestone: none → ubuntu-10.04
Ara Pulido (ara) wrote :

Hello Colin,

Please, find the log you required. I got this with version 13, as no new ISOs were built since Friday.

If you need anything else, please, feel free to ask.

Changed in partman-iscsi (Ubuntu Lucid):
status: Incomplete → Triaged
Ara Pulido (ara) wrote :

This bug is invalid. My KVMs network configuration was changed in the middle of my testing.
Configuring again the network solved the issue. I found some other minor issues related to authentication that I will report as separated bug reports.

Changed in partman-iscsi (Ubuntu Lucid):
status: Triaged → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers