partitioning step doesn't have "discard" as a selectable mount option

Bug #978032 reported by Alan Pope 🍺🐧🐱 🦄 on 2012-04-10
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
partman-basicfilesystems (Ubuntu)
Wishlist
Colin Watson
Precise
Wishlist
Colin Watson
partman-btrfs (Ubuntu)
Wishlist
Colin Watson
Precise
Wishlist
Colin Watson
partman-ext3 (Debian)
Fix Released
Unknown
partman-ext3 (Ubuntu)
Wishlist
Colin Watson
Precise
Wishlist
Colin Watson
ubiquity (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned

Bug Description

SRU justification:
[Impact] The installer does not support selecting some commonly-used mount options for common file systems. While this is technically a feature, the fix consists of adding lines to a plain text file, and it's cumbersome for users to work around otherwise; I'd like to make the trivial changes to precise to add these.
[Test case] Confirm that the installer permits selecting "discard" for ext4, fat16, fat32, and btrfs. (Use apt-setup/proposed=true while this change is still in precise-proposed.)
[Regression potential] Confirming that installation otherwise still works should be sufficient.

Original report follows:
Doing a clean install of Ubuntu server on a machine with an SSD. I am led to believe that in my fstab I should add the mount option "discard" to enable trim support. During the partitioning step I manually configured my partitions and selected "mount options" but 'discard' was not listed. I will now have to manually edit my fstab to add this in. Would it not be prudent to have this as a selectable option in d-i for server/alternate images?

Changed in debian-installer (Ubuntu):
importance: Undecided → Low
Colin Watson (cjwatson) wrote :

Kernel support seems to be:

fs/btrfs/super.c: {Opt_discard, "discard"},
fs/ext4/super.c: {Opt_discard, "discard"},
fs/fat/inode.c: {Opt_discard, "discard"},
fs/gfs2/super.c: {Opt_discard, "discard"},
fs/nilfs2/super.c: {Opt_discard, "discard"},

affects: debian-installer (Ubuntu) → partman-ext3 (Ubuntu)
Changed in partman-ext3 (Ubuntu):
status: New → Triaged
importance: Low → Wishlist
Changed in partman-btrfs (Ubuntu):
status: New → Triaged
importance: Undecided → Wishlist
Changed in partman-basicfilesystems (Ubuntu):
status: New → Triaged
importance: Undecided → Wishlist
Stephen Gran (sgran) wrote :

This is addressed (I believe) in debian bug #722598 and upload 79. Can you pull and test?

Colin Watson (cjwatson) on 2013-10-01
Changed in partman-ext3 (Ubuntu):
status: Triaged → Fix Committed
Colin Watson (cjwatson) on 2013-10-01
Changed in partman-basicfilesystems (Ubuntu Precise):
status: New → Triaged
importance: Undecided → Wishlist
Changed in partman-btrfs (Ubuntu Precise):
status: New → Triaged
importance: Undecided → Wishlist
Changed in partman-ext3 (Ubuntu Precise):
status: New → Triaged
importance: Undecided → Wishlist
Changed in partman-ext3 (Debian):
status: Unknown → Fix Released
Colin Watson (cjwatson) on 2013-10-01
Changed in partman-basicfilesystems (Ubuntu):
status: Triaged → Fix Committed
Changed in partman-btrfs (Ubuntu):
status: Triaged → Fix Committed
Changed in partman-basicfilesystems (Ubuntu):
assignee: nobody → Colin Watson (cjwatson)
Changed in partman-btrfs (Ubuntu):
assignee: nobody → Colin Watson (cjwatson)
Changed in partman-ext3 (Ubuntu):
assignee: nobody → Colin Watson (cjwatson)
Changed in partman-ext3 (Ubuntu Precise):
status: Triaged → In Progress
assignee: nobody → Colin Watson (cjwatson)
description: updated
Colin Watson (cjwatson) on 2013-10-01
Changed in partman-basicfilesystems (Ubuntu Precise):
status: Triaged → In Progress
assignee: nobody → Colin Watson (cjwatson)
milestone: none → ubuntu-12.04.4
Changed in partman-ext3 (Ubuntu Precise):
milestone: none → ubuntu-12.04.4
Changed in partman-btrfs (Ubuntu Precise):
milestone: none → ubuntu-12.04.4
status: Triaged → In Progress
assignee: nobody → Colin Watson (cjwatson)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package partman-basicfilesystems - 84ubuntu1

---------------
partman-basicfilesystems (84ubuntu1) saucy; urgency=low

  * Resynchronise with Debian. Remaining changes:
    - If partman/automount is preseeded to true, automatically mount
      partitions with usefully-mountable filesystems on subdirectories of
      /media.
    - Add minimal support for NTFS partitions using ntfs-3g.
    - Mount FAT filesystems at boot (fstab pass 1).
    - Mount FAT (other than EFI System Partitions) and NTFS with
      umask=007,gid=46 (static group plugdev).
    - When formatting over the top of an existing swap partition, preserve
      its UUID to avoid leaving systems that use UUIDs in /etc/fstab without
      swap.
    - mount.d/basic: Close mount's fd 3 so that it doesn't inherit a debconf
      file descriptor, to prevent log-output hanging when ntfs-3g is in use.
    - Special case loopmounted filesystems as it's safer to format the
      underlying file, not the device.
    - Allow armel/omap to use FAT for /boot, since the problems with it can
      be worked around while it's difficult to use anything else given uboot
      limitations.
    - Stop using libparted to format swap partitions.
    - Disable existing swap partitions before formatting them.
    - Use mkdosfs to create FAT filesystems, since libparted cannot handle
      doing that on non-512-sector disks.
    - Always use mkfs.ext2 to create ext2 filesystems, since libparted's
      ext2 code is deprecated and can't handle large sector sizes.

partman-basicfilesystems (84) unstable; urgency=low

  * Add nodiratime option for ext2, and noatime, nodiratime, relatime, and
    discard options for fat16 and fat32 (see #722598; LP: #978032).

  [ Updated translations ]
  * Turkish (tr.po) by Mert Dirik

partman-basicfilesystems (83) unstable; urgency=low

  [ Updated translations ]
  * Tajik (tg.po) by Victor Ibragimov

partman-basicfilesystems (82) unstable; urgency=low

  [ Updated translations ]
  * Arabic (ar.po) by Ossama Khayat
  * Czech (cs.po) by Miroslav Kure
  * German (de.po) by Holger Wansing
  * Italian (it.po) by Milo Casagrande
  * Russian (ru.po) by Yuri Kozlov
  * Tajik (tg.po) by Victor Ibragimov

partman-basicfilesystems (81) unstable; urgency=low

  [ Updated translations ]
  * Bulgarian (bg.po) by Damyan Ivanov
  * Japanese (ja.po) by Kenshi Muto
  * Bokmål, Norwegian (nb.po) by Hans Fredrik Nordhaug
  * Polish (pl.po) by Michał Kułach
  * Tajik (tg.po)
  * Uyghur (ug.po) by Abduqadir Abliz

partman-basicfilesystems (80) unstable; urgency=low

  [ Milan Kupcevic ]
  * Warn if bootable partition is not ext2 on Pegasos machines. Closes: #717511

  [ Updated translations ]
  * French (fr.po) by Christian Perrier
  * Slovak (sk.po) by Ivan Masár
  * Thai (th.po) by Theppitak Karoonboonyanan

partman-basicfilesystems (79) unstable; urgency=low

  [ Dmitrijs Ledkovs ]
  * Set debian source format to '3.0 (native)'.
  * Bump debhelper compat level to 9.
  * Set Vcs-* to canonical format.
 -- Colin Watson <email address hidden> Tue, 01 Oct 2013 10:29:00 +0100

Changed in partman-basicfilesystems (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package partman-ext3 - 79ubuntu1

---------------
partman-ext3 (79ubuntu1) saucy; urgency=low

  * Resynchronise with Debian (LP: #978032). Remaining changes:
    - Special case loopmounted filesystems as it's safer to format the
      underlying file, not the device.
    - Add preseedable partman-ext3/lazy_itable_init question, which if true
      runs mkfs.ext* with '-E lazy_itable_init', greatly speeding up mkfs on
      large drives. This defaults to false since it is currently unsafe for
      use on areas of disk that previously contained a filesystem.

partman-ext3 (79) unstable; urgency=low

  [ Stephen Gran ]
  * Allow "discard" and "nodiratime" options for ext4. Closes: #722598

partman-ext3 (78) unstable; urgency=low

  [ Updated translations ]
  * Tajik (tg.po) by Victor Ibragimov
 -- Colin Watson <email address hidden> Tue, 01 Oct 2013 09:59:23 +0100

Changed in partman-ext3 (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package partman-btrfs - 14ubuntu1

---------------
partman-btrfs (14ubuntu1) saucy; urgency=low

  * Resynchronise with Debian. Remaining changes:
    - Add support for creating and mounting btrfs subvolumes corresponding
      to / and /home, in case of a btrfs rootfs.

partman-btrfs (14) unstable; urgency=low

  * Add nodiratime and discard mount options (see #722598; LP: #978032).

partman-btrfs (13) unstable; urgency=low

  [ Updated translations ]
  * Tajik (tg.po) by Victor Ibragimov
 -- Colin Watson <email address hidden> Tue, 01 Oct 2013 10:44:56 +0100

Changed in partman-btrfs (Ubuntu):
status: Fix Committed → Fix Released

Hello Alan, or anyone else affected,

Accepted partman-ext3 into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/partman-ext3/67ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in partman-ext3 (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Changed in partman-btrfs (Ubuntu Precise):
status: In Progress → Fix Committed
Stéphane Graber (stgraber) wrote :

Hello Alan, or anyone else affected,

Accepted partman-btrfs into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/partman-btrfs/8ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in partman-basicfilesystems (Ubuntu Precise):
status: In Progress → Fix Committed
Stéphane Graber (stgraber) wrote :

Hello Alan, or anyone else affected,

Accepted partman-basicfilesystems into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/partman-basicfilesystems/71ubuntu3.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Chris Halse Rogers (raof) wrote :

This is blocking the release of the fix for https://bugs.launchpad.net/ubuntu/+source/partman-basicfilesystems/+bug/1215458 - if anyone is interested in this bug, please test that the package in precise-proposed resolves it.

Colin Watson (cjwatson) wrote :

This failed verification for me earlier today: the debconf templates are missing so no mount options at all are selectable for the affected filesystem types. As soon as git.debian.org comes back I'll check whether Debian has fixed this and amend the package in precise-proposed accordingly.

tags: added: verification-failed
removed: verification-needed
Changed in ubiquity (Ubuntu):
status: New → Fix Released
Changed in ubiquity (Ubuntu Precise):
status: New → In Progress
Stéphane Graber (stgraber) wrote :

Hello Alan, or anyone else affected,

Accepted partman-basicfilesystems into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/partman-basicfilesystems/71ubuntu3.4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: removed: verification-failed
tags: added: verification-needed
Colin Watson (cjwatson) wrote :

Hello Alan, or anyone else affected,

Accepted ubiquity into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/ubiquity/2.10.28 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ubiquity (Ubuntu Precise):
status: In Progress → Fix Committed
Dimitri John Ledkov (xnox) wrote :

ubiquity - automated installations all passed, manual smoke-test also works.

Dimitri John Ledkov (xnox) wrote :

verified that discard option is available in partman and selected it
completed server install.
installed system has discard mount option specified in /etc/fstab, and has been mounted with that option as verified in /proc/self/mountinfo

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package partman-btrfs - 8ubuntu1.1

---------------
partman-btrfs (8ubuntu1.1) precise; urgency=low

  * Add nodiratime and discard mount options (see #722598; LP: #978032).
 -- Colin Watson <email address hidden> Tue, 01 Oct 2013 10:57:25 +0100

Changed in partman-btrfs (Ubuntu Precise):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package partman-ext3 - 67ubuntu1.1

---------------
partman-ext3 (67ubuntu1.1) precise; urgency=low

  * Backport from Debian (Stephen Gran):
    - Allow "discard" and "nodiratime" options for ext4 (closes: #722598,
      LP: #978032).
 -- Colin Watson <email address hidden> Tue, 01 Oct 2013 10:49:22 +0100

Changed in partman-ext3 (Ubuntu Precise):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package partman-basicfilesystems - 71ubuntu3.4

---------------
partman-basicfilesystems (71ubuntu3.4) precise; urgency=low

  * Make nodiratime and discard mount options translatable (closes: #725371,
    LP: #978032).

partman-basicfilesystems (71ubuntu3.3) precise; urgency=low

  * Add nodiratime option for ext2, and noatime, nodiratime, relatime, and
    discard options for fat16 and fat32 (see #722598; LP: #978032).

partman-basicfilesystems (71ubuntu3.2) precise; urgency=low

  * Always use mkfs.ext2 to create ext2 filesystems, since libparted's ext2
    code is deprecated and can't handle large sector sizes (LP: #1215458).
 -- Colin Watson <email address hidden> Fri, 29 Nov 2013 12:08:27 +0000

Changed in partman-basicfilesystems (Ubuntu Precise):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.10.28

---------------
ubiquity (2.10.28) precise; urgency=low

  * Automatic update of included source packages: partman-
    basicfilesystems 71ubuntu3.4. (LP: #978032)

ubiquity (2.10.27) precise; urgency=low

  * Automatic update of included source packages: netcfg 1.68ubuntu14.1
    (LP: #901700), partman-auto 101ubuntu2.2 (LP: #1197766, #1065281),
    partman-base 153ubuntu6 (LP: #1065281), partman-basicfilesystems
    71ubuntu3.3 (LP: #978032, #1215458), partman-btrfs 8ubuntu1.1 (LP:
    #978032), partman-efi 25ubuntu1.2 (LP: #1065281), partman-ext3
    67ubuntu1.1 (LP: #978032).
 -- Dmitrijs Ledkovs <email address hidden> Tue, 03 Dec 2013 18:04:05 +0000

Changed in ubiquity (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.