Ubiquity pops out a warning message from partman-partitioning on UEFI BIOS when there is a EFI system partition existed.

Bug #972122 reported by Shih-Yuan Lee on 2012-04-03
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
partman-efi (Ubuntu)
Medium
Unassigned

Bug Description

Reproduce Steps:
1. Downloading ubuntu-12.04-beta2-desktop-amd64.iso and creating USB stick from it.
2. Using USB stick to install Ubuntu 12.04.
3. Manually creating EFI system partition (/dev/sda1) and Ubuntu partition (/dev/sda2) during the installation on the PC with UEFI BIOS.
4. Using USB stick to install another Ubuntu 12.04 in different partition.
5. Manually creating Ubuntu partition (/dev/sda3) during the installation on the PC with UEFI BIOS.
6. Then it pops up this warning message.

Shih-Yuan Lee (fourdollars) wrote :
Changed in partman-partitioning (Ubuntu):
importance: Undecided → Medium
Changed in partman-partitioning (Ubuntu):
status: New → Confirmed
Shih-Yuan Lee (fourdollars) wrote :

The message is from partman-partitioning/no_bootable_gpt_efi of lp:~ubuntu-core-dev/partman-partitioning/ubuntu.
It seems relative to http://bazaar.launchpad.net/~ubuntu-core-dev/partman-partitioning/ubuntu/revision/913 .

Shih-Yuan Lee (fourdollars) wrote :

This seems to be a regression of Bug #855871.

description: updated
Shih-Yuan Lee (fourdollars) wrote :
Shih-Yuan Lee (fourdollars) wrote :
Shih-Yuan Lee (fourdollars) wrote :

The attachment "ignore_no_bootable_gpt_check.diff" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Colin Watson (cjwatson) on 2012-04-11
tags: added: regression-release
Colin Watson (cjwatson) wrote :

I can see what you're trying to do with this patch, but I think it's a workaround for the real problem, which is that the EFI partition isn't being detected. I'd prefer to fix that instead. Doing so would probably also fix bug 900245.

In the case of GPT partition tables, we can reliably detect existing EFI System Partitions using something like this:

  [ "$(blkid -o value -s PART_ENTRY_TYPE "$path")" = c12a7328-f81f-11d2-ba4b-00a0c93ec93b ]

affects: partman-partitioning (Ubuntu) → partman-efi (Ubuntu)
Changed in partman-efi (Ubuntu):
status: Confirmed → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package partman-efi - 25ubuntu1

---------------
partman-efi (25ubuntu1) precise; urgency=low

  * Resynchronise with Debian. Remaining changes:
    - Automatically use existing EFI system partitions on Intel Macs as EFI
      boot partitions.
    - Create fat32 EFI partitions with the name "EFI System Partition" by
      default on Intel Macs.
    - choose_method/efi/do_option: Make sure no mountpoint is set.
    - Remove efi-modules dependency; it seems to be built into Ubuntu
      kernels now.
    - Require partman-base >= 129 to support a null value for the name.
    - Automatically mount the first method=efi filesystem we see on
      /boot/efi.
    - On x86 architectures, create EFI system partitions using FAT32 rather
      than FAT16, and require newly-created ones to have a minimum size of
      34091008 bytes.
    - Never format EFI system partitions that already contain a filesystem.
  * Detect existing EFI system partitions more reliably on GPT partition
    tables (LP: #972122, #900245).

partman-efi (25) unstable; urgency=low

  [ Updated translations ]
  * Asturian (ast.po) by Mikel González
  * Bulgarian (bg.po) by Damyan Ivanov
  * German (de.po) by Holger Wansing
  * Dzongkha (dz.po) by Jurmey Rabgay
  * Estonian (et.po) by Mattias Põldaru
  * Hebrew (he.po) by Lior Kaplan
  * Hindi (hi.po) by Kumar Appaiah
  * Indonesian (id.po) by Mahyuddin Susanto
  * Icelandic (is.po) by Sveinn í Felli
  * Italian (it.po) by Milo Casagrande
  * Kannada (kn.po) by vignesh prabhu
  * Macedonian (mk.po) by Arangel Angov
  * Polish (pl.po) by Marcin Owsiany
  * Romanian (ro.po) by Ioan Eugen Stan
  * Sinhala (si.po)
  * Ukrainian (uk.po) by Borys Yanovych
  * Simplified Chinese (zh_CN.po) by YunQiang Su
 -- Colin Watson <email address hidden> Wed, 11 Apr 2012 15:06:07 +0100

Changed in partman-efi (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers