[Lubuntu] Having zram support means that encrypted LVM installs don't work

Bug #1759732 reported by Simon Quigley on 2018-03-29
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
partman-crypto (Ubuntu)
Status tracked in Bionic
Bionic
Critical
Steve Langasek

Bug Description

Lubuntu enables zram support on our live images. Currently, zram is caught by the unsafe swap detection performed by this package (or similar). This is causing Encrypted LVM installs to fail. Unmounting all zram mount points result in a successful install.

Dimitri John Ledkov (xnox) wrote :

I agree. I think it is sane for partman-auto-crypto to unmount zram or skip the checks for it.

Is zram still in use, in the installed systems too? Does it affect encryption at rest? (e.g. does zram memory remain unencrypted upon hybernate?)

tags: added: bionic
removed: rls-bb-incoming
tags: added: id-5abd10a030762b57e1db728a
Simon Quigley (tsimonq2) wrote :

> I agree. I think it is sane for partman-auto-crypto to unmount zram or skip the checks for it.

I remember briefly looking into this and seeing a conditional with one exception in there so far, so adding this might be trivial. That's probably the solution here.

> Is zram still in use, in the installed systems too?

No, just on the live system.

> Does it affect encryption at rest? (e.g. does zram memory remain unencrypted upon hybernate?)

No, because it isn't in the default install (and the live image is not encrypted).

Simon Quigley (tsimonq2) on 2018-04-04
affects: partman-auto-crypto (Ubuntu Bionic) → partman-crypto (Ubuntu Bionic)
Simon Quigley (tsimonq2) wrote :
Changed in partman-crypto (Ubuntu Bionic):
milestone: ubuntu-18.03 → none
no longer affects: partman-crypto (Ubuntu Bionic)
Changed in partman-crypto (Ubuntu):
milestone: none → later
Simon Quigley (tsimonq2) wrote :

Actually, Steve has a patch.

Changed in partman-crypto (Ubuntu):
assignee: nobody → Steve Langasek (vorlon)
milestone: later → none
Steve Langasek (vorlon) on 2018-04-05
Changed in partman-crypto (Ubuntu):
status: Confirmed → Fix Committed
milestone: none → ubuntu-18.03
milestone: ubuntu-18.03 → ubuntu-18.04-beta

Hello Simon, or anyone else affected,

Accepted partman-crypto into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/partman-crypto/86ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed verification-needed-bionic
tags: removed: verification-needed verification-needed-bionic
Do Re (kokolores) wrote :

Kubuntu 18.04 daily 2018-04-04.
reproduceable on AMD64 and i386 (downloads SAH256 checked)
i hit this also on a previous daily-build some days before

steps to reproduce:

While booting Live-USB and install Kubuntu via UI
at the point
- Disk Setup
with the option
- Guided - use entire disk and set up encrypted LVM

a message appears:

"Configuration of encrypted volumes failed
An error occurred while configuring encrypted volumes.
The configuration have been aborted."

After trying multiple times to install with encrypted LVM with the error message coming again and again i startet without encryption. than there have been the errormessage written above that stopped the installation. fter klicking back a partition was created with about half of my disksize without advising to do so. Crash with message like "volume has not enough space" resulting in black screen and reboot.

now the USB-Stick is not anymore in the bootable devices and booting my harddrive let me see a blinking _ underline on a black screen

Not sure if i am right place here; It was not possible for me to create a new empty bugreport. Failed installtaion made my system unbootable so i can not report out of the damaged system. Please be so kind to put this in the right place if necessary. Sorry im not at all expirienced with debugging or such. It is a new Laptop with PCI-Express SSD and Intel Core i3-7100U. "Acer Swift 3 SF314-52-385X"

On Thu, Apr 05, 2018 at 08:02:44PM -0000, Do Re wrote:
> three pictures hitting the bug (screen-photos)
> - http://fs1.directupload.net/images/180405/qqsncezm.jpg
> - http://fs1.directupload.net/images/180405/dsl9i7n8.jpg
> - http://fs1.directupload.net/images/180405/vfdxrri6.jpg

Sorry, this is definitely unrelated. You will need to file a separate bug
report.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package partman-crypto - 86ubuntu2

---------------
partman-crypto (86ubuntu2) bionic; urgency=medium

  * lib/crypto-base.sh: don't regard zram devices as "unsafe", since we
    know these are entirely RAM-backed. LP: #1759732.

 -- Steve Langasek <email address hidden> Wed, 04 Apr 2018 17:07:27 -0700

Changed in partman-crypto (Ubuntu Bionic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers