12.04.4 alternate installer encryption should default to aes-xts-plain64

Bug #1263740 reported by Marc Deslauriers on 2013-12-23
264
This bug affects 2 people
Affects Status Importance Assigned to Milestone
partman-crypto (Debian)
Fix Released
Unknown
partman-crypto (Ubuntu)
Undecided
Dimitri John Ledkov
Precise
Undecided
Dimitri John Ledkov

Bug Description

[Impact]

 * Default LUKS encryption settings in the installer are proven to be susceptible to a malleability attack (targeted manipulation of encrypted data).
 * Thus it is proposed to bump defaults to aes-xts-plain64 which is believe to not be affected by above attack.

[Test Case]

 * Perform LUKS encrypted installation using d-i (text) based interface
 * After installation verity that XTS has been used, and not CBC.

# cryptsetup luksDump /dev/sda5|grep Cipher

Here is the sample of _bad_ (CBC) output:

Cipher name: aes
Cipher mode: cbc-essiv:sha256

Here is the sample of _good_ (XTS) output:

Cipher name: aes
Cipher mode: xts-plain64

[Other Info]

12.04 LUKS encryption in the installer defaulted to CBC. We should switch 12.04.4 to aes-xts-plain64 as in 12.10 and above.

See:
http://www.jakoblell.com/blog/2013/12/22/practical-malleability-attack-against-cbc-encrypted-luks-partitions/

Changed in ubiquity (Ubuntu):
assignee: nobody → Dimitri John Ledkov (xnox)
status: New → Fix Released
Changed in ubiquity (Ubuntu Precise):
milestone: none → ubuntu-12.04.4
assignee: nobody → Dimitri John Ledkov (xnox)
affects: ubiquity (Ubuntu) → partman-crypto (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in partman-crypto (Ubuntu Precise):
status: New → Confirmed
description: updated
Changed in partman-crypto (Ubuntu Precise):
status: Confirmed → In Progress
description: updated
Changed in partman-crypto (Debian):
status: Unknown → Fix Released

Hello Marc, or anyone else affected,

Accepted partman-crypto into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/partman-crypto/50ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in partman-crypto (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Dimitri John Ledkov (xnox) wrote :

Verified using server image, xts-plain64 was used and the machine booted / mounted encrypted root correctly.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package partman-crypto - 50ubuntu2

---------------
partman-crypto (50ubuntu2) precise; urgency=medium

  * Backport support for, and use by default, xts-plain64. (LP: #1263740) (closes: #482092)
    - Double key size if xts mode is selected.
 -- Dimitri John Ledkov <email address hidden> Wed, 22 Jan 2014 12:25:11 +0000

Changed in partman-crypto (Ubuntu Precise):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for partman-crypto has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

To post a comment you must log in.
This report contains Public Security information  Edit
Everyone can see this security related information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.