ubiquity crashed with KeyError in partman_edit_dialog(): 'method_choices'

Bug #885654 reported by sparker256 on 2011-11-03
156
This bug affects 24 people
Affects Status Importance Assigned to Milestone
partman-base (Ubuntu)
High
Colin Watson
Precise
High
Colin Watson

Bug Description

Trying to install Ubuntu 12.04 64bit by manually setting up the partitions and would not allow me to do that. Will try with 32bit next.

WORKAROUND

change #! /bin/sh to #! /bin/bash in /lib/partman/choose_partition/60partition_tree/do_option

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: ubiquity 2.9.2
ProcVersionSignature: Ubuntu 3.1.0-2.3-generic 3.1.0
Uname: Linux 3.1.0-2-generic x86_64
ApportVersion: 1.24-0ubuntu1
Architecture: amd64
CasperVersion: 1.288
Date: Thu Nov 3 12:47:00 2011
ExecutablePath: /usr/lib/ubiquity/bin/ubiquity
InterpreterPath: /usr/bin/python2.7
LiveMediaBuild: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20111102)
ProcCmdline: /usr/bin/python /usr/lib/ubiquity/bin/ubiquity gtk_ui
ProcEnviron: Error: [Errno 13] Permission denied: '/proc/5373/environ'
PythonArgs: ['/usr/lib/ubiquity/bin/ubiquity', 'gtk_ui']
SourcePackage: ubiquity
Title: ubiquity crashed with KeyError in partman_edit_dialog(): 'method_choices'
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

sparker256 (bgood) wrote :
tags: removed: need-duplicate-check
sparker256 (bgood) on 2011-11-03
visibility: private → public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Aslam Muhammad (aslamckra) wrote :

I used 32 bit, same problem here

Blair Zajac (blair) wrote :

I saw a similar error in a kubuntu install, see #885842.

sparker256 (bgood) wrote :

Using daily live usb 11-04-11 and using gparted I got the same error as before.

ubiquity crashed with KeyError in partman_edit_dialog(): 'method_choices'

Will do further testing to make sure bug is in ubuquity and not gparted

sparker256 (bgood) wrote :

Using daily live usb 11-06-11 and using gparted I got the same error as before.

ubiquity crashed with KeyError in partman_edit_dialog(): 'method_choices'

Changed in ubiquity (Ubuntu Precise):
status: Confirmed → Triaged
importance: Undecided → High
assignee: nobody → Ubuntu Installer Team (ubuntu-installer)
milestone: none → precise-alpha-1
Erick Brunzell (lbsolost) wrote :

Same with 20111107-i386.

Erick Brunzell (lbsolost) wrote :

In my case, just to be very specific, this happens after choosing "something else" to perform a manual install. Then when the next window opens and I try to select file system type, or anything else from that window, nothing happens other than this crash report.

If i use a spare blank drive and choose "entire disc" things work as they should. I've not tried "side-by-side" ATM.

sparker256 (bgood) wrote :

I was given this work around from bedbug on Ubuntu forums.

Temporary workaround
change #! /bin/sh to #! /bin/bash in /lib/partman/choose_partition/60partition_tree/do_option

Ignore Crashes... It's Worked for me !!!

Bill

newuser (newuser) wrote :

@sparker256:
Your workaround work for me.

Mooregoth (tex-moore16) wrote :

How does one do that?

Joel Pickett (jpickett) wrote :

echoing comment #10

dittoing #10

Omer Akram (om26er) on 2011-11-25
description: updated
Guy Stone (stoneguy3) wrote :

Attempting install of 32-bit version to empty 16GB SDHC card. Booted from 4GB USB key with Nov 25 daily live of Precise created with Startup Disk Creator. Can't create new partition on SDHC in Do Something Else option. Sometimes get ubi-partman error 114.

see #8 above, Was able to proceed using workaround in #9.

tags: added: rls-mgr-p-tracking
Colin Watson (cjwatson) on 2011-11-25
Changed in ubiquity (Ubuntu Precise):
assignee: Ubuntu Installer Team (ubuntu-installer) → Colin Watson (cjwatson)
Colin Watson (cjwatson) wrote :

I found this in my syslog:

  Nov 25 16:47:48 ubuntu ubiquity: /lib/partman/choose_partition/60partition_tree/do_option: 77: local: not in a function

But this code hasn't changed for some time. However, here's a dash change between oneiric and precise:

2010-05-24 Herbert Xu <email address hidden>

       * Add localvars nesting, local now fails outside functions.

So I think the shell has become stricter here. It's entirely entitled to reject this construct; I'll fix it in the installer.

affects: ubiquity (Ubuntu Precise) → partman-base (Ubuntu Precise)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package partman-base - 151ubuntu3

---------------
partman-base (151ubuntu3) precise; urgency=low

  * choose_partition/partition_tree/do_option: 'local' is not legal outside
    a function (and current dash rejects this; LP: #885654).
 -- Colin Watson <email address hidden> Fri, 25 Nov 2011 17:46:39 +0000

Changed in partman-base (Ubuntu Precise):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers