LVM partitioning does not work with edgy beta alternative

Bug #63721 reported by Michael Helmling on 2006-10-03
12
Affects Status Importance Assigned to Milestone
partman-base (Ubuntu)
High
Colin Watson

Bug Description

Binary package hint: partman-lvm

I try to install Ubuntu Edgy Beta using LVM partitions, so I downloaded the alternative install CD. However when I select "Configure the Logical Volume Manager" at "Partitioning Disks", the display just flashes and shows up the same page again. At console 4, everything looks ok:

partman-lvm: PV /dev/sda7 VG laptopvg lvm2
...
...
partman-lvm: Reading all physical volums .... found volume group "laptopvg" using metadata type lvm2 ....

no errors or warnings there.

Colin,

i have noticed this too. It seems that neither partman-lvm or partman-raid can access their submenus if there are no changes to commit on the disk layout.

It looks to me like the question that ask "In order to go further you need to commit the changes to disk! <yes> <no>" is doing something wrong. Note that the question is not shown when there are no changes to commit, but you get set back on the partman menu.

Once there is a change the commit, the question shows up and you are presented with the submenus for lvm/raid

Fabio

Michael Helmling (supermihi) wrote :

Thanks, I'll try that hint. By the way, the error isn't present in the dapper alternative CD. Also, what I just tested, it works with recent debian testing installer discs.

Michael

Michael Helmling (supermihi) wrote :

I can confirm that it works if you do any action to the existing partition layout, or only a "pseudo-action", like changing the usage of a partition and then change it back. This makes ubuntu at least installable, to the insiders ..

Colin Watson (cjwatson) wrote :

This turns out to be a bug in the confirm_changes function in partman-base; I dropped the priority of the partman*/confirm_nochanges questions to medium way back in the hoary cycle for reasons I no longer recall. These reasons are almost certainly obsolete nowadays anyway, so I'll revert that change.

Changed in partman-lvm:
assignee: nobody → kamion
importance: Undecided → High
status: Unconfirmed → Confirmed
Colin Watson (cjwatson) wrote :

partman-base (90ubuntu7) edgy; urgency=low

  * Set the priority of partman*/confirm_nochanges questions back to
    critical; having it at medium breaks LVM and RAID configuration (closes:
    Malone #63721).

 -- Colin Watson <email address hidden> Tue, 10 Oct 2006 11:43:28 +0100

Changed in partman-base:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers