Partitioner throws "Unable to satisfy all constraints" when trying to use previously created partitions

Bug #558382 reported by Steve Beattie on 2010-04-08
38
This bug affects 5 people
Affects Status Importance Assigned to Milestone
partman-base (Ubuntu)
High
Colin Watson
Lucid
High
Colin Watson

Bug Description

Binary package hint: debian-installer

Disk image: netbootmini.iso 20081029ubuntu95 amd64

The disk image in this vm had been used in prior rounds of iso testing and had a remaining ext4 and swap partition on it, from a use full disk option. I attmepted to install with the above media and do a side-by-side installation with the existing partitions. That install failed giving me the constraint error in the title; however, I'd neglected to boot with debugging enabled. I rebooted with debugging enabled but of course didn't have the option of a side-by-side install; the prior attempt had successfully resized the existing partition. Attempting to create a new logical partition in the free space also fails with the constraint error above. The swap partition is the existing one from prior installs.

Here's the state of the disk image as reported by fdisk in sectors:

Disk /dev/sda: 10.7 GB, 10737418240 bytes
255 heads, 63 sectors/track, 1305 cylinders, total 20971520 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x0001cad8

   Device Boot Start End Blocks Id System
/dev/sda1 * 2048 9377047 4687500 83 Linux
Partition 1 does not end on cylinder boundary.
/dev/sda2 19984382 20971519 493569 5 Extended
/dev/sda5 19984384 20971519 493568 82 Linux swap / Solaris

Steve Beattie (sbeattie) wrote :
Steve Beattie (sbeattie) wrote :
summary: Partitioner throws "Unable to satisfy all constraints" when trying to
- use previously created swap partition
+ use previously created partitions
tags: added: iso-testing
Steve Langasek (vorlon) on 2010-04-10
Changed in debian-installer (Ubuntu):
importance: Undecided → Medium
Colin Watson (cjwatson) on 2010-04-16
Changed in debian-installer (Ubuntu Lucid):
status: New → Confirmed
Colin Watson (cjwatson) on 2010-04-16
Changed in debian-installer (Ubuntu Lucid):
milestone: none → ubuntu-10.04
edisso (martin-piroth) wrote :

I get this when I try to use the option "Use the largest continuous free space" doing a fresh install of Lucid on a hard disk with three other partitions (1 primary and 2 logical). Installation method worked without problems with 9.10.

edisso (martin-piroth) wrote :

1st error message

edisso (martin-piroth) wrote :

followup error message

edisso (martin-piroth) wrote :

last error message

edisso (martin-piroth) wrote :

right screenshot of follow up error message

edisso, screenshots are no use to me, but log files (/var/log/syslog and
/var/log/partman) may be of use, for comparison with Steve's. I haven't
managed to reproduce this myself yet, although I'm working on it ...

edisso (martin-piroth) wrote :

Here it is:
partman

edisso (martin-piroth) wrote :

and syslog

Colin Watson (cjwatson) on 2010-04-16
affects: debian-installer (Ubuntu Lucid) → partman-base (Ubuntu Lucid)
Colin Watson (cjwatson) wrote :

This is directed just at Steve Beattie for now, because these directions are suited for modifying the image he's using but not for modifying ubiquity, which edisso is using. If this becomes a problem I'll revise later, but it should do for now.

Steve, please do the following:

  * 'apt-get source parted', apply http://paste.ubuntu.com/418715/ to it, and 'debuild -b'.
  * 'apt-get source partman-base', apply http://paste.ubuntu.com/418716/ to it, and 'debuild -b'.
  * Start your VM, in such a state that the next installation will reproduce this bug. Make sure that it has network access to the machine on which you built these packages; if you just built on the VM host and are using kvm, then I believe 10.0.2.2 should work by default.
  * Run through the installation until the point where it asks you for your hostname, switch to tty2, and start a shell.
  * Run 'anna-install openssh-client-udeb', scp over the libparted0-udeb and partman-base udebs you just built, and unpack them both using 'udpkg --unpack'.
  * Switch back to tty1, reproduce the bug, and exit to the installer main menu.
  * Attach the resulting /var/log/syslog, /var/log/partman, and /var/log/parted_server.err to this bug.

Thanks in advance! I haven't tested these directions, so please get in touch with me on IRC if you have problems.

Changed in partman-base (Ubuntu Lucid):
status: Confirmed → Incomplete
assignee: nobody → Colin Watson (cjwatson)
importance: Medium → High
Steve Beattie (sbeattie) wrote :

Colin, my initial attempts at using your patches resulted in a SEGV in _try_constraint(); the first couple of times that function is invoked, ped_constraint_intersect() returns NULL. I added a NULL check to debug.patch like so: http://paste.ubuntu.com/418950/ and was able to successfully get logs.

I had difficulty reproducing the failure condition. Ultimately, what I resorted to doing was a default full disk karmic install, and then resizing the partitions slightly to match as best I could the partition table I listed in my initial report. It's not exactly the same setup, as fdisk in sector mode would not let me create /dev/sda5 starting at sector 19984384, but I was able to reproduce the constaint error.

Attached are my logs.

Steve Beattie (sbeattie) wrote :
Steve Beattie (sbeattie) wrote :
Colin Watson (cjwatson) wrote :

The problem does appear to be intersection coming out as NULL. I've now reproduced this locally by setting up the initial state to match your partman log, so I should be able to make progress on this.

Changed in partman-base (Ubuntu Lucid):
status: Incomplete → In Progress
Colin Watson (cjwatson) on 2010-04-21
Changed in partman-base (Ubuntu Lucid):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package partman-base - 139ubuntu6

---------------
partman-base (139ubuntu6) lucid; urgency=low

  * Don't apply optimal alignment to extended partitions (LP: #558382).
 -- Colin Watson <email address hidden> Tue, 20 Apr 2010 15:46:47 +0100

Changed in partman-base (Ubuntu Lucid):
status: Fix Committed → Fix Released
Michael Lueck (mlueck) wrote :

Resolution confirmed. I installed WinXP SP3 first, then Lucid behind XP.

The daily CD image 20100426.1 allowed me to do so.

Thank you SO MUCH for getting that fixed!

axelsvag (darinsson) wrote :

No it is not fixed. I downloaded what I hope is the latest from the official site. The problem is the same. The only thing that works is first install 9.10 then upgrade, totally impossible to install lucid on the free space after Vista installation.

Colin Watson (cjwatson) wrote :

axelsvag: it's fixed for the people who reported it initially, so therefore you have a new bug that just happens to have similar symptoms. Instead of following up to an existing bug, please file a new bug with full installation logs attached.

edisso (martin-piroth) wrote :

Sorry, I was on holiday.

For me it's fixed too. Clean installation of 10.04 on my Windows 7 drive with 30 GB free space worked without problems by using the "use largest free space" option. Thanks Colin...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers