cannot create first partition smaller than 16.8G

Bug #539456 reported by tavasti on 2010-03-16
50
This bug affects 7 people
Affects Status Importance Assigned to Milestone
partman-base (Ubuntu)
Critical
Colin Watson
Lucid
Critical
Colin Watson

Bug Description

Binary package hint: debian-installer

Installer on lucid seems to be bit broken, I can't create /boot partition
smaller than 16.8GB on 1T disk with alternative installer, text mode.
I tried giving size as 200M, 200MB, 1%, 1G and creating primary in
beginning of disk. All resulting 16.8G partition 16.8G from
beginning.

Used cd-image is from
http://cdimage.ubuntu.com/xubuntu/daily/20100315/lucid-alternate-amd64.iso

Tried creating partition with ext2, ext3, ext4, same results.
However, when there is that 16.8G partition with 16.8G offset, I can
create another partition with correct size. So bug happens only when
creating first partition to empty disk?

tavasti (tavasti) wrote :
tavasti (tavasti) wrote :
tavasti (tavasti) wrote :
tavasti (tavasti) wrote :
tavasti (tavasti) wrote :
tavasti (tavasti) wrote :
Usama Akkad (damascene) on 2010-03-16
tags: added: iso-testing lucid
Colin Watson (cjwatson) wrote :

That's impressive; it seems to have got thoroughly confused about the optimal partition alignment on your disk. Could you please press Alt-F2, start a shell, and tell me the output of the following commands?

  cat /sys/block/sda/alignment_offset
  cat /sys/block/sda/queue/minimum_io_size
  cat /sys/block/sda/queue/optimal_io_size
  cat /sys/block/sda/queue/physical_block_size

affects: debian-installer (Ubuntu) → partman-base (Ubuntu)
Changed in partman-base (Ubuntu):
status: New → Incomplete
summary: - Alternative installer cannot create first partition smaller than 16.8G
+ cannot create first partition smaller than 16.8G
tavasti (tavasti) wrote :

/sys/block/sda/alignment_offset
0
/sys/block/sda/queue/minimum_io_size
512
/sys/block/sda/queue/optimal_io_size
0
/sys/block/sda/queue/physical_block_size
512

Colin Watson (cjwatson) on 2010-03-16
Changed in partman-base (Ubuntu):
status: Incomplete → Confirmed

This also happens on older drives (250 and 320G sata drives in my case) and even if there are partitions already set up, the installer insists on stuffing 16.8G before any new partition, as well as making them at least 16G in size.

Additionally, setting whole disk partitions is impossible in this tool; in case of the 250G disk it wasted around 80GB on "alignment".

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package partman-base - 138ubuntu4

---------------
partman-base (138ubuntu4) lucid; urgency=low

  * Don't source /usr/share/debconf/confmodule in init.d/parted;
    /lib/partman/lib/base.sh will always source it for us.
  * Tell libparted not to use cylinder alignment (LP: #539456).
 -- Colin Watson <email address hidden> Wed, 17 Mar 2010 00:21:07 +0000

Changed in partman-base (Ubuntu Lucid):
status: Confirmed → Fix Released
Colin Watson (cjwatson) on 2010-03-17
Changed in partman-base (Ubuntu Lucid):
importance: Undecided → Critical
assignee: nobody → Colin Watson (cjwatson)
milestone: none → ubuntu-10.04-beta-1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers