It's possible to install to the device the installation files reside on.

Bug #276656 reported by Evan on 2008-10-01
2
Affects Status Importance Assigned to Milestone
partman-base (Ubuntu)
High
Colin Watson

Bug Description

Binary package hint: partman-base

As it stands, if you create a USB disk with the desktop CD or alternate CD on it, partman will let you try to install to /dev/sda or whatever the USB disk may be. This ends poorly.

Attached is a patch that attempts to fix this by filtering out the device mounted on /cdrom or /hd-media, using code from grub-installer to determine the parent block device.

Colin, I would very much appreciate it if you reviewed this patch as while I've tried to consider every possibility, I imagine an extra set of eyes may find a flaw in this design.

Evan (ev) wrote :
Changed in partman-base:
assignee: nobody → kamion
importance: Undecided → High
milestone: none → ubuntu-8.10
status: New → Confirmed
Evan (ev) wrote :

Also, is this worth sending upstream? It does not seem to be specific to Ubuntu in any way, save maybe searching for /cdrom.

I haven't looked at this patch's behavior yet, but please keep in mind
the scenario that /cdrom is on that same disk, just that you are
installing to a different partition.

On 10/01/2008, Evan Dandrea <email address hidden> wrote:
> Also, is this worth sending upstream? It does not seem to be specific
> to Ubuntu in any way, save maybe searching for /cdrom.
>
> --
> It's possible to install to the device the installation files reside on.
> https://bugs.launchpad.net/bugs/276656
> You received this bug notification because you are a member of Ubuntu
> Installer Team, which is subscribed to partman-base in ubuntu.
>

--
Sent from my mobile device

Mario Limonciello
<email address hidden>

Evan (ev) wrote :

From #ubuntu-installer a while back:
06:26 < cjwatson> evand: is there any reason not to just exclude *any* mounted device, not just /cdrom or /hd-media?

Evan (ev) wrote :

Updated patch that excludes any mounted device and provides a preseed option to avoid the check entirely.

Does this adequately address your concerns, Mario and Colin?

Colin Watson (cjwatson) wrote :

This looks fine to me; go ahead and send it upstream and commit it to Ubuntu's partman-base.

I'd also suggest that you should add something to the preseeding appendix in our installation-guide branch about it. It wouldn't have to be very long, just a commented entry in the section about partman.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package partman-base - 121ubuntu7

---------------
partman-base (121ubuntu7) intrepid; urgency=low

  [ Colin Watson ]
  * Exit straight away if a called script is killed by a signal.
  * Disable backup while displaying device/partition locked errors; it makes
    no sense and it can cause us to exit without closing the FIFO to
    parted_server (LP: #274219).
  * Record that CHANGE_FILE_SYSTEM changes the partition table
    (LP: #149832).

  [ Evan Dandrea ]
  * Exclude devices that have mounted partitions. Useful for when installing
    from a disk (LP: #276656). This can be disabled by preseeding
    partman/filter_mounted to false.

 -- Evan Dandrea <email address hidden> Sun, 12 Oct 2008 02:32:41 -0400

Changed in partman-base:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers