Partman is disorganized

Bug #180269 reported by jhansonxi on 2008-01-04
6
Affects Status Importance Assigned to Milestone
partman-base (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: partman-base

I'm finding that the partition manager on the Ubuntu Gutsy Alternate and Server Hardy Alpha 2 CDs is useless for anything other than very simple drive setups. I've wasted a ridiculous amount of time trying to set up a RAID1/LVM2/dm-crypt arrangement with two pairs of identical drives:
sda1+sdb1=RAID1=lvm=crypt
sdc1+sdd1=RAID1=/boot
sdc2+sdd2=RAID1=crypt=swap
sdc3+sdd3=RAID1=lvm=crypt

A bunch of LUKS/dm-crypt volumes in LVs for /, /home, /var/lib/backuppc, and a couple of archives. Not too complicated except the partition manager can't handle it (manual mode):

1. Some mount point assignments lost when RAID, LVM, or Crypt sub-menus are loaded.
2. Old MDs and LVMs are re-discovered after deletion, re-partitioning, and new mount point assignments whenever the same sub-menus are used.
3. MD likes to start resyncing volumes in the background which apparently causes the LVM config module to fail to reload the partition table. The convenient <Go Back> <Cancel> <OK> options are ambiguous and all lead the the LVM sub-menu anyways. Sometimes when the LVM sub-menu actually loads it just aborts when any option is selected and kicks back to the main partitoning screen.
4. Device assignments for MDs sometimes start at md0, sometimes not, depending on it's mood and what kind of mess mdcfg has got going on in the background.

jhansonxi (jhansonxi) wrote :

After several attempts with fallbacks to the GParted LiveCD to really kill some partitons that the partition manager couldn't give up on I finally got the damn mess to install. Except of course md was complaining about not being able to bd_claim sda at every boot and mdadm kept reporting it had a bad superblock. I failed it, removed it, wiped it, copied it, fdisked it, added and re-added it, tried every solution suggested on the entire Internet and it still had errors. The odd thing is that the partition still seemed to sync.

jhansonxi (jhansonxi) wrote :

So I though after that mess I would give Hardy Alpha 2 server a try and start over from scratch. Fist thing that popped up is that it insisted that sda was using reiser. Another couple of rounds with the partition manager and fdisk out of BusyBox finally got rid of it. But the fun was just starting...

jhansonxi (jhansonxi) wrote :

Oh how I long for the days where I could just load up MS-DOS fdisk and partiton a drive and be done with it. Hardy was not an improvement over Gutsy. I deleted all partitions, created new type FD RAID partions (of different sizes) and dove into the RAID sub-menu. It was screwed up right at the start. sda and sdb were already defined (md0) and the module wanted sdc1 and sdd1 to start at md4. So just where exactly was md1-3? So I stuck with the suggested device names and pressed on. I set the md's to ext3 or LVM as needed and tried to enter the LVM config module. It said it couldn't load md5. So I kept going. Then when I tried to create volume group vg0 it said it already existed. So I went back to the main partition editing screen and verified that md was syncing as usual. Further attempts to enter LVM would only abort. So here we are.

with Ubuntu 8.04.01 server CD:

I agree with jhansonxi that the partman module of the alternate installer is almost useless. I tried for two days to do a rather simple setup: two identical disks, RAID 1 for sda1 / sdb1, LVM on top of this containing only one root partition.

I finally succeed (ignoring all kind of resync/reboot warnings when trying to setup LVM). LILO was able to load and start the kernel, which froze after 'freeing initrd memory' :-( BTW: LILO loads the kernel + initrd really slow, takes about 10 sec. on rather high-end hardware.

For server use, I don't need a funky graphical installer, but the text-mode installer should work in a more logical way and must cope with non-standard situations (i.e. LVM on top of RAID, several RAID partitions etc.). Numerous bugs reported here show that Ubuntu fails in this respect. Red Hat/Fedora show how this can be done.

jhansonxi (jhansonxi) wrote :

I recommend that this bug be marked as a duplicate of bug 68308 as it's just a mess of symptoms of the larger partitioning/RAID/LVM/dm-crypt design problem.

Roy Jamison (xteejx) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 68308, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

Changed in partman-base (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers