Skip eMMC device's boot0, boot1 and rpmb partitions

Bug #1456443 reported by Tsung-Han Lin on 2015-05-19
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OEM Priority Project
High
Unassigned
Trusty
Undecided
Unassigned
debian-installer (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Unassigned
partman-base (Debian)
Fix Released
Unknown
partman-base (Ubuntu)
Medium
Unassigned
Trusty
Medium
Mathieu Trudel-Lapierre
ubiquity (Ubuntu)
Medium
Unassigned
Trusty
Medium
Shih-Yuan Lee

Bug Description

[Impact]
Installations on specific eMMC devices, where they are shipping with mmcblk0rpmb and mmcblk0boot* partitions. For example, Nvidia Jetson TK-1 ARM boards.

[Test case]
Attempt a server installation on the device.

[Regression potential]
Minimal; these devices are meant to be read-only and should be treated as such by partman, so it makes sense to explicitly filter them out.

---
During installation,
partman will scan all the available partitions.
However, with the eMMC device, especially with its /dev/mmcblk0rpmb partition,
a popup warning will show up to interrupt the whole installation process.
One has to manually press the 'Ignore' button to skip that and proceed the installation.
This seriously impacts some of OEM's auto installation requirements.

Ref:
https://lists.debian.org/debian-boot/2014/12/msg00263.html

Tsung-Han Lin (tsunghan-tw) wrote :
description: updated

The attachment "skip-emmc-partitions.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Dimitri John Ledkov (xnox) wrote :

I'd rather the patch be posted to the debian bug report - <email address hidden>

From there myself, or other members of Ubuntu & Debian Installer team can merge it there and then it would propagate to wily + sru's to where this is needed.

Tsung-Han Lin (tsunghan-tw) wrote :

Ok, thanks.

I will post the patch back to debian.

Changed in partman-base (Debian):
status: Unknown → New
Tsung-Han Lin (tsunghan-tw) wrote :

Patch sent.
Waiting for the review/reply.

Changed in partman-base (Debian):
status: New → Fix Released
Ara Pulido (ara) on 2015-08-10
Changed in oem-priority:
status: New → Triaged
importance: Undecided → High

I merged partman-base with Debian in wily; this brings in the fix for this bug for wily.

Changed in partman-base (Ubuntu):
status: New → Fix Released
description: updated

The fixes are now in the vivid and trusty queues awaiting review by the SRU team.

Changed in partman-base (Ubuntu Trusty):
status: New → In Progress
Changed in partman-base (Ubuntu Vivid):
status: New → In Progress
Changed in partman-base (Ubuntu Trusty):
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
Changed in partman-base (Ubuntu Vivid):
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
Changed in partman-base (Ubuntu Trusty):
importance: Undecided → Medium
Changed in partman-base (Ubuntu Vivid):
importance: Undecided → Medium

Hello Tsung-Han, or anyone else affected,

Accepted partman-base into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/partman-base/172ubuntu1.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in partman-base (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
Changed in partman-base (Ubuntu Vivid):
status: In Progress → Fix Committed
Chris J Arges (arges) wrote :

Hello Tsung-Han, or anyone else affected,

Accepted partman-base into vivid-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/partman-base/181ubuntu3.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Shih-Yuan Lee (fourdollars) wrote :

Please also include partman-base update in ubiquity.

tags: added: verification-failed vivid
removed: verification-needed
Changed in ubiquity (Ubuntu Trusty):
status: New → Confirmed
Changed in ubiquity (Ubuntu Vivid):
status: New → Confirmed
Changed in ubiquity (Ubuntu):
status: New → Fix Released
tags: added: verification-needed
removed: verification-failed
Shih-Yuan Lee (fourdollars) wrote :

I tried http://archive.ubuntu.com/ubuntu/dists/trusty-updates/main/installer-amd64/current/images/vivid-netboot/mini.iso but I can not see the eEMMC device inside.
Please update ubiquity to include this partman-base so we can test it by the trusty daily build, aka http://cdimage.ubuntu.com/trusty/daily-live/current/.

Shih-Yuan Lee (fourdollars) wrote :

Ubuntu doesn't have the mmc udeb like https://packages.debian.org/unstable/mmc-modules-4.2.0-1-amd64-di in Debian so we can not install Ubuntu into eMMC storage by debian-installer.

Shih-Yuan Lee (fourdollars) wrote :

Regarding comment #12, I opened Bug #1502772.

Changed in ubiquity (Ubuntu Trusty):
assignee: nobody → Shih-Yuan Lee (fourdollars)
Changed in ubiquity (Ubuntu Vivid):
assignee: nobody → Shih-Yuan Lee (fourdollars)
Changed in ubiquity (Ubuntu Trusty):
status: Confirmed → In Progress
Changed in ubiquity (Ubuntu Vivid):
status: Confirmed → In Progress
no longer affects: ubiquity (Ubuntu Vivid)
Changed in ubiquity (Ubuntu Trusty):
assignee: Shih-Yuan Lee (fourdollars) → nobody
assignee: nobody → Shih-Yuan Lee (fourdollars)
Changed in partman-base (Ubuntu):
importance: Undecided → Medium
Changed in ubiquity (Ubuntu):
importance: Undecided → Medium
Changed in ubiquity (Ubuntu Trusty):
importance: Undecided → Medium
Chris J Arges (arges) wrote :

Hello Tsung-Han, or anyone else affected,

Accepted ubiquity into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubiquity/2.18.8.11 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ubiquity (Ubuntu Trusty):
status: In Progress → Fix Committed
Shih-Yuan Lee (fourdollars) wrote :

I have verified ubiquity/2.18.8.11 in Ubuntu 14.04.3 LTS "Trusty Tahr" - Beta amd64 (20151029).
And it does fix this issue.

tags: added: verification-done
removed: verification-needed
Changed in oem-priority:
status: Triaged → Fix Committed
tags: added: verification-needed-vivid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package partman-base - 172ubuntu1.2

---------------
partman-base (172ubuntu1.2) trusty; urgency=low

  * Do not list /dev/mmcblk.(rpmb|boot.) devices, as they cannot be
    usefully partitioned (LP: #1456443)

 -- Mathieu Trudel-Lapierre <email address hidden> Mon, 10 Aug 2015 11:54:18 -0400

Changed in partman-base (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for partman-base has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

tags: added: verification-done-trusty
removed: verification-done

This appears to already be available in the trusty images; I can definitely see it in http://archive.ubuntu.com/ubuntu/dists/trusty-proposed/main/installer-amd64/current/images/vivid-netboot/mini.iso; the latest partman-base (...1.2) will get pulled in.

Shih-Yuan Lee (fourdollars) wrote :

@Mathieu,

There is no kernel module support for eMMC storage in debian-installer so I opened Bug #1502772 and backported the fix at https://lists.ubuntu.com/archives/kernel-team/2015-October/063694.html.
Right now, the Linux kernel is ready but it is not up to date in debian-installer.
That is why we need to update http://archive.ubuntu.com/ubuntu/dists/trusty-proposed/main/installer-amd64/current/images/vivid-netboot/mini.iso and http://archive.ubuntu.com/ubuntu/dists/trusty-proposed/main/installer-amd64/current/images/netboot/mini.iso.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.18.8.11

---------------
ubiquity (2.18.8.11) trusty; urgency=medium

  [ Shih-Yuan Lee ]
  * Automatic update of included source packages: partman-base
    172ubuntu1.2. (LP: #1456443)
  * debian/control: Fix Vcs-Bzr.

  [ Mathieu Trudel-Lapierre ]
  * Automatic update of included source packages: flash-kernel
    3.0~rc.4ubuntu49.6, grub-installer 1.78ubuntu20.3.

 -- Mathieu Trudel-Lapierre <email address hidden> Fri, 23 Oct 2015 17:45:08 +0100

Changed in ubiquity (Ubuntu Trusty):
status: Fix Committed → Fix Released

I verified again; there is no mmc-modules package available, but that is because the modules were added to the block-modules package instead. Still, I can definitely install this from the vivid-netboot image at least. We don't normally ship this large number of different block device modules on the netboot image as they are not strictly required for loading the installer: they can be installed afterwards from the network.

I see two options here:
- use preseed rules to load block-modules dynamically when doing the network installation (since you're trying to do an automated install).
*or*
- get back to the kernel team and make it clear that you need the modules in *mmc-modules* rather than *block-modules*, in which case once the package is available we can do a d-i update to pull it in.

In the meantime, installing should already work, just you need to load the package yourself, either manually or though the preseed rules.

Shih-Yuan Lee (fourdollars) wrote :

I didn't use any preseed config. I just download the mini.iso and make an installation USB stick by it.
Then I plug the USB stick into a laptop that only has an eMMC system storage inside to do the installation test manually.
During the installation, I will connect to Internet to download other udeb packages and this is the usual usage for mini.iso.

http://archive.ubuntu.com/ubuntu/dists/wily-proposed/main/installer-amd64/current/images/netboot/mini.iso works and /proc/version_signature shows "Ubuntu 4.2.0-16.19-generic 4.2.3".

http://archive.ubuntu.com/ubuntu/dists/vivid-proposed/main/installer-amd64/current/images/netboot/mini.iso doesn't work and /proc/version_signature shows "Ubuntu 3.19.0-30.33-generic 3.19.8-ckt6".

http://archive.ubuntu.com/ubuntu/dists/trusty-proposed/main/installer-amd64/current/images/vivid-netboot/mini.iso works and /proc/version_signature shows "Ubuntu 3.19.0-32.37~14.04.1-generic 3.19.8-ckt7".

http://archive.ubuntu.com/ubuntu/dists/trusty-proposed/main/installer-amd64/current/images/utopic-netboot/mini.iso doesn't work and /proc/version_signature shows "Ubuntu 3.16.0-52.71~14.04.1-generic 3.16.7-ckt8".

http://archive.ubuntu.com/ubuntu/dists/trusty-proposed/main/installer-amd64/current/images/netboot/mini.iso works and /proc/version_signature shows "Ubuntu 3.13.0-67.110-generic 3.13.11-ckt27".

It is expected that "Ubuntu 3.13.0-67.110-generic 3.13.11-ckt27", "Ubuntu 3.19.0-32.37~14.04.1-generic 3.19.8-ckt7" and "Ubuntu 4.2.0-16.19-generic 4.2.3" work and "Ubuntu 3.19.0-30.33-generic 3.19.8-ckt6" doesn't work.

It is not expected that "Ubuntu 3.16.0-52.71~14.04.1-generic 3.16.7-ckt8" doesn't work but we don't maintain utopic now so it is probably OK.

The only problem left now is that http://archive.ubuntu.com/ubuntu/dists/vivid-proposed/main/installer-amd64/current/images/netboot/mini.iso is not up to date.

Changed in debian-installer (Ubuntu):
status: New → Fix Released
Changed in debian-installer (Ubuntu Trusty):
status: New → Fix Released
Changed in oem-priority:
status: Fix Committed → Fix Released
status: Fix Released → Fix Committed
Changed in oem-priority:
status: Fix Committed → Fix Released
Shih-Yuan Lee (fourdollars) wrote :

http://archive.ubuntu.com/ubuntu/dists/trusty-updates/main/installer-amd64/current/images/vivid-netboot/mini.iso works and /proc/version_signature shows "Ubuntu 3.19.0-32.37~14.04.1-generic 3.19.8-ckt7".

http://archive.ubuntu.com/ubuntu/dists/trusty-updates/main/installer-amd64/current/images/netboot/mini.iso works and /proc/version_signature shows "Ubuntu 3.13.0-67.110-generic 3.13.11-ckt27".

tags: added: verification-done-wily
tags: added: verification-failed-vivid
removed: verification-needed-vivid
no longer affects: partman-base (Ubuntu Vivid)
tags: removed: verification-failed-vivid
tags: added: wily
removed: vivid

The version of partman-base in the proposed pocket of Vivid that was purported to fix this bug report has been removed because the bugs that were to be fixed by the upload were not verified in a timely (105 days) fashion.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.