ubiquity crashed with TypeError in partman_column_name(): argument of type 'NoneType' is not iterable

Bug #912031 reported by Timothy Kross on 2012-01-04
334
This bug affects 62 people
Affects Status Importance Assigned to Milestone
partman-auto
New
Undecided
Unassigned
partman-auto (Ubuntu)
High
Colin Watson
Precise
High
Colin Watson

Bug Description

Most people redirected here by apport are likely affected by bug 939450 instead.
The bug report below has indeed been fixed even if it causes an identical stack trace as the new one.

---------------------

Ubuntu 12.04 daily build of 4-1-2012

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: ubiquity 2.9.10
ProcVersionSignature: Ubuntu 3.2.0-7.13-generic 3.2.0-rc7
Uname: Linux 3.2.0-7-generic x86_64
ApportVersion: 1.90-0ubuntu1
Architecture: amd64
CasperVersion: 1.296
Date: Wed Jan 4 22:51:36 2012
ExecutablePath: /usr/lib/ubiquity/bin/ubiquity
InterpreterPath: /usr/bin/python2.7
LiveMediaBuild: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64+mac (20120104)
ProcCmdline: /usr/bin/python /usr/lib/ubiquity/bin/ubiquity --greeter --only
ProcEnviron: Error: [Errno 13] Permission denied: '/proc/3174/environ'
PythonArgs: ['/usr/lib/ubiquity/bin/ubiquity', '--greeter', '--only']
SourcePackage: ubiquity
Title: ubiquity crashed with TypeError in partman_column_name(): argument of type 'NoneType' is not iterable
Traceback:
 Traceback (most recent call last):
   File "/usr/lib/ubiquity/plugins/ubi-partman.py", line 593, in partman_column_name
     if 'id' not in partition:
 TypeError: argument of type 'NoneType' is not iterable
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

Timothy Kross (timkross) wrote :
visibility: private → public
tags: removed: need-duplicate-check
Jean-Baptiste Lallement (jibel) wrote :

Thanks for your report.

Error from the logs:
----
Jan 4 22:51:36 ubuntu ntfsresize: Filesystem check failed! Totally 6 cluster accounting mismatches.
Jan 4 22:51:36 ubuntu ntfsresize: ERROR: NTFS is inconsistent. Run chkdsk /f on Windows then reboot it TWICE!
Jan 4 22:51:36 ubuntu ntfsresize: The usage of the /f parameter is very IMPORTANT! No modification was
Jan 4 22:51:36 ubuntu ntfsresize: and will be made to NTFS by this software until it gets repaired.
Jan 4 22:51:36 ubuntu partman: Error running 'ntfsresize --info'
Jan 4 22:51:36 ubuntu ubiquity[3174]: Exception in GTK frontend (invoking crash handler):
Jan 4 22:51:36 ubuntu ubiquity[3174]: Traceback (most recent call last):
Jan 4 22:51:36 ubuntu ubiquity[3174]: File "/usr/lib/ubiquity/plugins/ubi-partman.py", line 593, in partman_column_name
Jan 4 22:51:36 ubuntu ubiquity[3174]: if 'id' not in partition:
Jan 4 22:51:36 ubuntu ubiquity[3174]: TypeError: argument of type 'NoneType' is not iterable
Jan 4 22:51:36 ubuntu ubiquity[3174]:
----

I'm setting to confirmed because it is also reported in bug 912563
In both cases the error follows an ntfsresize error.

Changed in ubiquity (Ubuntu):
assignee: nobody → Ubuntu Installer Team (ubuntu-installer)
importance: Undecided → High
status: New → Confirmed
Fabio Marconi (fabiomarconi) wrote :

present in today-s build

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/912031

tags: added: iso-testing
Fabio Marconi (fabiomarconi) wrote :

Nope, same message but other error, opening a new report
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

tags: added: rls-mgr-p-tracking
Erick Brunzell (lbsolost) wrote :

I just experienced this "crash" with the installer while testing the 20120131.2 Ubuntu i386 iso-testing image. I'd just rebooted the live DVD after testing integrity and completing a live image test, then selecting "install", following which I chose to install 3rd party software & download updates.

I then chose "something else" to reuse the Linux partition in this setup:

Model: ATA WDC WD800BB-63JK (scsi)
Disk /dev/sda: 80.0GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number Start End Size Type File system Flags
 1 32.3kB 48.5GB 48.5GB primary ntfs boot
 2 48.5GB 80.0GB 31.5GB extended
 5 48.5GB 79.0GB 30.5GB logical ext4
 6 79.0GB 80.0GB 1005MB logical linux-swap(v1)

Note: the ntfs partition is XP.

The next thing I saw was a screen displaying the attached picture (yes, I know the date is wrong).

Erick Brunzell (lbsolost) wrote :

I'm just now trying Lubuntu live-i386 20120131 and it proceeded OK with the identical hardware and partitioning arrangement. And I've noticed a discrepancy in iso-image dates so give me a little while to double check my images.

Erick Brunzell (lbsolost) wrote :

Rather than saying "date" in the last post I should have said "time-stamp". I suppose because things are wacky in Oneiric nautilus showing the time last audited. I'll include a screenshot of nautilus just for clarification but I've triple checked to be sure I was using Ubuntu i386 20120131.2, and I was! And it passes the integrity test!

The attached screenshot is therefore unrelated but I'll likely not report it as a bug until after iso-testing is complete just due to time constraints.

Arrgh, now even that has changed somewhat :^(

But you can still see that the time last modified exceeds my local time by ten minutes. It had previously shown several hours!

Erick Brunzell (lbsolost) wrote :

Sorry if I caused any confusion but here's a better screenshot of the time discrepancy regarding image verification. This is the latest Lubuntu image and you can see that the time-stamp is totally wrong. How can the modification time be later than the actual time?

I'm sure that has nothing to do with this bug but I'm very strict about assuring that I'm running the proper iso for a test.

Erick Brunzell (lbsolost) wrote :

Actually my Lubuntu Alpha 2 testing install also failed due to bug 870643.

Kate Stewart (kate.stewart) wrote :

I chose something else with today's image (20120131), and it crashed immediately rather than on backout.

wolfen69 (wolfen69) wrote :

Ubiquity crashes with the daily build 1/1/12

Colin Watson (cjwatson) wrote :

I'm pretty sure I have a fix for this now; thanks to Kate for providing remote access to an affected system for debugging. However, rather than risk making alpha-2 worse rather than better at this late stage, I'm going to land it just after alpha-2. We'll release-note it, and on affected systems it should be possible to upgrade the installer before starting once a fix has been released.

Changed in ubiquity (Ubuntu Precise):
status: Confirmed → In Progress
assignee: Ubuntu Installer Team (ubuntu-installer) → Colin Watson (cjwatson)
milestone: none → ubuntu-12.04-beta-1
Colin Watson (cjwatson) wrote :

Erick, I wouldn't worry about timestamp discrepancies if I were you. It's easy for such things to arise due to clock skew, timezone changes, plain old confusion in HTTP clients about what timestamps mean, and all kinds of things. It's better to just believe the signed checksums instead.

Colin Watson (cjwatson) on 2012-02-02
affects: ubiquity (Ubuntu Precise) → partman-auto (Ubuntu Precise)
Colin Watson (cjwatson) on 2012-02-02
Changed in partman-auto (Ubuntu Precise):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package partman-auto - 93ubuntu19

---------------
partman-auto (93ubuntu19) precise; urgency=low

  * Close mount's fds 6 and 7 when running within an
    open_dialog/close_dialog pair, so that if ntfs-3g is in use it doesn't
    keep those fds open in the background and cause havoc (LP: #912031).
 -- Colin Watson <email address hidden> Thu, 02 Feb 2012 14:47:27 +0000

Changed in partman-auto (Ubuntu Precise):
status: Fix Committed → Fix Released
Mike (bild85) wrote :

Happened to me running Alpha 2 downloaded a few minutes ago. Syslog attached. MacBook Pro w/SATA drive partitioned with Bootcamp.

On Fri, Feb 03, 2012 at 08:54:38PM -0000, Mike wrote:
> Happened to me running Alpha 2 downloaded a few minutes ago.

This bug was fixed too late for the fix to be present in the Alpha 2
images.

Sam_ (and-sam) wrote :

Sorry about #18 it belongs to new bug 926150 regarding daily current of Feb. 3rd

wolfen69 (wolfen69) wrote :

Ubiquity still crashes for me as of daily build Feb. 11

No way I can get this installed to help in testing.

Colin Watson (cjwatson) wrote :

On Sat, Feb 11, 2012 at 10:13:35PM -0000, wolfen69 wrote:
> Ubiquity still crashes for me as of daily build Feb. 11

Please file a new bug for me with all your logs; there are evidently
multiple manifestations of this bug and I won't be able to sort them out
if people just post follow-ups to this bug. Thanks in advance.

Bowmore (bowmore) wrote :

@Colin: It's hard to file a new bug as when I try to all it does is to refer to this bug.

Mine crashed today after selecting manual partitioning.
I have 20+ partitions on sda (from pre-lucid times) if that mignt be an issue.

Attila Hammer (hammera) wrote :

The current Precise daily live CD producing this issue when I select manual partitioning. The issue is happening when I try press Tab key to go to the awailable columns.
apport-cli redirected me this bugreport.

Attila

elatllat (elatllat) wrote :

Hard to test when you cant install.
I was directed here after loading a daily build into VirtualBox and selecting (download updates+install non-free), then clicking partition(or whatever the other option is) on the installer.
a bunch of other crashes happen right after ending in #938128.

Marco Cimmino (cimmo) wrote :

Happens for me as well on today's daily cd, but automatic report told me as well that this is a duplicate of this issue, then fails to open the link in the browser, closing the error start again and lastly sent something, not sure where and what, finally rebooted.

This is quote bad issue.

Marco Cimmino (cimmo) wrote :

Ok I found the log files.

Marco Cimmino (cimmo) wrote :
Marco Cimmino (cimmo) wrote :
Marco Cimmino (cimmo) wrote :
Marco Cimmino (cimmo) wrote :
Marco Cimmino (cimmo) wrote :
AnrDaemon (anrdaemon) wrote :

VirtualBox, newly created disk image, BIOS boot. Same issue. Crashes as it scan for partitions.
Additionally, is unable to open the bug page in browser as well.

Jack White (stefanweis01) wrote :

sadly still not possible to make a costum install on todays daily build.

chindit (littletiger58) wrote :

I confirm, bug is still not fixed (build 02/27/12)

gmoore777 (guy-moore) wrote :

I also confirm this bug with 2012-02-27 build of 64-bit PrecisePangolin Desktop LiveCD.

gmoore777 (guy-moore) wrote :

Here is my hard drive information, in case that matters:

$ sudo fdisk -l

Disk /dev/sda: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders, total 625142448 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000080

   Device Boot Start End Blocks Id System
/dev/sda1 63 192779 96358+ de Dell Utility
/dev/sda2 * 192780 4289354 2048287+ 83 Linux
/dev/sda3 4289355 625137344 310423995 5 Extended
/dev/sda5 4289418 86210559 40960571 83 Linux
/dev/sda6 602341173 625137344 11398086 82 Linux swap / Solaris
/dev/sda7 86212608 188612607 51200000 83 Linux
/dev/sda8 188614656 291014655 51200000 83 Linux

Partition table entries are not in disk order

Pascal de Bruijn (pmjdebruijn) wrote :

The problem still exists in the daily-live amd64 cd image of 2012-02-28

Stéphane Graber (stgraber) wrote :

I think you're seeing bug 939450 which has similar symptoms.

elatllat (elatllat) wrote :

yes most people here are likely experiencing bug 939450 or some other number, but this is where Ubuntu sends us so this is where it should be tracked (until the crash reporter is made to send people to a different page)

elatllat (elatllat) wrote :

Well hey at least the browser is opening now. But it's still FAIL.

I hit #939450 today with the amd64 iso although the bug submitter brought me here.

If anyone wants to do a custom install, simply boot to a live session first and do it from there.

shinyblue (shinyblue) wrote :

Got crash trying to install from 12.04 Beta 1.

Stephan Henningsen (zta77) wrote :

Crashed in 12.04 beta 1 on my ThinkPad X30. Selected "Install Ubuntu", checked "Install 3rd party software", and selected "Something for partitioning".

Stephan Henningsen (zta77) wrote :

After the crash the Installer bailed out and left me in a live desktop. From here, I could start the "Install Ubuntu 12.04 LTS", but this time without the crash during "Something else" for partitioning.

no longer affects: partman-auto
Gone fishing (humpmihk-msn) wrote :

Just got the same error - downloaded the Beta version the day it was released.

Same error - gagged trying to find a free partition. Details from sudo fdisk -l are below.
The installer offered only /dev/sde for "Alongside other OS". That's a usb external drive. OK, try "Something else". The crash occurred while scanning disk partitions. I'd wanted to put Precise on /dev/sda5.

= = = = = = = =
Disk /dev/sda: 120.0 GB, 120033041920 bytes
255 heads, 63 sectors/track, 14593 cylinders, total 234439535 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x19f619f5

   Device Boot Start End Blocks Id System
/dev/sda1 * 2048 206847 102400 7 HPFS/NTFS/exFAT
/dev/sda2 208894 234438655 117114881 5 Extended
/dev/sda5 208957 107619434 53705239 83 Linux
/dev/sda6 107630592 226183167 59276288 83 Linux
/dev/sda7 226185216 234438655 4126720 82 Linux swap / Solaris

Disk /dev/sdb: 120.0 GB, 120034123776 bytes
255 heads, 63 sectors/track, 14593 cylinders, total 234441648 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xd1e6d1e7

   Device Boot Start End Blocks Id System
/dev/sdb1 63 234436544 117218241 c W95 FAT32 (LBA)

Disk /dev/sdc: 120.0 GB, 120034123776 bytes
255 heads, 63 sectors/track, 14593 cylinders, total 234441648 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x0000993e

   Device Boot Start End Blocks Id System
/dev/sdc1 2048 107425791 53711872 83 Linux
/dev/sdc2 107426716 117194174 4883729+ 5 Extended
/dev/sdc3 117194752 234438655 58621952 7 HPFS/NTFS/exFAT
/dev/sdc5 107426718 117194174 4883728+ 82 Linux swap / Solaris

Disk /dev/sdd: 120.0 GB, 120034123776 bytes
255 heads, 63 sectors/track, 14593 cylinders, total 234441648 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x0007bc7b

   Device Boot Start End Blocks Id System
/dev/sdd1 2048 109053951 54525952 83 Linux
/dev/sdd2 109053952 119539711 5242880 83 Linux
/dev/sdd4 119539712 234441647 57450968 5 Extended
/dev/sdd5 119541760 130027519 5242880 83 Linux
/dev/sdd6 130029568 234441647 52206040 83 Linux

Disk /dev/sde: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders, total 625142448 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x44fdfe06

   Device Boot Start End Blocks Id System
/dev/sde1 63 625137344 312568641 7 HPFS/NTFS/exFAT

Installation attempt was from the Beta CD, downloaded today.

After the crash, Firefox correctly displayed this launchpad page. But desktop was nearly useless, and "Install" window could not be dismissed.

RobWilkens (robwilkens) wrote :

This bug is still in beta 1 which i just downloaded and tried to install. It's at least visible on 64 bit version, perhaps if i tried 32 bit it might not have the issue?

RobWilkens (robwilkens) wrote :

Update : While this bug occured in initial install of beta 1.. When it went back to desktop, I re-ran the install (without rebooting) it worked on 64-bit version without the same error..

description: updated
Mark Ewoldt (ewoldtmark) wrote :

crashed while trying to use the partion manager or installer

Nick (bezvezebas) wrote :

Bug is still present.

erlinda urban (erlinda-urban) wrote :

crashed while starting to use the partion manager while the Installation

Vadim Rutkovsky (roignac) wrote :

Occurred in Precise Beta 1, please, reopen the issue

devvv (devvv) wrote :

still present in current 12.04 beta. keeps me from installing the beta

Johan (deberghes-johan) wrote :

I confirm. Bug still present when using manual partitioning

Pere Orga (pereorga) wrote :

yes, in current daily build the bug is still present (using manual partitioning)

Doug Bates (coloneldare) wrote :

Alpha 2&3 ran fine on this old Celeron M laptop, but Beta 1 always crashes on manual partitioning (I've tried several 'daily' builds since i first saw the prob on day1 of Beta.

Madhusudan Challa (challa) wrote :

I hit this bug as well during manual partitioning. You can repro it by manually running /lib/partman/display.d/80manual_partitioning, you should see a clobbered screen and then the process exits.

how can i download the package to fix this error ?

Changed in partman-auto (Ubuntu Precise):
assignee: Colin Watson (cjwatson) → Anthony Mallah (anthony-mallah)
Colin Watson (cjwatson) on 2012-03-09
Changed in partman-auto (Ubuntu Precise):
assignee: Anthony Mallah (anthony-mallah) → Colin Watson (cjwatson)
Daniel Greeley (danielgreeley) wrote :

Ran into this bug after downlading and trying to install today's daily build (3.9.12) immediately after selecting "do something else" from the partition manager.

oriolsbd (oriolsbd) wrote :

I had this bug when trying to do a manual partitioning while installing Ubuntu 12.04 beta

Carlos Carreras (carlosmaxo7) wrote :

I hat this bug after select install directly. I test the software and install after test without any problem

Paul Graydon (twirrim) wrote :

Get this on choosing advanced partition tool during the installer.

Present in beta 2

noeh (wengratz) wrote :

how???

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers