[12.04] Ubiquity/Partman do not re-use/detect FAT32 EFI partition

Bug #900245 reported by YannUbuntu on 2011-12-05
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
partman-auto (Ubuntu)
Undecided
Unassigned

Bug Description

On Ubuntu 11.10 and 12.04 alpha

On a EFI system which already contains a FAT32 EFI partition, when the user chooses "Install Ubuntu alongside them" (see attached screenshot) , Ubiquity will create another EFI partition, but will not use it. Instead it will use the first EFI partition detected on the disk.

For example, if you install Ubuntu 11.04, then 11.10, then 12.04 alpha on a EFI system, you will find that 3 EFI partitions are created, but only the 1st EFI partition will be used (grubx64.efi will be updated each time). The 2 other EFI partitions will remain useless (empty).

Remarks:
- if the user chooses "Something else" and creates a root (/) partition, Ubiquity will correctly detect and use the existing EFI partition.
- if the EFI partition is FAT16, it will be correctly detected by Partman, and Ubiquity will correctly use it (and won't create additional EFI partition)

(translated from French: http://forum.ubuntu-fr.org/viewtopic.php?pid=7332931#p7332931 )

YannUbuntu (yannubuntu) wrote :
Colin Watson (cjwatson) on 2012-02-16
affects: ubiquity (Ubuntu) → partman-auto (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in partman-auto (Ubuntu):
status: New → Confirmed
Colin Watson (cjwatson) wrote :

This is basically the same as bug 311299.

YannUbuntu (yannubuntu) wrote :

With today's daily ISO of Precise, the SWAP is correctly reused (bug 311299 is solved), but still the installer creates a new EFI partition.
So the current bug is different from bug 311299, and still valid, i removed the duplicate.

Colin Watson (cjwatson) wrote :

Please post the syslog and partman logs to demonstrate the problem.

Changed in partman-auto (Ubuntu):
status: Confirmed → Incomplete
Colin Watson (cjwatson) wrote :

I think this is probably caused by bug 972122, which I'm fixing now.

YannUbuntu (yannubuntu) wrote :

After further investigation, it seems that Partman correctly detects EFI partition when it is FAT16, but not when it is FAT32.
Whatever the size of the FAT16 or FAT32 partition.

Consequence: Ubiquity correctly re-uses FAT16 EFI partition, but not FAT32 EFI partition.

summary: - [12.04] Ubiquity creates useless EFI partition
+ [12.04] Ubiquity/Partman do not re-use/detect FAT32 EFI partition
description: updated
YannUbuntu (yannubuntu) wrote :

Attached files corresponding to the 2nd system of the following procedure:

1) Installed Ubuntu 12.04 Beta2 ("use the entire disk")
2) Reduced sda2 partition.
3) then installed a second Ubuntu 12.04 Beta2 ("alongside Ubuntu 12.04").

Changed in partman-auto (Ubuntu):
status: Incomplete → Confirmed
YannUbuntu (yannubuntu) wrote :

For information, resulting partitioning is:

sudo parted -s /dev/sda unit s print
Model: ATA VBOX HARDDISK (scsi)
Disk /dev/sda : 40853504s
Sectors size (logical/physical): 512B/512B
Partition Table : gpt

Number Start End Size FileSystem Name Flags
 1 34s 195346s 195313s fat32 boot
 2 195347s 12613631s 12418285s ext4
 4 12613632s 12808944s 195313s fat32 boot
 5 12808945s 38759800s 25950856s ext4
 3 38759801s 40853470s 2093670s linux-swap(v1)

YannUbuntu (yannubuntu) wrote :

Seeing https://bugs.launchpad.net/ubuntu/+source/partman-efi/+bug/972122/comments/11 , is this bug (#900245) partially or completely solved ?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers