feisty fawn herd 4 server loops when partitioning disks attempted

Bug #87275 reported by mkovac on 2007-02-23
2
Affects Status Importance Assigned to Milestone
partman-auto (Ubuntu)
Undecided
Unassigned

Bug Description

probably a partman bug

i have feisty-fawn-herd4 server for AMD64 from http://cdimage.ubuntu.com/ubuntu-server/daily/current/ downloaded on 22nd February 2007.
uname -a
Linux ....... 2.6.20-8-generic #2 SMP ...........x86_64 unknown

booted ok, scanned disks, but when i came to partitioning disks, it gave me these options:

--------------------------
Partitioning method:
0
Guided - resize cdrom-retriever and use freed space
Guided - use entire disk
Guided - use entire disk and set up LVM
--------------------------

i didn't want any guidance, i knew exactly which partition i wanted to use, so i chose '0'. i got a red screen with this:

--------------------------
[!!] Partition disks
No root file system

No root file system is defined.
Please correct this from the partitioning menu.
<Go Back> <Continue>
--------------------------

whether i choose Go Back or Continue, it doesn't matter - the screen blinks blue and i still get the same red screen with the same message. there's no way to skip this step, return back or anything.

i am attaching my fdisk, lspci, lspci -vv and /var/syslog

mkovac (mkovac) wrote : system info

lspci, lspci, lspci -vv

description: updated
mkovac (mkovac) wrote : syslog

syslog

mkovac (mkovac) wrote :

i've just tried other choice - 'Guided - use entire disk' and i got the same result. red screen, same message.

Brian Murray (brian-murray) wrote :

Thanks for your bug report. After downloading the CD image did you verify the md5sum of the ISO? Thanks in advance.

mkovac (mkovac) wrote :

i did md5sum now and it matches.
i also had k3b do the md5sum on the cd. also ok.

Changed in ubiquity:
assignee: brian-murray → nobody
status: Needs Info → Confirmed
Colin Watson (cjwatson) wrote :

Could you reproduce this and get me /var/log/partman as well, please?

Changed in ubiquity:
status: Confirmed → Needs Info
mkovac (mkovac) wrote :

btw, 64bit desktop version of feisty fawn herd4 produces the very same error. this is the /var/log/partman from it. it is exactly the same as from the server one.

Colin Watson (cjwatson) wrote :

Thanks. I worked with the submitter of bug 89004 (which is the same bug) on IRC and managed to get enough information that I could reproduce it myself. I'll have this fixed right after Herd 5.

Launchpad Janitor (janitor) wrote :

[Expired for partman-auto (Ubuntu) because there has been no activity for 60 days.]

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers