resized partition size doesn't count swap space size.

Bug #769350 reported by Scott Kitterman on 2011-04-23
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
partman-auto (Ubuntu)
High
Evan
Natty
High
Canonical Foundations Team
Oneiric
High
Evan
partman-partitioning (Ubuntu)
Undecided
Evan
Natty
Undecided
Unassigned
Oneiric
Undecided
Evan
ubiquity (Ubuntu)
Undecided
Evan
Natty
Undecided
Unassigned
Oneiric
Undecided
Evan

Bug Description

Binary package hint: ubiquity

See the attached screenshots. During a guided, install along side test I moved the slider bar all the way to the right. According to the Ubiquity U/I I was using 2.7 GB, but I got an error it was too small and neede at least 2.1 GB. After I got bounced back to the manual partitioner (I think this is bug #218694) the empty space was, indeed less than 2.1 GB and not matched to what the slider told me I'd get.
---
Architecture: i386
DistroRelease: Ubuntu 11.04
LiveMediaBuild: Kubuntu 11.04 "Natty Narwhal" - Release i386 (20110423)
NonfreeKernelModules: wl
Package: ubiquity 2.6.10
PackageArchitecture: i386
ProcEnviron:
 LANGUAGE=
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Tags: natty
Uname: Linux 2.6.38-8-generic i686
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

Scott Kitterman (kitterman) wrote :
Scott Kitterman (kitterman) wrote :
tags: added: apport-collected natty
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

tags: added: iso-testing

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here.

I can confirm this issue using the Xubuntu Desktop image dated 20110422.1 . This results in the user being unable to install to the partition, and the must manually resize the partition to complete the installation.

Thanks for taking the time to make Ubuntu better!

Changed in ubiquity (Ubuntu):
importance: Undecided → High
status: New → Confirmed
Scott Kitterman (kitterman) wrote :

Since it's not just a KDE front end issue, making it RC at least for release team review.

Changed in ubiquity (Ubuntu):
milestone: none → ubuntu-11.04

Confirmed with ubiquity 2.6.10, this is not a problem with Ubiquity but with partman and it is reproducible with the debian-installer.

Actually, the partition is correctly resized to the size indicated by the slider but it creates 2 partitions in this space, a root partition and a swap partition. So in the case where you resize to 2.7GB, the allocated space to the root partition is 2.7 - swapsize (e.g 1GB) leaving only 1.7GB for the root partition.

It's the same problem with the text installer, if the user selects 'resize' and resizes the partition to the maximum value proposed, then the partition is correctly resized but it also creates a swap partition in the free space. The installer doesn't stop immediately after the partitioning but further in the installation process when files are being installed and stops with a 'No space left on device'

On a side note, when a system is installed more than on time and the user chooses to overwrite the Ubuntu partition (e.g Windows installed alongside with Ubuntu, and reinstalling Ubuntu) a new swap partition is created each time ending up with as many swap partition as times the system has been reinstalled.

I'm moving to partman-auto

affects: ubiquity (Ubuntu Natty) → partman-auto (Ubuntu Natty)
Changed in partman-auto (Ubuntu Natty):
status: Confirmed → Triaged
assignee: nobody → Canonical Foundations Team (canonical-foundations)
summary: - Ubiquity size sliders don't match actual size
+ resized partition size doesn't count swap space size.
Scott Kitterman (kitterman) wrote :

That or the minimum Ubiquity should allow is minimum install space plus planned swap space.

Evan (ev) wrote :

> Actually, the partition is correctly resized to the size indicated by the
> slider but it creates 2 partitions in this space, a root partition and a
> swap partition. So in the case where you resize to 2.7GB, the allocated
> space to the root partition is 2.7 - swapsize (e.g 1GB) leaving only 1.7GB
> for the root partition.

I'd prefer that we fix this by moving to swap files. Doing so will offer no
additional space, but will more clearly line up with the user's expectations
of the size of the partition.

> It's the same problem with the text installer, if the user selects 'resize'
> and resizes the partition to the maximum value proposed, then the partition
> is correctly resized but it also creates a swap partition in the free space.
> The installer doesn't stop immediately after the partitioning but further in
> the installation process when files are being installed and stops with a 'No
> space left on device'

I don't think this is the same problem. Ubiquity has logic in it to check
that the requested partition size is greater than a multiple of the size of
the read-only copy of the squashfs. This is the figure that's presented on
the "Prepare to install Ubuntu" page.

debian-installer, lacks the ability to have similar functionality due to its
flexibility and construction. It is close to impossible to determine the
minimum size needed for the installation in this environment. If you resize a
partition too small and try to install onto it, then sorry, but don't do that.

> On a side note, when a system is installed more than on time and the user
> chooses to overwrite the Ubuntu partition (e.g Windows installed alongside
> with Ubuntu, and reinstalling Ubuntu) a new swap partition is created each
> time ending up with as many swap partition as times the system has been
> reinstalled.

This should not happen if you choose the "Upgrade/Reinstall Ubuntu" or "Erase
Ubuntu and reinstall" options in ubiquity. These options are made to reuse
the existing swap partition. Please file a separate bug if this not the case.

Changed in partman-auto (Ubuntu Natty):
milestone: ubuntu-11.04 → natty-updates
Changed in partman-auto (Ubuntu Oneiric):
milestone: ubuntu-11.04 → none
tags: added: rls-mgr-o-tracking
Steve Langasek (vorlon) wrote :

It's too late in the cycle to move to swap files for oneiric, and that wouldn't help for natty-updates anyway (which also has a bug target here). Evan, can we do something here to make sure users don't get this "insufficient space" error after already repartitioning?

Changed in partman-auto (Ubuntu Oneiric):
assignee: Canonical Foundations Team (canonical-foundations) → Ubuntu Installer Team (ubuntu-installer)
Evan (ev) wrote :

Yes. We can get the minimum swap size from the partman recipe and factor it into the bounds for the resize slider as well as our consideration of presenting the resize option.

I've started on a patch to this effect and hope to have something done by the end of Monday.

Colin Watson (cjwatson) on 2011-10-03
Changed in partman-auto (Ubuntu Oneiric):
assignee: Ubuntu Installer Team (ubuntu-installer) → Evan Dandrea (ev)
Evan (ev) wrote :

ubiquity (2.8.4) oneiric; urgency=low

  [ Evan Dandrea ]
  * Handle the keyboard query window closed callback being fired twice
    (LP: #865493).
  * Allow focusing of labels when we're in the screen reader
    acessibility profile, so that Orca can read them
    (LP: #856782, LP: #856773).
  * Make sure we account for the size of the installation and swap
    partition when calculating the bounds for the partition resizer
    (LP: #769350).

  [ Colin Watson ]
  * Don't install duplicate copies of console-setup-apply,
    localechooser-apply, and netcfg-wrapper.
  * Bump fallback Ubuntu version number in ubi-language to 11.10.
  * Update translations from Launchpad.
  * For cases where selecting a different location may imply a different
    dialect of the language, i.e. Portuguese and Chinese, take care to set
    LANG to something reflecting the location and
    LANGUAGE/LC_MESSAGES/LC_CTYPE/LC_COLLATE to something reflecting the
    language (LP: #590108). This roughly matches the behaviour of
    language-selector.
  * Automatic update of included source packages: localechooser 2.37ubuntu2,
    partman-partitioning 81ubuntu3.

  [ Stéphane Graber ]
  * Update ubiquity-dm to export self.username as SUDO_USER.
    Make gsettings work properly later on during the install.
  * Whenever we call wget, set --tries=1 instead of the default
    of 20.
  * If we think we're offline, don't try to contact geoip or run
    rdate. (LP: #868668)
 -- Colin Watson <email address hidden> Thu, 06 Oct 2011 02:20:53 +0100

Changed in partman-auto (Ubuntu Oneiric):
status: Triaged → Invalid
Changed in partman-auto (Ubuntu Natty):
status: Triaged → Invalid
Changed in partman-partitioning (Ubuntu Natty):
status: New → Won't Fix
Changed in partman-partitioning (Ubuntu Oneiric):
status: New → Fix Released
assignee: nobody → Evan Dandrea (ev)
Changed in ubiquity (Ubuntu Natty):
status: New → Won't Fix
Changed in ubiquity (Ubuntu Oneiric):
assignee: nobody → Evan Dandrea (ev)
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers