partman fails to load during install on LVM systems

Bug #729394 reported by benste on 2011-03-04
54
This bug affects 10 people
Affects Status Importance Assigned to Milestone
partman-auto (Ubuntu)
High
Colin Watson

Bug Description

Binary package hint: partman-base

natty amd64 Alpha 3 alternate CD
- checking integrity of the disc was passed succesful

After network installation the insaller is loading partman modules, switch to a screen "laoding partman"
which has a very fast increasing statusbar, at about 70% the bar disabpears and I'm stuck with a Blue window, withouht anything to click - i suspected partman to appear.
Changeing to a terminal i was able to launch partman manually again, but this one ended with a statusbar at about 52%, but didn't disapear.

I suspect this issue to be a combination of my previous system and maybe the latest version of partman.

PS: my HDD:
/dev/sda3 - Fat32 45GB
/dev/sda4 - 2 GB Linux swap
1 physical Volume 186,2 GB for LVM
4 logical volumes in there
-lv_boot ~20GB
- lv_home ~100 GB
- lv_opt 2 GB
- lv_temp 10GB

benste (benste) wrote :

PS: all LVM volume use ext4

Martin Erik Werner (arand) wrote :

Similar issue using latest daily (12-Mar-2011 07:42)
I currently have an LVM setup on the main disk, and a PV with no associated VG on my attached usb disk.
Attaching syslog and partman log for the install session.

Martin Erik Werner (arand) wrote :
Martin Erik Werner (arand) wrote :

I have tried to run the installation without the additional USB disk mentioned above, it made no difference.

Martin Erik Werner (arand) wrote :

I was able to reproduce this issue on a virtual KVM instance by creating one singe primary partition, adding it as a physical volume, adding it to a volume group, and then creating one logical volume spanning all free extents.

At this point starting partman fails.

Then I ran a simple mkfs.ext4 on the before completely blank logical volume.

At this point starting partman is succesful, and I was able to get past the partitioning step and into the "installing base system" step (by which time I exited the installer).

Colin Watson (cjwatson) on 2011-03-14
affects: partman-base (Ubuntu) → partman-auto (Ubuntu)
Changed in partman-auto (Ubuntu):
assignee: nobody → Colin Watson (cjwatson)
importance: Undecided → High
status: New → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package partman-auto - 93ubuntu10

---------------
partman-auto (93ubuntu10) natty; urgency=low

  * Guard against blkid returning non-zero (LP: #729394).
 -- Colin Watson <email address hidden> Mon, 14 Mar 2011 13:39:58 +0000

Changed in partman-auto (Ubuntu):
status: Triaged → Fix Released
benste (benste) wrote :

thanks for fixing - will this fix be in daily live ? or should i wait for the next testing release ?

This fix (and released bug fixes in general) is available in the daily live -- you do not have to wait for the next milestone.

Colin Watson (cjwatson) wrote :

Though you won't find it in the most recent daily-live build at the time of writing. It should be in tomorrow's assuming the build doesn't fail.

benste (benste) wrote :

It's included since of yesterday !
Now partman offered me the freedom to use LVM

Thanks you very much for this quick fix.

thebravoman reported a similar bug, but affecting the Maverick installer (bug 694041). Is it possible that that's the same bug as this? If so, should bugfixes be backported to Maverick, even though the person installing Maverick who had experienced the bug would have to update the relevant partman packages in order to install?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments