alternate ISO: installation freezes when starting partman

Bug #726131 reported by C de-Avillez on 2011-02-27
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
partman-auto (Ubuntu)
Critical
Colin Watson
Natty
Critical
Colin Watson

Bug Description

Binary package hint: debian-installer

Continuing saga ;-)

after giving up hope on saving my home filesystem (see bug 723482), I went ahead and started an install-from-scratch with the current daily (20110227) alternate AMD64 ISO.

To my surprise the install freezes at about the time it should start asking abut partitioning the disc.

a 'ps' shows
udpkg --configure --force-configure partman-base
/bin/sh /var/lib/dpkg/info/partman-base.postinst con
/bin/sh /bin/partman
parted_server
/bin/sh /lib/partman/display.d/10initial_auto
/bin/sh /lib/partman/display.d/10initial_auto
/bin/sh /lib/partman/automatically_partition/50bigge

C de-Avillez (hggdh2) wrote :

install from DVD ISO: same issue.

Charlie Kravetz (charlie-tca) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here.

I can confirm this issue using both Ubuntu and Xubuntu images. I am able to reproduce it reliably, it does block all installations.

Thanks for taking the time to make Ubuntu better!

Changed in debian-installer (Ubuntu):
importance: High → Critical
status: New → Confirmed
C de-Avillez (hggdh2) on 2011-02-28
Changed in debian-installer (Ubuntu):
milestone: none → natty-alpha-3
Colin Watson (cjwatson) wrote :

I can't reproduce this on a fresh install inside KVM. Please attach installer logs.

Changed in debian-installer (Ubuntu Natty):
status: Confirmed → Incomplete
C de-Avillez (hggdh2) wrote :
C de-Avillez (hggdh2) wrote :
C de-Avillez (hggdh2) wrote :
C de-Avillez (hggdh2) wrote :

At the moment I copied hte files the installer terminal was showing a blue screen; nothing was written on it.

Changed in debian-installer (Ubuntu Natty):
status: Incomplete → New
Jean-Baptiste Lallement (jibel) wrote :

I can confirm with ISO from 20110228 on both alternate and server

Changed in debian-installer (Ubuntu Natty):
status: New → Confirmed
Jean-Baptiste Lallement (jibel) wrote :

It could be related to this issue bug 722198

Charlie Kravetz (charlie-tca) wrote :

Using Xubuntu Alternate i386 and amd64 images dated 20110228, I can run both installations in VirtualBox with no problems. Unfortunately, attempting the Xubuntu alternate i386 installation on real hardware using a cd-r fails. It hangs at the same point in the installation.

Colin Watson (cjwatson) wrote :

Unfortunately the log is a bit sparse. Could you try:

 * At the hostname prompt, switch to Alt-F2, 'nano /lib/partman/lib/base.sh', and put 'set -x' on the first line
 * Continue installation until you reproduce the bug
 * Kill the partman-related processes that seem stalled, in order to flush logs
 * Post the logs again

C de-Avillez (hggdh2) wrote :
C de-Avillez (hggdh2) wrote :
C de-Avillez (hggdh2) wrote :
C de-Avillez (hggdh2) wrote :

Here they are; I ran with the 20110228 altername AMD64 ISO.

Colin Watson (cjwatson) wrote :

partman-auto (93ubuntu8) natty; urgency=low

  [ Evan Dandrea ]
  * Signal to clear_partitions in partman-target that it should not
    notify the user about the unformatted partitions we have set up.

  [ Colin Watson ]
  * Guard against 'grep -s DISTRIB_ID $mountpoint/etc/lsb-release' returning
    false and causing parted_server communications to get out of sync
    (LP: #726131).

 -- Colin Watson <email address hidden> Mon, 28 Feb 2011 16:22:32 +0000

affects: debian-installer (Ubuntu Natty) → partman-auto (Ubuntu Natty)
Changed in partman-auto (Ubuntu Natty):
assignee: nobody → Colin Watson (cjwatson)
status: Confirmed → Fix Released

i'm getting this on an attempted install using the amd64 alternate install disc (on usb) for natty alpha 3. Did the released fix make that version? (It seems the dates are close; fix released 28 feb, alpha 3 iso image datestamped 1 mar :-)

machine has 5 sata hdds and a cf-in-ide; plan was to put /boot on the latter and / on a raid5 on the former; but i didn't get far enough to tell it that; it just hung up apparently trying to start partman. There were ongoing occasional noises from the hard drives as if it was still running some detection, but after several minutes with nothing further being logged on vc4 it seems dead to me. ps on vc2 shows similar to original bug poster.

Just going to try instead a maverick alternate and upgrade from there, but if this bug is in maverick's installer too I'll be back. :-)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers