installation hangs on 15reuse w/ blank disk

Bug #722198 reported by Norbert Moldován on 2011-02-20
40
This bug affects 5 people
Affects Status Importance Assigned to Milestone
OEM Priority Project
Critical
Chris Van Hoof
partman-auto (Ubuntu)
High
Evan
Natty
High
Evan

Bug Description

Binary package hint: ubiquity

Installing Natty, but after pressing forward on the Preparing to install Ubuntu window ubiquity lags forever.

The image was right, now I'll try to burn it on another cd and see if that solves this issue.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: ubiquity 2.5.16 [modified: lib/partman/automatically_partition/question]
ProcVersionSignature: Ubuntu 2.6.38-4.31-generic 2.6.38-rc5
Uname: Linux 2.6.38-4-generic i686
Architecture: i386
Date: Sun Feb 20 16:12:29 2011
ExecutablePath: /usr/lib/ubiquity/bin/ubiquity
InterpreterPath: /usr/bin/python2.7
LiveMediaBuild: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110220)
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 LC_MESSAGES=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity

edhelas (edhelas) wrote :

I'm also affected by this bug ;)

Mario Limonciello (superm1) wrote :

this is being caused by a problem with partman-auto's new 15reuse method.

Here's a syslog with set -x on all of partman-auto's 15reuse files.

The disk was blank when I started.

affects: ubiquity (Ubuntu) → partman-auto (Ubuntu)
summary: - Ubuntu installation lags
+ installation hangs on 15reuse w/ blank disk
Changed in partman-auto (Ubuntu):
status: New → Confirmed
importance: Undecided → Critical
milestone: none → natty-alpha-3
Changed in partman-auto (Ubuntu Natty):
assignee: nobody → Evan Dandrea (ev)
Chris Van Hoof (vanhoof) wrote :

Adding a OEM Priority task as I've seen a number of emails related to this today

Changed in oem-priority:
importance: Undecided → Critical
assignee: nobody → Chris Van Hoof (vanhoof)
tags: added: hwe-blocker
Changed in oem-priority:
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package partman-auto - 93ubuntu6

---------------
partman-auto (93ubuntu6) natty; urgency=low

  * Don't explode on unpartitioned space in the reuse option (LP:
    #722198).
 -- Evan Dandrea <email address hidden> Thu, 24 Feb 2011 15:29:10 +0000

Changed in partman-auto (Ubuntu Natty):
status: Confirmed → Fix Released
Chris Van Hoof (vanhoof) on 2011-02-24
Changed in oem-priority:
status: Confirmed → Fix Released
Kent Baxley (kentb) wrote :

I'm still seeing problems with this, even with the 2.5.18 ubiquity update from yesterday, which contains the partman-auto fixes.

The installer still gets 'stuck' at any attempts to partition the disk, either automatically or manually.

I've attached the /var/log/installer/debug output and the /var/log/syslog output with 'debug-ubiquity' added to kernel command line.

Kent Baxley (kentb) wrote :
Chris Van Hoof (vanhoof) on 2011-02-25
Changed in oem-priority:
status: Fix Released → Confirmed
Evan (ev) wrote :

Can you attach the output of `ps auxf` when the installer is hanging to this bug? Thanks!

Changed in partman-auto (Ubuntu Natty):
status: Fix Released → Incomplete
Kent Baxley (kentb) wrote :

Hi Evan,

Here you go. Let me know if I can get anything else for you. Thanks.

Martin Pitt (pitti) on 2011-03-01
Changed in partman-auto (Ubuntu Natty):
milestone: natty-alpha-3 → ubuntu-11.04-beta-1
Kent Baxley (kentb) on 2011-03-01
Changed in partman-auto (Ubuntu Natty):
status: Incomplete → Confirmed
Kent Baxley (kentb) wrote :

With today's build of Natty, it looks like we're finally good to go. I can partition a blank disk either manually or via auotpartitioning without any hangs.

Chris Van Hoof (vanhoof) on 2011-03-07
Changed in oem-priority:
status: Confirmed → Fix Released
Evan (ev) wrote :

Can anyone still reproduce this with the latest daily-live CDs? I believe we took care of this with further changes to partman-auto, but I want to be sure before closing this bug.

Luke Yelavich (themuso) wrote :

Yes, can reproduce here with a totally blank partition table. Syslog with set -x for 15reuse files attached.

Changed in partman-auto (Ubuntu Natty):
importance: Critical → High
Bojan Rajkovic (bojanr) wrote :

+1, can reproduce. Trying to install over a Debian install, and I never make it to the partitioning stage. Always stuck at the first page of the wizard. Partman fails with udpkg: not found. /var/log/installer/debug from running ubiquity --debug is attached.

Bojan Rajkovic (bojanr) wrote :

Also attaching ps auxf output, and the last line in syslog that's relevant is:

Mar 13 19:15:43 ubuntu ubiquity: umount: /tmp/tmp.pHSxYl51qp: not mounted

Bojan Rajkovic (bojanr) wrote :

Hmm, I think I've found what triggers the bug--partman only freezes if there's unpartitioned space (I had around 280 GB reserved for a Windows 7 partition). After formatting the empty space as NTFS with GParted, I was able to continue with the installation.

Colin Watson (cjwatson) wrote :

I'm pretty sure that these changes cover the various problems along these lines:

partman-auto (93ubuntu10) natty; urgency=low

  * Guard against blkid returning non-zero (LP: #729394).

 -- Colin Watson <email address hidden> Mon, 14 Mar 2011 13:39:58 +0000

ubiquity (2.5.27) natty; urgency=low

  * Drop code related to debian-installer/fallbacklocale, since that
    template no longer exists (LP: #736060).
  * Update imported translations from gtk+2.0 2.24.3-0ubuntu2 and
    gnome-panel 1:2.32.1-0ubuntu6.
  * Ensure that PartedServer dialogs are always properly closed on
    exceptional paths.
  * Fix partition-table-full check to cope with disks without a partition
    table.

 -- Colin Watson <email address hidden> Wed, 16 Mar 2011 14:36:02 +0000

If partitioning still fails with a current daily build, please open a new bug and attach /var/log/syslog, /var/log/partman, and /var/log/installer/debug.

Changed in partman-auto (Ubuntu Natty):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers