Installer makes swap too small to hibernate

Bug #697779 reported by rjdaggett on 2011-01-05
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
partman-auto (Ubuntu)
Undecided
Unassigned

Bug Description

I have 512Mib of physical ram and the installer made a 394Mib swap part. This is the same a 9.10 when it was beta. Were going to make the same mistakes over and over? It's easier to delete one then resize. the installer should ask if you want hibernate to work, and make the swap part match RAM, DUH!

ProblemType: BugDistroRelease: Ubuntu 10.10
Package: evince 2.32.0-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-24.42-generic-pae 2.6.35.8
Uname: Linux 2.6.35-24-generic-pae i686
Architecture: i386
Date: Wed Jan 5 12:53:54 2011InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bashSourcePackage: evince

***Actually seems fixed in natty***

rjdaggett (rjdaggett) wrote :
Fabio Marconi (fabiomarconi) wrote :

see attached screenshot

Changed in ubuntu:
status: New → Confirmed
affects: ubuntu → partman-auto (Ubuntu)
description: updated
Fabio Marconi (fabiomarconi) wrote :

It appear as fixed in Natty 20110105

Confirmed. 8 gib ssd drive as well. Thought the size forced auto-part to do
it perhaps, I will test natty. Thanks for the quick debugging there fabio!
Great work

On Jan 6, 2011 3:50 PM, "Fabio Marconi" <email address hidden> wrote:
>
> *** This bug is a duplicate of bug 345126 ***
> https://bugs.launchpad.net/bugs/345126
>
> ** This bug has been marked a duplicate of bug 345126
> Installer creates too small swap partition (hibernation fails)
> * You can subscribe to bug 345126 by following this link:
https://bugs.launchpad.net/ubuntu/+source/partman-auto/+bug/345126/+subscribe
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/697779
>
> Title:
> Installer makes swap too small to hibernate
>
> Status in “partman-auto” package in Ubuntu:
> Confirmed
>
> Bug description:
> I have 512Mib of physical ram and the installer made a 394Mib swap part.
This is the same a 9.10 when it was beta. Were going to make the same
mistakes over and over? It's easier to delete one then resize. the installer
should ask if you want hibernate to work, and make the swap part match RAM,
DUH!
>
> ProblemType: BugDistroRelease: Ubuntu 10.10
> Package: evince 2.32.0-0ubuntu1
> ProcVersionSignature: Ubuntu 2.6.35-24.42-generic-pae 2.6.35.8
> Uname: Linux 2.6.35-24-generic-pae i686
> Architecture: i386
> Date: Wed Jan 5 12:53:54 2011InstallationMedia: Ubuntu 10.10 "Maverick
Meerkat" - Release i386 (20101007)
> ProcEnviron:
> LANG=en_US.UTF-8
> SHELL=/bin/bashSourcePackage: evince
>
> ***Actually seems fixed in natty***
>
> To unsubscribe from this bug, go to:
>
https://bugs.launchpad.net/ubuntu/+source/partman-auto/+bug/697779/+subscribe

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers