Installer doesn't comfirm resizing partitions

Bug #52830 reported by Scott Severance on 2006-07-13
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
partman-auto (Ubuntu)
Undecided
Colin Watson

Bug Description

On the Dapper install Live CD, when you come to the partitioning section, if you choose the default resizing option and click forward, the installer doesn't ask before resizing the partition. Instead, it immediately does so. This is a bug because every other partitioner that I'm aware of makes sure that the user is very well aware that it's about to alter the partition table. And since no documentation that I was able to find mentioned that it was able to safely resize NTFS partitions with data that would have to be moved, and since past partitioners haven't been able to do this safely, then there needs to be some sort of confirmation. I think that no disk operations of any kind should be done until the install actually begins.

More information on my specific issue is in this thread: http://www.ubuntuforums.org/showthread.php?t=212985

Related branches

Tristan Rhodes (tristanrhodes) wrote :

I definitely agree with this bug. I was helping my father install Ubuntu 6.10 on his Windows drive, and I told him that Ubuntu would not make any changes to his hard drive until the last step, when it confirms the changes with the user.

So when we hit "Next" after resizing the partition, we thought the installer was locked up, and it took over an hour to complete the resize. I am not sure how much damage we would have caused it we thought it was frozen and cancelled the install.

I think you have two options:

1. Don't perform the actual resizing of partitions until after the confirmation screen

or

2. Add a new confirmation screen that informs users that resizing the partitions will occur NOW, that it may take a long time, and a warning about cancelling during this process.

Tristan Rhodes (tristanrhodes) wrote :

I agree that this change needs to happen. See my two options in my comment.

Changed in ubiquity:
status: Unconfirmed → Confirmed
Colin Watson (cjwatson) wrote :

I think I agree, but this change needs to be done in partman-auto (and then it will apply to the alternate install CD too).

Colin Watson (cjwatson) wrote :

(At the moment, resizing does have to be done immediately due to some constraints in the partitioner. These constraints aren't insuperable, but they would take some careful redesign to lift.)

partman-auto (62ubuntu9) feisty; urgency=low

  * resize_use_free: Add confirmation question before resizing (LP: #52830).

 -- Colin Watson <email address hidden> Thu, 29 Mar 2007 13:14:06 +0100

Changed in partman-auto:
assignee: nobody → kamion
status: Confirmed → Fix Released

Colin,

Thanks for fixing this!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers