[jaunty] "max" value in guided partitioner does not give enough space for grub

Bug #361707 reported by Ara Pulido on 2009-04-15
4
Affects Status Importance Assigned to Milestone
partman-auto (Ubuntu)
Medium
Colin Watson
Jaunty
Medium
Colin Watson

Bug Description

Binary package hint: debian-installer

In jaunty latest images:

I have a 8GB disk with an already installed Ubuntu system.

I select Guided partitioner and resize option.

I select "max" as size, and this calculates that the new system requires 2.0GB of space, but that's only true for the packages during installation.

When it tries to install GRUB the free space is over and the installation fails.

Expected behaviour: "max" space should consider also the space taken by GRUB.

Dave Morley (davmor2) wrote :

Confirmed on hw 160gb drive

Changed in debian-installer (Ubuntu):
status: New → Confirmed
Colin Watson (cjwatson) on 2009-04-15
affects: debian-installer (Ubuntu) → partman-auto (Ubuntu)
Changed in partman-auto (Ubuntu):
status: Confirmed → New
Colin Watson (cjwatson) wrote :

This is going to depend a bit on which language you select, and probably also on how much memory you have (for the swap partition), since different language packs and support packages are different sizes; we don't calculate this exactly, it's just a fixed lower bound on the size of the space we leave. I have no problem increasing the lower bound a bit, though.

Colin Watson (cjwatson) on 2009-04-15
Changed in partman-auto (Ubuntu):
assignee: nobody → Colin Watson (cjwatson)
importance: Undecided → Medium
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package partman-auto - 84ubuntu4

---------------
partman-auto (84ubuntu4) jaunty; urgency=low

  * Add another 300MB to the amount of space we require to be left by
    automatic resizing, to account for (a) growth in installation size, (b)
    variable language pack sizes, and (c) increased memory sizes resulting
    in upward pressure on swap partition sizes (LP: #361707).

 -- Colin Watson <email address hidden> Thu, 16 Apr 2009 14:00:00 +0100

Changed in partman-auto (Ubuntu Jaunty):
status: Fix Committed → Fix Released
tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers