installer creates rather small /boot partition

Bug #1716999 reported by Brian Murray on 2017-09-13
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
partman-auto (Ubuntu)
High
Mathieu Trudel-Lapierre
Xenial
Undecided
Unassigned
ubiquity (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned

Bug Description

[Impact]
All new installs of 16.04.

[Test case]
1) Install Ubuntu 16.04 on a system
2) Validate that the size of the /boot partition is greater than or equal to 512MB; should be somewhere between 512MB and 1GB, close to 768MB.

[Regression potential]
This may adversely affect installs on tiny disks, by taking up more space for the /boot partition than was previously taken, at the cost of / or /home. As such, failures to install due to insufficient space on a partition, or failure to partition a disk that was previously working should be investigated as possible regressions.
This is a corner case in general since there is no requirement to allocate a separate partition for /boot in the default configuration, and if you are using a non-default configuration where /boot must be a separate partition, you probably also don't have a disk so small that an additional 256MB of disk usage is a problem.

---

The installer (in 16.04 and 17.10) creates a separate /boot partition, when required, of only 487M. This ends up being rather small when you using the following equation to estimate a minimal size allowing for reasonable room for further growth.

(2*(3*kernel + 4*plymouth-carrying initrd + bootloader))

for Kernels of 8Mb, initrd of 55Mb and bootloader of ~10Mb:

2* ( 3*8 + 4*55 + 10 )
2* ( 24 + 220 + 10 )
2* ( 254 )
508

We're slightly off with the math right now, so I'll make the absolute minimum size for /boot to be 512Mb; and bump the maximum from 512 to 768. This should give us partition sizes of a little over 512, probably around 650Mb (so some room for future kernel/initrd growth).

Changed in partman-auto (Ubuntu):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Mathieu Trudel-Lapierre (cyphermox)
Changed in partman-auto (Ubuntu Xenial):
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package partman-auto - 134ubuntu7

---------------
partman-auto (134ubuntu7) artful; urgency=medium

  * Bump minimum and maximum sizes for /boot partitions on default, x86, and
    EFI platforms to a minimum of 512Mb and maximum of 768Mb. (LP: #1716999)

 -- Mathieu Trudel-Lapierre <email address hidden> Wed, 13 Sep 2017 11:35:21 -0700

Changed in partman-auto (Ubuntu):
status: In Progress → Fix Released
tags: added: id-5982561eb1d9aa0d07be953f
Brian Murray (brian-murray) wrote :

Let's try and get this in the next point release of 16.04.

Changed in partman-auto (Ubuntu Xenial):
milestone: none → ubuntu-16.04.5
tags: added: id-5b2c1998114aa1c67e32d510
Łukasz Zemczak (sil2100) wrote :

There is an ongoing partman-auto SRU for xenial right now, but once that's out of the way I'd like the fix landing as soon as possible to make it for 16.04.5. Is the SRU assigned to anyone yet? Is it on anyone's plate?

Brian Murray (brian-murray) wrote :

I added the milestone but didn't to talk to anyone about getting it assigned. If you could do it that would be great.

Changed in partman-auto (Ubuntu Bionic):
milestone: none → ubuntu-18.04.1

Why is this targetted to 18.04 too? It was fixed in artful, do we still need to further increase /boot size?

no longer affects: partman-auto (Ubuntu Xenial)
no longer affects: partman-auto (Ubuntu Bionic)
description: updated

Hello Brian, or anyone else affected,

Accepted partman-auto into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/partman-auto/134ubuntu1.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

description: updated
Changed in partman-auto (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed verification-needed-xenial

Verification done on xenial with partman-auto/134ubuntu1.3:

Installed on a 320G disk with LVM (so that a boot partition gets created at all); /boot is generated with a size of 766MB. Obviously, exact size of the /boot partition will depend on the overall disk size, since the recipe depends on the proportions of the other partitions.

tags: added: verification-done-xenial
removed: verification-needed verification-needed-xenial
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package partman-auto - 134ubuntu1.3

---------------
partman-auto (134ubuntu1.3) xenial; urgency=medium

  * Bump minimum and maximum sizes for /boot partitions on default, x86, and
    EFI platforms to a minimum of 512Mb and maximum of 768Mb. (LP: #1716999)

 -- Mathieu Trudel-Lapierre <email address hidden> Fri, 06 Jul 2018 12:52:33 -0400

Changed in partman-auto (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for partman-auto has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers