Installation scheme based on Separate /home, /usr, /var, and /tmp partitions fail

Bug #1461860 reported by bugproxy on 2015-06-04
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
partman-auto (Ubuntu)
Medium
Unassigned
Trusty
Medium
Mathieu Trudel-Lapierre

Bug Description

[Impact]
This prevents the installation process for completing for ppc64el systems due to / not having sufficient space for installing kernel modules.

[Test Case]
See below "Steps to reproduce"

[Regression Potential]
Minimal. This changes the recipe used for the initial partitioning of disks when the multi recipe is picked. Multi is not the default recipe, and this simply merges the / and /usr partitions so that /usr will be contained on the same partition as / rather than being on a separate partition (and thus mounted onto /). Possible issues might be that remaining space for the partition will be slightly lower than it would be for the two separate partitions.

---

== Comment: #0 - SACHIN P. SANT <email address hidden> - 2015-06-04 05:04:36 ==
---Problem Description---
Installation scheme based on Separate /home, /usr, /var, and /tmp partitions fail

---uname output---
3.16.0-38

Machine Type = POWER8

---Debugger---
A debugger is not configured

---Steps to Reproduce---

1) Start 14.04.02 (latest daily ISO) installation as a Power VM guest.
2) On partitioning disk panel select - Separate /home, /usr, /var, and /tmp partitions - option
3) Continue with the installation.

Installation fails with following message :

                  Configuring linux-image-3.16.0-38-generic

                    Unable to install the selected kernel
      An error was returned while trying to install the kernel into the
      target system.

      Kernel package: 'linux-generic'.

      Check /var/log/syslog or see virtual console 4 for the details.

                                  <Continue>

Contact Information = Sachin Sant / <email address hidden>

Install ISO Information: 14.04.02 latest daily ISO

Install method: DVD

/var/log/syslog contains following messages at the time of failure

Jun 1 09:20:49 in-target: Selecting previously unselected package linux-firmware.
Jun 1 09:20:49 in-target: Preparing to unpack .../linux-firmware_1.127.12_all.deb ...
Jun 1 09:20:49 in-target: Unpacking linux-firmware (1.127.12) ...
Jun 1 09:20:53 in-target: Selecting previously unselected package linux-image-extra-3.16.0-38-generic.
Jun 1 09:20:53 in-target: Preparing to unpack .../linux-image-extra-3.16.0-38-generic_3.16.0-38.52~14.04.1_ppc64el.deb ...
Jun 1 09:20:53 in-target: Unpacking linux-image-extra-3.16.0-38-generic (3.16.0-38.52~14.04.1) ...
Jun 1 09:21:01 in-target: dpkg: error processing archive /media/cdrom//pool/main/l/linux-lts-utopic/linux-image-extra-3.16.0-38-generic_3.16.0-38.52~14.04.1_ppc64el.deb (--unpack):
Jun 1 09:21:01 in-target: cannot copy extracted data for './lib/modules/3.16.0-38-generic/kernel/drivers/i2c/busses/i2c-designware-pci.ko' to '/lib/modules/3.16.0-38-generic/kernel/drivers/i2c/busses/i2c-designware-pci.ko.dpkg-new': failed to write (No space left on device)
Jun 1 09:21:01 in-target: dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Jun 1 09:21:02 in-target: Selecting previously unselected package linux-image-generic-lts-utopic.

== Comment: #1 - SACHIN P. SANT <email address hidden> - 2015-06-04 05:06:07 ==
This problem is similar to the one described in the following report

Bug 120256 - LP1410573 -Expert mode installation fails with error

https://bugs.launchpad.net/ubuntu/+source/debian-installer/+bug/1410573

Default Comment by Bridge

tags: added: architecture-ppc64le bugnameltc-125874 severity-high targetmilestone-inin---

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1461860/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
affects: ubuntu → debian-installer
Colin Watson (cjwatson) wrote :

Looks like the partitioning recipe sizes need tweaking a bit here.

affects: debian-installer → partman-auto (Ubuntu)

------- Comment From <email address hidden> 2015-06-24 10:26 EDT-------
Is there a fix available for this ?

bugproxy (bugproxy) on 2015-07-06
tags: added: targetmilestone-inin14043
removed: targetmilestone-inin---
Steve Langasek (vorlon) wrote :

Note that while this option is still present in the installer, installing a system with /usr on a separate partition from / should generally be considered deprecated.

Changed in partman-auto (Ubuntu):
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
importance: Undecided → Medium
milestone: none → ubuntu-14.04.3
status: New → Triaged

Indeed, that option won't be available in following LTS releases, and already is no longer available in 15.04.

Considering this affects only new installations, I think we could probably go the route of applying the size changes, folding /usr into / for the partitioner as a SRU.

description: updated
Changed in partman-auto (Ubuntu Trusty):
milestone: none → ubuntu-14.04.3
Changed in partman-auto (Ubuntu):
milestone: ubuntu-14.04.3 → none
Changed in partman-auto (Ubuntu Trusty):
status: New → Triaged
importance: Undecided → Medium
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
Changed in partman-auto (Ubuntu):
assignee: Mathieu Trudel-Lapierre (mathieu-tl) → nobody
status: Triaged → Fix Released
Changed in partman-auto (Ubuntu Trusty):
status: Triaged → In Progress

Hello bugproxy, or anyone else affected,

Accepted partman-auto into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/partman-auto/118ubuntu3.14.04.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in partman-auto (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed

------- Comment From <email address hidden> 2015-07-16 06:39 EDT-------
(In reply to comment #11)
> Hello bugproxy, or anyone else affected,
>
> Accepted partman-auto into trusty-proposed. The package will build now and
> be available at
> https://launchpad.net/ubuntu/+source/partman-auto/118ubuntu3.14.04.2 in a
> few hours, and then in the -proposed repository.
>
> Please help us by testing this new package. See
> https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to
> enable and use -proposed. Your feedback will aid us getting this update out
> to other Ubuntu users.
>
> If this package fixes the bug for you, please add a comment to this bug,
> mentioning the version of the package you tested, and change the tag from
> verification-needed to verification-done. If it does not fix the bug for
> you, please add a comment stating that, and change the tag to
> verification-failed. In either case, details of your testing will help us
> make a better decision.
>
> Further information regarding the verification process can be found at
> https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in
> advance!

I have tried the updated package and confirm that the problem is fixed.

tags: added: verification-done
removed: verification-needed

Default Comment by Bridge

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package partman-auto - 118ubuntu3.14.04.2

---------------
partman-auto (118ubuntu3.14.04.2) trusty; urgency=medium

  * Combine / and /usr in the multi recipe for ppc64el; this makes sure / has
    enough space for completing the install, and brings us in sync with the
    multi recipe for later releases. (LP: #1461860)

 -- Mathieu Trudel-Lapierre <email address hidden> Wed, 08 Jul 2015 14:25:32 -0400

Changed in partman-auto (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for partman-auto has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints