guided lvm creation fails with certain hostnames in alternate installer

Bug #812162 reported by Antti Kaijanmäki on 2011-07-18
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
partman-auto-lvm (Ubuntu)
High
Unassigned

Bug Description

If you set hostname in network configuration section of debian installer to "zero", "null", etc. found under /dev/ the guided lvm creation fails with error: "/dev/<hostname>: already exists in filesystem" (see screenshot)

This can simply be circumvented by adding "lvm-" prefix to the lvm devices.

I ran into this with 10.04.2 amd64 server installer.

Antti Kaijanmäki (kaijanmaki) wrote :
Colin Watson (cjwatson) on 2013-12-11
affects: debian-installer (Ubuntu) → partman-auto-lvm (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in partman-auto-lvm (Ubuntu):
status: New → Confirmed
Colin Watson (cjwatson) on 2013-12-11
Changed in partman-auto-lvm (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → High
Dimitri John Ledkov (xnox) wrote :

As a follow-up to the previous bug #154086 it appears that this problem has still not been fixed.

Case in point that bug #453276 is still present, thus upon creating a new partition we really should be clearing it (e.g. at least pvremove and the like)

Also upon removing volumes and groups we should be zeroing the lvm metadata off it

Changed in partman-auto-lvm (Ubuntu):
assignee: nobody → Dimitri John Ledkov (xnox)
Changed in partman-auto-lvm (Ubuntu):
assignee: Dimitri John Ledkov (xnox) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments