LVM server installs with maximum root partition size

Bug #160156 reported by Ketil Malde on 2007-11-05
10
Affects Status Importance Assigned to Milestone
partman-auto-lvm (Ubuntu)
Wishlist
Unassigned

Bug Description

When I installed Gutsy from a server iso image, I chose LVM partitioning. I messed about a bit in the partition setup, but couldn't find a way to manually specify a set of LVM partitions to use, and thought I'd fix it later. Unfortunately, Ubuntu divided the entire disk into 1% swap, and 99% (187Gb) root. Since ext3 cannot be shrunk online, and / cannot be unmounted, I need to reboot to fix this. I think it would be much better if LVM defaulted to a more modest size for root, since 1) file systems can grow online, and 2) LVM isn't particularly useful if you only want a single partition anyway.

-k

Ketil Malde (ketil-ii) wrote :

Just to clarify this a bit, the above is when choosing the "Guided" partitioning, I redid the install with manual partitioning, and got the system configured the way I wanted it. So the problem is the Guided partitioning choosing a suboptimal configuration. A 10G root partition should suffice, I think - or, the user could perhaps choose between multiple predefined configurations (e.g. single root, root+home, root+var+tmp+home, etc)

-k

Dan Trevino (dantrevino) wrote :

assigned to server team

Scott Kitterman (kitterman) wrote :

Unassigned. Server team doesn't work that way. You want to evaluate it feel free, but don't assign things to teams that you aren't in charge of or that don't have a policy that supports it (Kernel team does as an example).

Colin Watson (cjwatson) on 2009-02-11
Changed in partman-auto-lvm:
importance: Undecided → Wishlist
status: New → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package partman-auto-lvm - 32ubuntu2

---------------
partman-auto-lvm (32ubuntu2) jaunty; urgency=low

  * Ask how much of the VG should be used for logical volumes, rather than
    unconditionally using it all (LP: #160156).

 -- Colin Watson <email address hidden> Fri, 13 Feb 2009 10:51:20 +0000

Changed in partman-auto-lvm:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers