Ubuntu

cannot label fat 32 partitions

Reported by Vertago1 on 2012-07-30
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KDE Partition Manager
Fix Released
Wishlist
partitionmanager (Ubuntu)
Wishlist
Unassigned

Bug Description

I submitted a bug through KDE, but found out that is is a problem with the code snapshot used for kubuntu (https://bugs.kde.org/show_bug.cgi?id=304209).

The last post at the time of me submitting this bug report is: "Gentoo ship an svn snapshot that supports setting labels for FAT32. Kubuntu ships the original 1.0.3 which does not."

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: partitionmanager 1.0.3-0ubuntu4
ProcVersionSignature: Ubuntu 3.2.0-27.43-generic 3.2.21
Uname: Linux 3.2.0-27-generic x86_64
ApportVersion: 2.0.1-0ubuntu11
Architecture: amd64
Date: Mon Jul 30 14:11:21 2012
InstallationMedia: Kubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120423)
ProcEnviron:
 LANGUAGE=
 TERM=xterm
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: partitionmanager
UpgradeStatus: No upgrade log present (probably fresh install)

partitionmanager does not support labeling fat32 partitions.

Reproducible: Always

Steps to Reproduce:
1. have a fat32 partition on the system (on a usb flash drive for example).
2. open partitionmanager and navigate to the physical volume of choice.
3. right click and select properties for the fat32 partition
4. the volume label is not editable because this feature is not yet supported (but is requested).
Actual Results:
You cannot set or change the volume label

Expected Results:
You would be able to set or change the volume label

This is a requested feature.

I can edit the label of FAT32 partitions without problem. Did you unmount the partition before trying to change its label?

I never mounted it. What version are you using?

Using partitionmanager-1.0.3_p20110912 (a snapshot) in Gentoo.

I am using 1.0.3-0ubuntu4 (precise). I will probably need to see what the compilation flags are for Gentoo.

I downloaded the source package at http://packages.ubuntu.com/source/precise/partition-manager
built it it, ran it, and it cannot change the volume label for fat32 either.
In the CHANGES file it has: 1.0.3 (2010-09-01)
as the last entry.

To do the build I extracted the tar, installed the dependent packages, made the build directory, ran cmake, make and then found the executable and ran sudo ./partitionmanager-bin

Are there any patches to the Gentoo package?

Gentoo ship an svn snapshot that supports setting labels for FAT32. Kubuntu ships the original 1.0.3 which does not.

Vertago1 (vertago1) wrote :
Changed in partitionman:
importance: Unknown → Wishlist
status: Unknown → Fix Released
Changed in partitionmanager (Ubuntu):
status: New → Fix Committed
importance: Undecided → Wishlist
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.