partimage segfaults on ntfs

Bug #235394 reported by Rocko on 2008-05-28
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
partimage (Ubuntu)
Undecided
Unassigned

Bug Description

Running partimage 0.6.4-17 on Hardy 2.6.24-17-generic amd64, I get a segmentation fault when I try to save an NTFS partition.

It segfaults immediately after giving the warning that NTFS support is experimental.

Attached is the logfile created by partimage's -g10 option.

Rocko (rockorequin) wrote :
randomas (randomas) wrote :

I would just like to confirm this bug and add my log.
I also had trouble recognizing images made with previous 32 bit versions of partimage, but I doubt it's related.

Rocko (rockorequin) wrote :

The problem is that the 64 bit repositories contain a very old version of partimage, ie 0.6.4 - the latest stable version is 0.6.7-1 in the 32 bit repositories.

I tried the 32 bit version of partimage for Hardy on a 32-bit PC: it had no trouble saving NTFS partitions.

I then built a 64-bit version of partimage 0.6.7 manually using sources downloaded from partimage.org, and it had no trouble saving the NTFS partition.

So, how do we request that the 64-bit repositories get updated with the latest version?

Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage . I have classified this bug as a bug in partimage.

drakesoft (powerschorsch21) wrote :

Same problem (Ubuntu 8.04 AMD64)

I have added the tag "needs-packaging" because i've had the same error. The problem is exactly what Rocko says.

This also occurs on the latest version: 8.10 alternate amd64

Phillip Susi (psusi) wrote :

Three isn't a separate 64 bit repository, and we are currently up to 0.6.8-2, so I'm going to say this was fixed long ago.

Changed in partimage (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers