'guided resize' partioning leaves Mac unbootable

Bug #856826 reported by Chad A. Davis on 2011-09-22
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
High
Unassigned
apport (Ubuntu)
High
Brian Murray
Precise
High
Brian Murray
parted (Ubuntu)
High
Colin Watson
Precise
High
Colin Watson

Bug Description

After installing with ubuntu-oneiric-alternate-amd64+mac.iso (ISO from 2011-09-21) this MacBookPro6,2 is not bootable. I used the 'guided resize' partitioning option to split an existing ext4 partition to make space. The original system was working fine and the resulting partition table, after the install, looks reasonable (two ext4 partitions, two swap parititons, and a bios_grub partition).

This would appear to be a regression. If I remember rightly, this worked correctly in Oneiric once before.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: debian-installer 20101020ubuntu65
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Uname: Linux 3.0.0-11-generic x86_64
ApportVersion: 1.23-0ubuntu1
Architecture: amd64
CasperVersion: 1.284
Date: Thu Sep 22 21:36:04 2011
Dependencies:

DeviceMapperTables:
 Error: command ['dmsetup', 'table'] failed with exit code 1: /dev/mapper/control: open failed: Permission denied
 Failure to communicate with kernel device-mapper driver.
 Command failed
DmraidDevices: Error: command ['dmraid', '-r'] failed with exit code 1: ERROR: you must be root
DmraidSets: Error: command ['dmraid', '-s'] failed with exit code 1: ERROR: you must be root
LiveMediaBuild: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64+mac (20110921.2)
MachineType: Apple Inc. MacBookPro6,2
MemoryUsage:
 total used free shared buffers cached
 Mem: 3860344 1354748 2505596 0 130964 571360
 -/+ buffers/cache: 652424 3207920
 Swap: 8058476 0 8058476
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: file=/cdrom/preseed/hostname.seed boot=casper initrd=/casper/initrd.lz quiet splash -- maybe-ubiquity
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 07/26/10
dmi.bios.vendor: Apple Inc.
dmi.bios.version: MBP61.88Z.0057.B0C.1007261552
dmi.board.asset.tag: Base Board Asset Tag#
dmi.board.name: Mac-F22586C8
dmi.board.vendor: Apple Inc.
dmi.board.version: MacBookPro6,2
dmi.chassis.type: 10
dmi.chassis.vendor: Apple Inc.
dmi.chassis.version: Mac-F22586C8
dmi.modalias: dmi:bvnAppleInc.:bvrMBP61.88Z.0057.B0C.1007261552:bd07/26/10:svnAppleInc.:pnMacBookPro6,2:pvr1.0:rvnAppleInc.:rnMac-F22586C8:rvrMacBookPro6,2:cvnAppleInc.:ct10:cvrMac-F22586C8:
dmi.product.name: MacBookPro6,2
dmi.product.version: 1.0
dmi.sys.vendor: Apple Inc.

Related branches

Chad A. Davis (chadadavis) wrote :
Chad A. Davis (chadadavis) wrote :
Chad A. Davis (chadadavis) wrote :
Chad A. Davis (chadadavis) wrote :

Also occurs with kubuntu-oneiric-desktop-amd64+mac.iso . I.e. it's not specific to debian-installer.

summary: - d-i 'guided resize' partioning leaves Mac unbootable
+ 'guided resize' partioning leaves Mac unbootable
Chad A. Davis (chadadavis) wrote :
Chad A. Davis (chadadavis) wrote :
Chad A. Davis (chadadavis) wrote :
tags: added: ubiquity-2.7.35
Brian Murray (brian-murray) wrote :

Looking at the data collected in this bug report by apport we can see there is an issue with the debian-installer source package hook and its ability to collect dmraid information. (Its failing because the commands are not executed as root.)

Changed in apport (Ubuntu):
assignee: nobody → Brian Murray (brian-murray)
importance: Undecided → High
status: New → In Progress
Changed in ubiquity (Ubuntu):
assignee: nobody → Ubuntu Installer Team (ubuntu-installer)
importance: Undecided → High
Colin Watson (cjwatson) wrote :

Can I see the output of 'sudo sfdisk -d -uS' when it's in the broken state, please?

affects: ubiquity (Ubuntu) → partman-base (Ubuntu)
Changed in partman-base (Ubuntu):
assignee: Ubuntu Installer Team (ubuntu-installer) → Colin Watson (cjwatson)
status: New → Incomplete
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apport - 1.23-0ubuntu2

---------------
apport (1.23-0ubuntu2) oneiric; urgency=low

  [ Martin Pitt ]
  * debian/control: Bump GIR dependencies to ensure that we don't run this
    against older versions against gir1.2-glib-2.0, which still have a wrong
    API for markup_escape_text(). (LP: #851450)

  [ Brian Murray ]
  * data/general-hooks/ubuntu.py: also check CurrentDmesg for disk errors
    as some package hooks add it
  * data/package-hooks/source_debian-installer.py: for dmraid collection use
    attach_root_command_outputs (LP: #856826)
 -- Martin Pitt <email address hidden> Wed, 28 Sep 2011 07:12:19 +0200

Changed in apport (Ubuntu):
status: In Progress → Fix Released
Chad A. Davis (chadadavis) wrote :

The partition table looks empty. I'm attaching sfdisk output, as well as the installer logs again (syslog, partman, installer/debug).

For the latest install, I'm using ubuntu-oneiric-desktop-amd64+mac.iso from 2011-09-22

Chad A. Davis (chadadavis) wrote :
Chad A. Davis (chadadavis) wrote :
Chad A. Davis (chadadavis) wrote :
Chad A. Davis (chadadavis) wrote :
Changed in grub2 (Ubuntu):
importance: Undecided → High
Changed in partman-base (Ubuntu):
status: Incomplete → New
Chad A. Davis (chadadavis) wrote :

I installed libparted0debian1 version 2.3-6ubuntu3+ppa1 from ppa:cjwatson/ppa into the live session and had the same result. The system does not boot after install. Will attach installer logs.

Chad A. Davis (chadadavis) wrote :
Chad A. Davis (chadadavis) wrote :
Chad A. Davis (chadadavis) wrote :
Chad A. Davis (chadadavis) wrote :
Chad A. Davis (chadadavis) wrote :
Chad A. Davis (chadadavis) wrote :
Chad A. Davis (chadadavis) wrote :

Seems to also occur when doing an in-place upgrade (from Oneiric to Oneiric).

I started from a working Oneiric system (from ubuntu-oneiric-desktop-amd64+mac.iso from 2011-10-11) which was installed with "guided: entire disk" partitioning (i.e. using ext4).

I booted ubuntu-oneiric-desktop-amd64+mac.iso from 2011-10-12 and chose the upgrade option.

It's not clear if the cause is the same, but the symptoms (that the installed system does not boot) are the same. The installation appeared to finish normally.

Cengiz Vural (b-launchpad-ok) wrote :

Same here. Installed on MacBookPro3,1 and MacPro6,2. Both are unable to boot. Workaround: boot using the live cd into the first partition, install gpttools and run gpttools /dev/sda, reboot.

Changed in ubuntu-release-notes:
status: New → Fix Committed
importance: Undecided → High
tags: added: rls-mgr-p-tracking
Steve Langasek (vorlon) on 2011-10-13
Changed in ubuntu-release-notes:
status: Fix Committed → Fix Released
Colin Watson (cjwatson) wrote :

For the record (and before I forget), the problem here is that the EFI System Partition / BIOS Boot Partition (whichever it is) isn't being recognised as such by partman/libparted and so isn't getting the correct (indeed any) MBR partition type when gptsynced, which causes libparted to revert to protective MBR style, which causes everything to fall over in a heap.

Steve Langasek (vorlon) on 2011-10-26
tags: added: rls-p-tracking
Steve Langasek (vorlon) on 2011-11-15
Changed in partman-base (Ubuntu Precise):
milestone: none → ubuntu-12.04-beta-1
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in grub2 (Ubuntu):
status: New → Confirmed
Changed in partman-base (Ubuntu):
status: New → Confirmed
hackel (hackel) wrote :

Cengiz, you mention the "gpttools" command, which is also included in the 11.10 release notes, however there is no such package nor command that I can find. Can you please be more specific? Are you talking about gptsync?

Steve Langasek (vorlon) on 2012-02-23
Changed in partman-base (Ubuntu Precise):
milestone: ubuntu-12.04-beta-1 → ubuntu-12.04-beta-2
Colin Watson (cjwatson) wrote :

So, I think I've managed to fix this. Unfortunately, I don't actually have hardware to hand so that I can test it directly. I've written a test script which exercises as many cases as I can think of, and they all pass now, but the real test will be trying this on actual hardware. As such, please try tomorrow's daily build, and if it still goes wrong then please do let me know and reopen this bug.

no longer affects: grub2 (Ubuntu)
no longer affects: grub2 (Ubuntu Precise)
affects: partman-base (Ubuntu Precise) → parted (Ubuntu Precise)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package parted - 2.3-8ubuntu4

---------------
parted (2.3-8ubuntu4) precise; urgency=low

  * At least some Intel Macs get rather upset if we revert to a protective
    MBR, so try harder to avoid this and to do a better job of writing a
    hybrid MBR:
    - Write a type code of 0x83 for more filesystems, and 0xda for
      non-filesystem partitions.
    - Do not rely on filesystem probing to recognise EFI System Partitions.
    - Write a protective partition starting at LBA 1 if we find an EFI
      System Partition or BIOS Boot Partition in the first position, even if
      it does not really begin at LBA 1 (LP: #856826).
    - Ensure that protective partitions corresponding to an ESP or BBP
      always have starting cylinder 0, head 0, sector 1.
    - Don't revert to a protective MBR just because the first GPT partition
      wasn't recognised as anything in particular.
    - Add tests for hybrid MBR syncing.
 -- Colin Watson <email address hidden> Thu, 08 Mar 2012 15:44:55 +0000

Changed in parted (Ubuntu Precise):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers