Mac cannot boot after manual partitioning, unless using ext4

Bug #856763 reported by Chad A. Davis on 2011-09-22
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Medium
Kate Stewart
parted (Ubuntu)
Medium
Unassigned
Oneiric
Medium
Unassigned
Precise
Medium
Unassigned

Bug Description

I performed manual partitioning. In addition to a swap partition and the reiserfs partition, I left several megabytes free at the beginning of the disk for the GPT/bios_grub partition (the approach works fine for ext4 partitions). The installation proceeds without error. On reboot the Mac "Folder with question mark" icon is shown (meaning no bootable partitions found).

This is ubuntu-oneiric-desktop-amd64+mac from 2011-09-21.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: parted 2.3-6ubuntu3
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Uname: Linux 3.0.0-11-generic x86_64
ApportVersion: 1.23-0ubuntu1
Architecture: amd64
CasperVersion: 1.284
Date: Thu Sep 22 19:57:24 2011
LiveMediaBuild: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64+mac (20110921.2)
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: parted
UpgradeStatus: No upgrade log present (probably fresh install)

Chad A. Davis (chadadavis) wrote :
Chad A. Davis (chadadavis) wrote :
Chad A. Davis (chadadavis) wrote :
Chad A. Davis (chadadavis) wrote :
Changed in parted (Ubuntu):
importance: Undecided → Medium
Chad A. Davis (chadadavis) wrote :

And the output from 'sfdisk -d -uS' after the partitioning is attached. Is it correct that the reiserfs partition type should be 'ef' ?

Chad A. Davis (chadadavis) wrote :

Also, when I do try to manually create the efi partition (in case it's not automatically created) I get:

  The efi file system creation in partition #3 of SCSI1 (0,0,0) (sda) failed.

In this case I tried to create an xfs filesystem, rather than a reiserfs, but the failure occurred while trying to create the efi partition. So, I believe that it belongs in this bug report.

I will attach these new logs as well.

summary: - Mac cannot boot from reiserfs
+ Mac cannot boot after manual partitioning, unless using ext4
Chad A. Davis (chadadavis) wrote :
Chad A. Davis (chadadavis) wrote :
Chad A. Davis (chadadavis) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in parted (Ubuntu):
status: New → Confirmed
Changed in ubuntu-release-notes:
status: New → Fix Committed
importance: Undecided → Medium
assignee: nobody → Kate Stewart (kate.stewart)
Changed in parted (Ubuntu Oneiric):
status: New → Confirmed
importance: Undecided → Medium
Changed in ubuntu-release-notes:
status: Fix Committed → Fix Released
uMac (uvaio) wrote :

Hi, do you think released fix may also help to this problem? https://bugs.launchpad.net/ubuntu/+source/grub2/+bug/878003

Colin Watson (cjwatson) wrote :

Chad, the EFI partition creation problem you had is part of bug 811485.

Colin Watson (cjwatson) wrote :

Although the exact symptoms are a bit different, I intend to fix this in the same way as bug 855871, and have posted a more detailed explanation there. Accordingly, I'll mark this as a duplicate.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers