parted_server crashed with SIGABRT in __kernel_vsyscall()

Bug #796891 reported by BBerastegui on 2011-06-14
32
This bug affects 5 people
Affects Status Importance Assigned to Milestone
parted (Fedora)
Fix Released
High
parted (Ubuntu)
Medium
Colin Watson

Bug Description

Binary package hint: ubiquity

Crash every time i try to run either Gparted or ubiquity, some error about gpt partition in the HDD...

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: ubiquity 2.6.10
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic i686
Architecture: i386
Date: Mon Jun 13 20:47:31 2011
ExecutablePath: /bin/parted_server
LiveMediaBuild: Xubuntu 11.04 "Natty Narwhal" - Release i386 (20110427)
ProcCmdline: parted_server
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
Signal: 6
SourcePackage: ubiquity
StacktraceTop:
 __kernel_vsyscall ()
 raise () from /lib/i386-linux-gnu/libc.so.6
 abort () from /lib/i386-linux-gnu/libc.so.6
 ped_assert () from /lib/libparted.so.0
 ped_geometry_read () from /lib/libparted.so.0
Title: parted_server crashed with SIGABRT in __kernel_vsyscall()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

Related branches

BBerastegui (borjaberastegui) wrote :

StacktraceTop:
 __kernel_vsyscall ()
 raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
 abort () at abort.c:92
 ped_assert (cond_text=0xedf2aa "offset >= 0", file=0xedf274 "../../libparted/cs/geom.c", line=296, function=0xedf400 "ped_geometry_read") at ../../libparted/debug.c:112
 ped_geometry_read (geom=0x93e94d0, buffer=0xbff3575c, offset=-1, count=1) at ../../libparted/cs/geom.c:296

Changed in ubiquity (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace

abrt version: 1.1.18
architecture: i686
Attached file: backtrace, 7325 bytes
cmdline: partprobe
component: parted
Attached file: coredump, 536576 bytes
crash_function: ped_assert
executable: /sbin/partprobe
kernel: 2.6.35.13-91.fc14.i686
package: parted-2.3-4.fc14
rating: 4
reason: Process /sbin/partprobe was killed by signal 6 (SIGABRT)
release: Fedora release 14 (Laughlin)
time: 1308572008
uid: 0

How to reproduce
-----
after i modify my partition table, use partprobe to sync my hard disk, core dumped...

my system:
FC14

my partition table:
# fdisk -l

Disk /dev/sda: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders, total 625142448 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x4d74c238

   Device Boot Start End Blocks Id System
/dev/sda1 63 610469 305203+ 83 Linux
/dev/sda2 610470 123491654 61440592+ 83 Linux
/dev/sda3 123491655 184924214 30716280 c W95 FAT32 (LBA)
/dev/sda4 184924215 625137344 220106565 f W95 Ext'd (LBA)
/dev/sda5 184924278 287322524 51199123+ 7 HPFS/NTFS
/dev/sda6 287322588 389720834 51199123+ 7 HPFS/NTFS
/dev/sda7 389720898 408147389 9213246 af HFS / HFS+
/dev/sda8 * 408147453 469579949 30716248+ af HFS / HFS+
/dev/sda9 469580013 475716779 3068383+ 82 Linux swap / Solaris
/dev/sda10 475716843 625137344 74710251 83 Linux

Created attachment 505654
File: backtrace

What does the output of parted -l show?

Package: parted-2.3-4.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)

How to reproduce
-----
1. parted->print->crashed!
2.
3.

Hi Brian,

[root@localhost ~]# parted -l
Backtrace has 17 calls on stack:
  17: /lib/libparted.so.0(ped_assert+0x2b) [0x813bbb]
  16: /lib/libparted.so.0(ped_geometry_read+0x11f) [0x81d67f]
  15: /lib/libparted.so.0(hfsplus_probe+0x424) [0x83dfb4]
  14: /lib/libparted.so.0(ped_file_system_probe_specific+0x6e) [0x81562e]
  13: /lib/libparted.so.0(ped_file_system_probe+0x81) [0x815741]
  12: /lib/libparted.so.0() [0x84cf0b]
  11: /lib/libparted.so.0() [0x84d027]
  10: /lib/libparted.so.0() [0x84d027]
  9: /lib/libparted.so.0() [0x84d027]
  8: /lib/libparted.so.0() [0x84cf6d]
  7: /lib/libparted.so.0() [0x84d540]
  6: /lib/libparted.so.0(ped_disk_new+0x75) [0x81bc95]
  5: parted() [0x804c68b]
  4: parted() [0x804d7a8]
  3: parted(main+0x1971) [0x8052871]
  2: /lib/libc.so.6(__libc_start_main+0xe6) [0x435e36]
  1: parted() [0x804bb91]
已放弃 (core dumped)

---
Flos

BTW: even creating partition interfaces of anaconda gui or console setup of F14 or F13 have the same problem.

Created attachment 524242
first 512B of my hardisk

first 512 Bytes of my Hardisk(/dev/sda)

[root@localhost ~]# fdisk -l /dev/sda

Disk /dev/sda: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders, total 625142448 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x4d74c238

   Device Boot Start End Blocks Id System
/dev/sda1 63 610469 305203+ 83 Linux
/dev/sda2 610470 123491654 61440592+ 83 Linux
/dev/sda3 123491655 184924214 30716280 c W95 FAT32 (LBA)
/dev/sda4 184924215 625137344 220106565 f W95 Ext'd (LBA)
/dev/sda5 184924278 287322524 51199123+ 7 HPFS/NTFS
/dev/sda6 287322588 389720834 51199123+ 7 HPFS/NTFS
/dev/sda7 389720898 408147389 9213246 eb BeOS fs
/dev/sda8 * 408147453 469579949 30716248+ af HFS / HFS+
/dev/sda9 469580013 475716779 3068383+ 82 Linux swap / Solaris
/dev/sda10 475716843 625137344 74710251 83 Linux
[root@localhost ~]#

The backtrace looks like the one that shows up when there is a very short partition (< 8 block) but I see that all of yours are nowhere near that small. Thanks for the additional info.

Could you give this scratch build a try?

http://koji.fedoraproject.org/koji/taskinfo?taskID=3409804

The hfs probe code looks like it checks the size of the partition pretty well, but there were a few spots where device-supplied values, if they were wrong, could result in negative values.

Download full text (4.7 KiB)

Hi,

very good! it seems the problem has gone! :D i rebuild the SRPM in my Fedora 14 successfully. here is my result:
-----------------------------------
[xx@xx]sudo yum-builddep parted-3.0-3.fc17.src.rpm
总下载量:221 k
Installed size: 461 k
确定吗?[y/N]:y
下载软件包:
(1/3): device-mapper-devel-1.02.63-2.fc14.i686.rpm | 94 kB 00:01
(2/3): libblkid-devel-2.18-4.8.fc14.i686.rpm | 60 kB 00:01
(3/3): libudev-devel-161-10.fc14.i686.rpm | 67 kB 00:00
-----------------------------------------------------------------------------------------------------------------------------
总计 47 kB/s | 221 kB 00:04
运行 rpm_check_debug
执行事务测试
事务测试成功
执行事务
  正在安装 : libudev-devel-161-10.fc14.i686 1/3
  正在安装 : device-mapper-devel-1.02.63-2.fc14.i686 2/3
  正在安装 : libblkid-devel-2.18-4.8.fc14.i686 3/3

已安装:
  device-mapper-devel.i686 0:1.02.63-2.fc14 libblkid-devel.i686 0:2.18-4.8.fc14

作为依赖被安装:
  libudev-devel.i686 0:161-10.fc14

完毕!

[xx@xx]$ rpmbuild --rebuild parted-3.0-3.fc17.src.rpm
...
Checking for unpackaged file(s): /usr/lib/rpm/check-files /pub/RPM_build/BUILDROOT/parted-3.0-3.fc17.i386
Wrote: /pub/RPM_build/RPMS/i686/parted-3.0-3.fc14.i686.rpm
Wrote: /pub/RPM_build/RPMS/i686/parted-devel-3.0-3.fc14.i686.rpm
Wrote: /pub/RPM_build/RPMS/i686/parted-debuginfo-3.0-3.fc14.i686.rpm
...

[root@localhost i686]# ls
compat-wireless-debuginfo-2011_08_27-1.fc14.i686.rpm kmod-compat-wireless-2.6.39-1.fc14.3.i686.rpm
compat-wireless-debuginfo-2011_08_27-3.fc14.i686.rpm mldonkey
compat-wireless-debuginfo-2.6.39-1.fc14.3.i686.rpm paco-1.10.12-4.fc14.i686.rpm
ghex-2.24.0-5.fc14.i686.rpm paco-debuginfo-1.10.12-4.fc14.i686.rpm
ghex-debuginfo-2.24.0-5.fc14.i686.rpm paco-gpaco-1.10.12-4.fc14.i686.rpm
ghex-devel-2.24.0-5.fc14.i686.rpm parted-3.0-3.fc14.i686.rpm
guitone-1.0-0.1.rc4.fc12.i686.rpm parted-debuginfo-3.0-3.fc14.i686.rpm
guitone-debuginfo-1.0-0.1.rc4.fc12.i686.rpm parted-devel-3.0-3.fc14.i686.rpm
kmod-compat-wireless-2011_08_27-1.fc14.i686.rpm reiserfs-utils-3.6.21-2.fc14.i686.rpm
kmod-compat-wireless-2011_08_27-3.fc14.i686.rpm reiserfs-utils-debuginfo-3.6.21-2.fc14.i686.rpm

[root@localhost i686]# rpm -e parted
error: Failed dependencies:
 libparted.so.0 is needed by (installed) udisks-1.0.2-4.fc14.i686
 libparted.so.0 is needed by (installed) pyparted-3.4-5.fc14.i686

[root@localhost i686]# rpm -e parted --nodeps

[root@localhost i686]# rpm -Uvh parted-3.0-3.fc14.i686.rpm
Preparing... ################################...

Read more...

but it seems that parted cannot recognize filesystem of the 8th partition, which can be show by fdisk. and the 7th should be BeOS?

-----------------------------------
[root@localhost i686]# fdisk -l

Disk /dev/sda: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders, total 625142448 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x4d74c238

   Device Boot Start End Blocks Id System
/dev/sda1 63 610469 305203+ 83 Linux
/dev/sda2 610470 123491654 61440592+ 83 Linux
/dev/sda3 123491655 184924214 30716280 c W95 FAT32 (LBA)
/dev/sda4 184924215 625137344 220106565 f W95 Ext'd (LBA)
/dev/sda5 184924278 287322524 51199123+ 7 HPFS/NTFS
/dev/sda6 287322588 389720834 51199123+ 7 HPFS/NTFS
/dev/sda7 389720898 408147389 9213246 eb BeOS fs
/dev/sda8 * 408147453 469579949 30716248+ af HFS / HFS+
/dev/sda9 469580013 475716779 3068383+ 82 Linux swap / Solaris
/dev/sda10 475716843 625137344 74710251 83 Linux

and i have another small request, could this fix be ported to Fedora 16? because parted of any previous version cannot be run on my computer by anaconda. :P
Thanks !!!

Thanks for testing this. I think I'd classify that as a new bug (not detecting BeOS correctly).

that's ok. since this bug has been fixed, should i change the STATUS to CLOSED or wait others to confirm it?

It will get closed when I submit an update for F14. Thanks.

parted-3.0-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/parted-3.0-3.fc16

get it, thanks!

parted-2.3-11.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/parted-2.3-11.fc15

parted-2.3-5.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/parted-2.3-5.fc14

Package parted-2.3-5.fc14:
* should fix your issue,
* was pushed to the Fedora 14 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing parted-2.3-5.fc14'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-14410
then log in and leave karma (feedback).

parted-3.0-3.fc16 has been pushed to the Fedora 16 stable repository. If problems still persist, please make note of it in this bug report.

FYI, I applied that patch upstream and added a test:

http://thread.gmane.org/gmane.comp.gnu.parted.bugs/10535/focus=10594

parted-2.3-5.fc14 has been pushed to the Fedora 14 stable repository. If problems still persist, please make note of it in this bug report.

parted-2.3-11.fc15 has been pushed to the Fedora 15 stable repository. If problems still persist, please make note of it in this bug report.

Colin Watson (cjwatson) on 2012-03-20
affects: ubiquity (Ubuntu) → partman-base (Ubuntu)
affects: partman-base (Ubuntu) → parted (Ubuntu)
Colin Watson (cjwatson) on 2012-03-20
visibility: private → public
Changed in parted (Ubuntu):
status: New → Triaged
assignee: nobody → Colin Watson (cjwatson)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package parted - 2.3-8ubuntu5

---------------
parted (2.3-8ubuntu5) precise; urgency=low

  * Backport from upstream:
    - HFS/HFS+ probe: don't let a corrupt FS evoke failed assertion
      (LP: #796891).
 -- Colin Watson <email address hidden> Tue, 20 Mar 2012 20:13:53 +0000

Changed in parted (Ubuntu):
status: Triaged → Fix Released
Changed in parted (Fedora):
importance: Unknown → High
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.