--list option broken, segfaults (in 64 bit)

Bug #522947 reported by Fabián Rodríguez on 2010-02-17
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
parted (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: parted

It seems parted 64 bit is broken in Karmic, or at least the --list option.

This is the output I get:

device-mapper: deps ioctl failed: No such device or address

You found a bug in GNU Parted! Here's what you have to do:

Don't panic! The bug has most likely not affected any of your data.
Help us to fix this bug by doing the following:

Check whether the bug has already been fixed by checking
the last version of GNU Parted that you can find at:

 http://ftp.gnu.org/gnu/parted/

Please check this version prior to bug reporting.

If this has not been fixed yet or if you don't know how to check,
please visit the GNU Parted website:

 http://www.gnu.org/software/parted

for further information.

Your report should contain the version of this release (1.8.8.1.159-1e0e)
along with the error message below, the output of

 parted DEVICE unit co print unit s print

and the following history of commands you entered.
Also include any additional information about your setup you
consider important.

Command History:
Segmentation fault

I don't have time to test upstream for now, but can re-test this in Lucid 64 if needs be.

ProblemType: Bug
Architecture: amd64
Date: Tue Feb 16 19:28:07 2010
DistroRelease: Ubuntu 9.10
NonfreeKernelModules: nvidia wl
Package: parted 1.8.8.git.2009.06.03-1ubuntu6
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-19.56-generic
SourcePackage: parted
Uname: Linux 2.6.31-19-generic x86_64

Fabián Rodríguez (magicfab) wrote :
Brian Murray (brian-murray) wrote :

Its not clear to from your bug report what command you were having an issue with but I guessed 'sudo parted --list' and was unable to recreate this bug on Karmic or Lucid on multiple amd64 systems. Am I trying the right command?

Changed in parted (Ubuntu):
status: New → Incomplete
Fabián Rodríguez (magicfab) wrote :

I can't reproduce this anymore on the same system.

Changed in parted (Ubuntu):
status: Incomplete → Fix Released
Fabián Rodríguez (magicfab) wrote :

Marking fix released as updates seem to have taken care of it.

Igor (igor47) wrote :

i just experienced this same issue here on ubuntu 10.04. same exact output running "sudo parted --list"

I'm also on a 64-bit system:
root@piglet:~# cat /etc/issue
Ubuntu 10.04 LTS \n \l

root@piglet:~# uname -a
Linux piglet 2.6.32-22-generic #33-Ubuntu SMP Wed Apr 28 13:28:05 UTC 2010 x86_64 GNU/Linux

   Hallo! !
   Customer

We offer a program that will help ANYONE with professional experience get a 100% verified Dergee: Doctoarte, Bacheolrs, Dcotorate.

Regardless of your location, you can receive a degree in your desired field. All you need is sufficient knowledge, military, or professional experience and you are on your way to an instant degree in your relevant field.

At your Own Schedule!. Ticket to Success. No Study!.

This is your chance to finally make the right move and receive your due benefits. If you are more than qualified with your experience, but are lacking that prestigious piece of paper known as a diploma that is often the passport to success.

--------------------
Give us a call NOW!

+ 1 - 646 - 537 - 1732
Please leave us your:
1) Your Name
2) Your Country
3) Phone No. with countrycode if outside USA

We will get back to you ASAP
--------------------

Do Not Reply to this Email.
We do not reply to text inquiries, and our server will reject all response traffic.
We apologize for any inconvenience this may have caused you.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers