Ubuntu

devkit-disks-helper-create-partition-table assert failure: *** stack smashing detected ***: <unknown> terminated

Reported by Rory on 2009-10-09
58
This bug affects 11 people
Affects Status Importance Assigned to Milestone
parted (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: devicekit-disks

devkit-disks-helper-create-partition-table assert failure: *** stack smashing detected ***: <unknown> terminated

Not sure if its related, but in karmic the USB startup disk creator doesn't work as it cannot build the boot manager - i think mbr is not installed?? (out of my depth here)

ProblemType: Crash
Architecture: i386
AssertionMessage: *** stack smashing detected ***: <unknown> terminated
Date: Fri Oct 9 10:30:44 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/lib/devicekit-disks/devkit-disks-helper-create-partition-table
NonfreeKernelModules: wl
Package: devicekit-disks 007-1karmic1
ProcCmdline: /usr/lib/devicekit-disks/devkit-disks-helper-create-partition-table /dev/sdc mbr
ProcEnviron: PATH=(custom, no user)
ProcVersionSignature: Ubuntu 2.6.31-12.41-generic
Signal: 6
SourcePackage: devicekit-disks
StacktraceTop:
 __kernel_vsyscall ()
 raise () from /lib/tls/i686/cmov/libc.so.6
 abort () from /lib/tls/i686/cmov/libc.so.6
 ?? () from /lib/tls/i686/cmov/libc.so.6
 __fortify_fail () from /lib/tls/i686/cmov/libc.so.6
Title: devkit-disks-helper-create-partition-table assert failure: *** stack smashing detected ***: <unknown> terminated
Uname: Linux 2.6.31-12-generic i686
UserGroups:

Rory (rory) wrote :

StacktraceTop:__kernel_vsyscall ()
*__GI_raise (sig=6)
*__GI_abort () at abort.c:92
__libc_message (do_abort=2,
*__GI___fortify_fail (

Changed in devicekit-disks (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Martin Pitt (pitti) wrote :

Do you have a way to reproduce this? Can you please give detailled steps? If you have a device plugged in which causes this crash, please do

  devkit-disks --dump > /tmp/dkd.txt

and attach /tmp/dkd.txt here. Thanks!

Changed in devicekit-disks (Ubuntu):
status: New → Incomplete
visibility: private → public
roryj (johnston-rory) wrote :

I've tried 2 usb sticks and the USB Startup Disk Creator failed for both (both sticks worked fine before). I think there is a prerequisite package missing in the karmic install for the USB Disk Creator?

Anyway, now i get... sudo fdisk -l
Disk /dev/sdc: 2076 MB, 2076180480 bytes
64 heads, 62 sectors/track, 255 cylinders
Units = cylinders of 3968 * 2048 = 8126464 bytes
Disk identifier: 0x8ef631df

   Device Boot Start End Blocks Id System
>> and i have to ctrl-c

devkit dump enclosed... (its /dev/sdc you want)

Martin Pitt (pitti) on 2009-10-12
Changed in devicekit-disks (Ubuntu):
status: Incomplete → New
status: New → Confirmed
Martin Pitt (pitti) wrote :

This actually seems to be a crash in libparted:

4 0x00470de8 in *__GI___fortify_fail (
    msg=0x4b2585 "stack smashing detected") at fortify_fail.c:32
No locals.
#5 0x00470da0 in __stack_chk_fail () at stack_chk_fail.c:29
No locals.
#6 0x0016b104 in __stack_chk_fail_local () from /lib/libparted-1.8.so.12
No symbol table info available.
#7 0x001571b3 in msdos_write (disk=0x0)
    at ../../../libparted/labels/dos.c:1179

affects: devicekit-disks (Ubuntu) → parted (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers