Ubuntu

Samsung HM160JI sata hdd > no devices detected

Reported by macat on 2007-10-28
8
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
linux-source-2.6.22 (Ubuntu)
Undecided
Unassigned
parted (Ubuntu)
Undecided
Unassigned

Bug Description

The problem issued in a first generation Apple Macbook.
I bought a new hard drive (Samsung HM160JI, 160gb, sata).
The OSX installed sucessfully(so OSX see the drive), but in the Ubuntu the Gparted signal : No devices detected.

I tried to boot with "pci=nomsi", but it wasn't success.

Thanks

///////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////

~$ lspci
00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
00:07.0 Performance counters: Intel Corporation Unknown device 27a3 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2 (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 02)
00:1f.2 IDE interface: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA IDE Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 02)
01:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8053 PCI-E Gigabit Ethernet Controller (rev 22)
02:00.0 Ethernet controller: Atheros Communications, Inc. AR5006EG 802.11 b/g Wireless PCI Express Adapter (rev 01)
03:03.0 FireWire (IEEE 1394): Agere Systems FW323 (rev 61)

///////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////

ubuntu@ubuntu:~$ dmesg | grep sata
ubuntu@ubuntu:~$ dmesg | grep tail
ubuntu@ubuntu:~$ dmesg | grep pci
[ 0.000000] Kernel command line: BOOT_IMAGE=/casper/vmlinuz file=/cdrom/preseed/ubuntu.seed boot=casper initrd=/casper/initrd.gz quiet splash --
[ 100.803920] ACPI: bus type pci registered
[ 100.846940] PCI: If a device doesn't work, try "pci=routeirq". If it helps, post a report
[ 102.129073] Allocate Port Service[0000:00:1c.0:pcie00]
[ 102.129132] Allocate Port Service[0000:00:1c.0:pcie02]
[ 102.129335] Allocate Port Service[0000:00:1c.1:pcie00]
[ 102.129387] Allocate Port Service[0000:00:1c.1:pcie02]
[ 100.156000] pci_hotplug: PCI Hot Plug PCI Core version: 0.5
[ 102.316000] ath_pci: 0.9.4.5 (0.9.3.2)

~$ dmesg | grep ata
[ 0.000000] BIOS-e820: 000000007e2d1000 - 000000007eebf000 (ACPI data)
[ 0.000000] BIOS-e820: 000000007eeef000 - 000000007ef00000 (ACPI data)
[ 0.000000] ACPI: SSDT 7EEBC000, 064F (r1 APPLE SataPri 1000 INTL 20050309)
[ 0.000000] ACPI: SSDT 7EEBB000, 069C (r1 APPLE SataSec 1000 INTL 20050309)
[ 98.956967] Memory: 2035716k/2065216k available (2015k kernel code, 28204k reserved, 916k data, 364k init, 1147712k highmem)
[ 98.956997] .data : 0xc02f7d26 - 0xc03dce84 ( 916 kB)
[ 5.336000] libata version 2.21 loaded.
[ 5.940000] ata_piix 0000:00:1f.1: version 2.11
[ 5.940000] scsi0 : ata_piix
[ 5.940000] scsi1 : ata_piix
[ 5.940000] ata1: PATA max UDMA/133 cmd 0x000101f0 ctl 0x000103f6 bmdma 0x000120c0 irq 14
[ 5.940000] ata2: PATA max UDMA/133 cmd 0x00010170 ctl 0x00010376 bmdma 0x000120c8 irq 15
[ 6.260000] ata1.00: ATAPI: MATSHITACD-RW CW-8221, GA0J, max UDMA/33
[ 6.432000] ata1.00: configured for UDMA/33
[ 6.600000] ata_piix 0000:00:1f.2: MAP [ P0 P2 XX XX ]
[ 6.600000] ata_piix 0000:00:1f.2: invalid MAP value 0
[ 6.756000] scsi2 : ata_piix
[ 6.756000] scsi3 : ata_piix
[ 6.756000] ata3: SATA max UDMA/133 cmd 0x000120d8 ctl 0x000120fe bmdma 0x00012020 irq 19
[ 6.756000] ata4: SATA max UDMA/133 cmd 0x000120d0 ctl 0x000120fa bmdma 0x00012028 irq 19
[ 101.116000] tpm_inf_pnp 00:03: TPM found: config base 0x4e, data base 0x4700, chip version 0x000b, vendor id 0x15d1 (Infineon), product id 0x000b (SLB 9635 TT 1.2)
[ 133.680000] appletouch: incomplete data package (first byte: 2, length: 4).

///////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////

$ ls /dev
1-1 nvidiactl ptyc1 ptye9 ptyr1 ptyt9 ptyw1 ptyy9 rtc tty31 ttya1 ttyc9 ttyp1 ttyr9 ttytd ttyw5 ttyyd usbdev4.1_ep81
1-2 oldmem ptyc2 ptyea ptyr2 ptyta ptyw2 ptyya scd0 tty32 ttya2 ttyca ttyp2 ttyra ttyte ttyw6 ttyye usbdev4.3_ep00
3-2 port ptyc3 ptyeb ptyr3 ptytb ptyw3 ptyyb sequencer tty33 ttya3 ttycb ttyp3 ttyrb ttytf ttyw7 ttyyf usbdev4.3_ep02
4-1 ppp ptyc4 ptyec ptyr4 ptytc ptyw4 ptyyc sequencer2 tty34 ttya4 ttycc ttyp4 ttyrc ttyu0 ttyw8 ttyz0 usbdev4.3_ep03
5-4 psaux ptyc5 ptyed ptyr5 ptytd ptyw5 ptyyd sg0 tty35 ttya5 ttycd ttyp5 ttyrd ttyu1 ttyw9 ttyz1 usbdev4.3_ep81
adsp ptmx ptyc6 ptyee ptyr6 ptyte ptyw6 ptyye shm tty36 ttya6 ttyce ttyp6 ttyre ttyu2 ttywa ttyz2 usbdev4.3_ep82
agpgart pts ptyc7 ptyef ptyr7 ptytf ptyw7 ptyyf snapshot tty37 ttya7 ttycf ttyp7 ttyrf ttyu3 ttywb ttyz3 usbdev4.3_ep83
audio ptya0 ptyc8 ptyp0 ptyr8 ptyu0 ptyw8 ptyz0 snd tty38 ttya8 ttyd0 ttyp8 ttys0 ttyu4 ttywc ttyz4 usbdev5.1_ep00
bus ptya1 ptyc9 ptyp1 ptyr9 ptyu1 ptyw9 ptyz1 sndstat tty39 ttya9 ttyd1 ttyp9 ttyS0 ttyu5 ttywd ttyz5 usbdev5.1_ep81
cdrom ptya2 ptyca ptyp2 ptyra ptyu2 ptywa ptyz2 sr0 tty4 ttyaa ttyd2 ttypa ttys1 ttyu6 ttywe ttyz6 usbdev5.4_ep00
cdrw ptya3 ptycb ptyp3 ptyrb ptyu3 ptywb ptyz3 stderr tty40 ttyab ttyd3 ttypb ttyS1 ttyu7 ttywf ttyz7 vcs
console ptya4 ptycc ptyp4 ptyrc ptyu4 ptywc ptyz4 stdin tty41 ttyac ttyd4 ttypc ttys2 ttyu8 ttyx0 ttyz8 vcs1
core ptya5 ptycd ptyp5 ptyrd ptyu5 ptywd ptyz5 stdout tty42 ttyad ttyd5 ttypd ttyS2 ttyu9 ttyx1 ttyz9 vcs2
disk ptya6 ptyce ptyp6 ptyre ptyu6 ptywe ptyz6 tpm0 tty43 ttyae ttyd6 ttype ttys3 ttyua ttyx2 ttyza vcs3
dri ptya7 ptycf ptyp7 ptyrf ptyu7 ptywf ptyz7 tty tty44 ttyaf ttyd7 ttypf ttyS3 ttyub ttyx3 ttyzb vcs4
dsp ptya8 ptyd0 ptyp8 ptys0 ptyu8 ptyx0 ptyz8 tty0 tty45 ttyb0 ttyd8 ttyq0 ttys4 ttyuc ttyx4 ttyzc vcs5
dvd ptya9 ptyd1 ptyp9 ptys1 ptyu9 ptyx1 ptyz9 tty1 tty46 ttyb1 ttyd9 ttyq1 ttys5 ttyud ttyx5 ttyzd vcs6
fd ptyaa ptyd2 ptypa ptys2 ptyua ptyx2 ptyza tty10 tty47 ttyb2 ttyda ttyq2 ttys6 ttyue ttyx6 ttyze vcs7
full ptyab ptyd3 ptypb ptys3 ptyub ptyx3 ptyzb tty11 tty48 ttyb3 ttydb ttyq3 ttys7 ttyuf ttyx7 ttyzf vcs8
fuse ptyac ptyd4 ptypc ptys4 ptyuc ptyx4 ptyzc tty12 tty49 ttyb4 ttydc ttyq4 ttys8 ttyv0 ttyx8 urandom vcsa
hpet ptyad ptyd5 ptypd ptys5 ptyud ptyx5 ptyzd tty13 tty5 ttyb5 ttydd ttyq5 ttys9 ttyv1 ttyx9 usb1 vcsa1
initctl ptyae ptyd6 ptype ptys6 ptyue ptyx6 ptyze tty14 tty50 ttyb6 ttyde ttyq6 ttysa ttyv2 ttyxa usb2 vcsa2
input ptyaf ptyd7 ptypf ptys7 ptyuf ptyx7 ptyzf tty15 tty51 ttyb7 ttydf ttyq7 ttysb ttyv3 ttyxb usb3 vcsa3
kmem ptyb0 ptyd8 ptyq0 ptys8 ptyv0 ptyx8 ram0 tty16 tty52 ttyb8 ttye0 ttyq8 ttysc ttyv4 ttyxc usb4 vcsa4
kmsg ptyb1 ptyd9 ptyq1 ptys9 ptyv1 ptyx9 ram1 tty17 tty53 ttyb9 ttye1 ttyq9 ttysd ttyv5 ttyxd usb5 vcsa5
log ptyb2 ptyda ptyq2 ptysa ptyv2 ptyxa ram10 tty18 tty54 ttyba ttye2 ttyqa ttyse ttyv6 ttyxe usbdev1.1_ep00 vcsa6
loop0 ptyb3 ptydb ptyq3 ptysb ptyv3 ptyxb ram11 tty19 tty55 ttybb ttye3 ttyqb ttysf ttyv7 ttyxf usbdev1.1_ep81 vcsa7
loop1 ptyb4 ptydc ptyq4 ptysc ptyv4 ptyxc ram12 tty2 tty56 ttybc ttye4 ttyqc ttyt0 ttyv8 ttyy0 usbdev1.4_ep00 vcsa8
loop2 ptyb5 ptydd ptyq5 ptysd ptyv5 ptyxd ram13 tty20 tty57 ttybd ttye5 ttyqd ttyt1 ttyv9 ttyy1 usbdev1.4_ep81 watchdog
loop3 ptyb6 ptyde ptyq6 ptyse ptyv6 ptyxe ram14 tty21 tty58 ttybe ttye6 ttyqe ttyt2 ttyva ttyy2 usbdev1.5_ep00 xconsole
loop4 ptyb7 ptydf ptyq7 ptysf ptyv7 ptyxf ram15 tty22 tty59 ttybf ttye7 ttyqf ttyt3 ttyvb ttyy3 usbdev1.5_ep81 zero
loop5 ptyb8 ptye0 ptyq8 ptyt0 ptyv8 ptyy0 ram2 tty23 tty6 ttyc0 ttye8 ttyr0 ttyt4 ttyvc ttyy4 usbdev1.5_ep83
loop6 ptyb9 ptye1 ptyq9 ptyt1 ptyv9 ptyy1 ram3 tty24 tty60 ttyc1 ttye9 ttyr1 ttyt5 ttyvd ttyy5 usbdev1.5_ep84
loop7 ptyba ptye2 ptyqa ptyt2 ptyva ptyy2 ram4 tty25 tty61 ttyc2 ttyea ttyr2 ttyt6 ttyve ttyy6 usbdev2.1_ep00
MAKEDEV ptybb ptye3 ptyqb ptyt3 ptyvb ptyy3 ram5 tty26 tty62 ttyc3 ttyeb ttyr3 ttyt7 ttyvf ttyy7 usbdev2.1_ep81
mem ptybc ptye4 ptyqc ptyt4 ptyvc ptyy4 ram6 tty27 tty63 ttyc4 ttyec ttyr4 ttyt8 ttyw0 ttyy8 usbdev3.1_ep00
mixer ptybd ptye5 ptyqd ptyt5 ptyvd ptyy5 ram7 tty28 tty7 ttyc5 ttyed ttyr5 ttyt9 ttyw1 ttyy9 usbdev3.1_ep81
net ptybe ptye6 ptyqe ptyt6 ptyve ptyy6 ram8 tty29 tty8 ttyc6 ttyee ttyr6 ttyta ttyw2 ttyya usbdev3.2_ep00
null ptybf ptye7 ptyqf ptyt7 ptyvf ptyy7 ram9 tty3 tty9 ttyc7 ttyef ttyr7 ttytb ttyw3 ttyyb usbdev3.2_ep83
nvidia0 ptyc0 ptye8 ptyr0 ptyt8 ptyw0 ptyy8 random tty30 ttya0 ttyc8 ttyp0 ttyr8 ttytc ttyw4 ttyyc usbdev4.1_ep00

macat (attila-maczak) on 2007-10-28
description: updated
Andres Mujica (andres.mujica) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at [WWW] https://wiki.ubuntu.com/Bugs/FindRightPackage.

Please can you confirm us which live cd are you using? or is it a previously installed system ? (cat /etc/lsb-release)

also which version of gparted? (sudo dpkg -l gparted)

which kernel are you using? (uname -a)
This bug probably is kernel related but we need to gather the missing information for actually work on this
thanks a lot

macat (attila-maczak) wrote :

 First, I tried install the 7.10 release, but I tested the 7.04 version. Not change.
Interestingly: The 6.06 livecd saw the disk, I don't understand... I think someone changed about the EFI handling. So I can part the disk, and watch the partitions. Otherwise the 6.06 isn't good for me, because the installation is difficult, and I love the new 7.10 abilities.

Attila

This is the 7.10 test:
ubuntu@ubuntu:~$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=7.10
DISTRIB_CODENAME=gutsy
DISTRIB_DESCRIPTION="Ubuntu 7.10"
ubuntu@ubuntu:~$ sudo dpkg -l gparted
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Installed/Config-f/Unpacked/Failed-cfg/Half-inst/t-aWait/T-pend
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name Version Description
+++-=================================-=================================-==================================================================================
ii gparted 0.3.3-2ubuntu6 GNOME partition editor
ubuntu@ubuntu:~$ sudo dpkg -l parted
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Installed/Config-f/Unpacked/Failed-cfg/Half-inst/t-aWait/T-pend
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name Version Description
+++-=================================-=================================-==================================================================================
ii parted 1.7.1-5.1ubuntu8 The GNU Parted disk partition resizing program
ubuntu@ubuntu:~$ uname -a
Linux ubuntu 2.6.22-14-generic #1 SMP Sun Oct 14 23:05:12 GMT 2007 i686 GNU/Linux

pug (pug-nerd) wrote :

I can confirm this bug.

Neither Ubuntu 7.04 nor Ubuntu 7.10 can detect my harddrive in a mac mini (new 250 GB Samsung HM250JI SATA drive). However the hard drive is detected using a Knoppix CD from July 2007.

pug (pug-nerd) wrote :

Its definitely a problem with partition layout caused by OS X. I booted knoppix, removed all partitions made by OS X, added in some new ones (two primary, one 0.5 GB, the other 30 GB), rebooted - put the Ubuntu 7.10 CD in the drive and booted.

Gparted and the Ubuntu installer now sees the harddrive and I can partition and install etc.

'm not sure if this problem exists with Tiger as I've only tried to install both OS X *and* Ubuntu after I installed Leopard.

Andres Mujica (andres.mujica) wrote :

Macat, is possible for you to try the stuff that pug tried? so we can be sure about the partition layout??

thanks

Andres Mujica (andres.mujica) wrote :

Also could you both check if this problem is somehow related to

https://bugs.launchpad.net/ubuntu/+source/parted/+bug/26660

thanks

macat (attila-maczak) wrote :

Henceforward I'm joyless...
I tried everything:

First:
  1. Knoppix in
  2. Delete all partition
  3. Create 3 partition: 1. ntfs(because the osx saw this), 2. linuxswap, 3. ext3
  4. Reboot, Ubuntu in
  5. Huhuu... The Ubuntu saw the disk. I installed the Ubuntu(7.10) rapidly. Fine. Reboot.
  6. The OSX didn't want to the Knoppix's partition table. I didn't understand it. So... The OSX don't install after the Ubuntu. Ohh... Not fine...

Second:
  1. OSX in
  2. Create the partition table: 1. hfs+, 2.hfs+, 3.hfs+, Installl OSX
  3. Knoppix in
  4. Ohjee...Knoppix saw the OSX's partitions. Fine.
  5. I formatted the second, and the third partition: 2.linuxswap, 3. ext3. Reboot
  6. Ubuntu in
  7. Ohhh noo..the Ubuntu didn't see... Not fine
...
Then I played with the refit (http://refit.sourceforge.net/) But It didn't work...

I'm puzzled... Why Why Why? :(

If I can help anyway, I will do it.

macat (attila-maczak) wrote :

And the Versions...
Ubuntu = 7.10
OSX = 10.4.6
Knoppix = V 5.1.1

pug (pug-nerd) wrote :

I tried EVERY possible combination I could think of to put OS X and Ubuntu 7.10 on the same disk (the internal disk on my intel mac mini), all to no avail.

Once you install OS X, Ubuntu / the linux kernel running on both 7.04 and 7.10 simply IGNORES any harddrive OS X has touched thereby killing your Ubuntu installation and/or your attempt to install Ubuntu.

I finally gave up and installed OS X on a separate USB harddrive and Ubuntu on the internal harddrive.... this works, that is when Ubuntu boots... as sometimes it simply won't boot, something I suspect is caused by... Ubuntu not detecting the harddrive.. w00h00! (although I have no way to tell... it simply stalls before booting the kernel heh).

The EFI stuff in Ubuntu needs some maintenance! Would be cool if someone could take a look at it :-)

Andres Mujica (andres.mujica) wrote :

Hi can you provide us with this info with your ubuntu livecd AND your ubuntu install???

uname -r

cat /boot/config-`uname -r` | grep PART

Also, i don't know for sure if the file is there in knoppix but maybe you can try??

I'm pasting the output from 6.0.6 were the user reported it detected fine the part table

cat /boot/config-`uname -r` | grep PART
CONFIG_PM_STD_PARTITION=""
CONFIG_MTD_PARTITIONS=y
CONFIG_MTD_REDBOOT_PARTS=m
# CONFIG_MTD_REDBOOT_PARTS_UNALLOCATED is not set
# CONFIG_MTD_REDBOOT_PARTS_READONLY is not set
# CONFIG_MTD_CMDLINE_PARTS is not set
CONFIG_PARTITION_ADVANCED=y
CONFIG_ACORN_PARTITION=y
# CONFIG_ACORN_PARTITION_CUMANA is not set
# CONFIG_ACORN_PARTITION_EESOX is not set
CONFIG_ACORN_PARTITION_ICS=y
# CONFIG_ACORN_PARTITION_ADFS is not set
# CONFIG_ACORN_PARTITION_POWERTEC is not set
CONFIG_ACORN_PARTITION_RISCIX=y
CONFIG_OSF_PARTITION=y
CONFIG_AMIGA_PARTITION=y
CONFIG_ATARI_PARTITION=y
CONFIG_MAC_PARTITION=y
CONFIG_MSDOS_PARTITION=y
CONFIG_MINIX_SUBPARTITION=y
CONFIG_SOLARIS_X86_PARTITION=y
CONFIG_LDM_PARTITION=y
CONFIG_SGI_PARTITION=y
CONFIG_ULTRIX_PARTITION=y
CONFIG_SUN_PARTITION=y
CONFIG_EFI_PARTITION=y

Hello

Knoppix
2.6.19 kernel:

$ cat /boot/config-`uname -r` | grep PART
CONFIG_PM_STD_PARTITION=""
CONFIG_MTD_PARTITIONS=y
CONFIG_MTD_REDBOOT_PARTS=m
CONFIG_PARTITION_ADVANCED=y
CONFIG_OSF_PARTITION=y
CONFIG_AMIGA_PARTITION=y
CONFIG_ATARI_PARTITION is not set
CONFIG_MAC_PARTITION=y
CONFIG_MSDOS_PARTITION=y
CONFIG_MINIX_SUBPARTITION=y
CONFIG_SOLARIS_X86_PARTITION=y
CONFIG_LDM_PARTITION is not set
CONFIG_SGI_PARTITION=y
CONFIG_ULTRIX_PARTITION is not set
CONFIG_SUN_PARTITION=y
CONFIG_KARMA_PARTITION=y
CONFIG_EFI_PARTITION=y

What do you think about?

I tested the fedora 8, but also it didn't see my hard drive.
What can I do?
Only, in the weekend I have free time.

Attila

Ricky Campbell (cyberdork33) wrote :

This is a problem for quite a few people on the Apple Intel Forum. Seems most have Samsung Harddrives.

There is a trick to making a disk in normal MBR (msdos) partitioning, and still get osx on there, might try reformatting the disk in a 'msdos' format. To get OSX on there, you will have to install normally, then use something like Carbon Copy Cloner to clone the partition to an external drive. Then you can format the internal drive however you like (with an HFS+ partition) and clone the osx image back onto the msdos disk.

macat (attila-maczak) wrote :

Hooooooray!

I accomplished the task...but this is not the final solution.

The Way:

 1. Boot with Knoppix
 2. With GParted delete all partition, and create: 1 swap, 1 ext3, 1 ntfs
 3. Install Ubuntu to ext3 partition
 4. Plugin the old drive to USB (with Sata -> USB Converter, external drive)
 5. Boot old OSX system from the old drive... it is slow, because USB isn't very fast...
 6. With Apple's Disk Utility, format the 3rd partition to hfs+
 7. With Carbon Copy Cloner clone the system into the new partition
 8. Reboot, unplug the old drive, and the Refit is working without intervention

OK, but I don't have EFI partition, so I lose the firmware upgrade chance.

macat (attila-maczak) wrote :

One thing was out of my comment:
2. step: + Set the disklabel to : msdos... this is the problem, because it is MBR, not the new GPT.

And thanks to cyberdork33!!

Andres Mujica (andres.mujica) wrote :

Confirmed and solved by the user

Changed in linux-source-2.6.22:
status: New → Confirmed
Changed in linux-source-2.6.22:
assignee: nobody → ubuntu-kernel-team

The Hardy Heron Alpha2 release will be coming out soon (around Dec 20). It will have an updated version of the kernel. It would be great if you could test with this new release LiveCD and see if this issue still exists. I'll be sure to update this report when Alpha2 is available. Thanks!

Changed in linux:
status: New → Incomplete

Hardy Heron Alpha2 was recently released. It contains an updated version of the kernel. You can download and try the new Hardy Heron Alpha2 release from http://cdimage.ubuntu.com/releases/hardy/alpha-2/ . You should be able to then test the new kernel via the LiveCD. If you can, please verify if this bug still exists or not and report back your results. General information regarding the release can also be found here: http://www.ubuntu.com/testing/hardy/alpha2 . Thanks!

macat (attila-maczak) wrote :

Ok, I will test it in January. Because I'm in holiday, and I've
deleted the EFI partition.

Happy New Year!

On 28/12/2007, Leann Ogasawara <email address hidden> wrote:
> Hardy Heron Alpha2 was recently released. It contains an updated
> version of the kernel. You can download and try the new Hardy Heron
> Alpha2 release from http://cdimage.ubuntu.com/releases/hardy/alpha-2/ .
> You should be able to then test the new kernel via the LiveCD. If you
> can, please verify if this bug still exists or not and report back your
> results. General information regarding the release can also be found
> here: http://www.ubuntu.com/testing/hardy/alpha2 . Thanks!
>
> --
> Samsung HM160JI sata hdd > no devices detected
> https://bugs.launchpad.net/bugs/158166
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
===================
Maczák Attila
http://attila.maczak.hu
+36 30 554 7650

MastaG (mastag) wrote :

The workaround works but if you would like to keep your efi partition its best to use an updated distro.

The libata_piix driver shipped with the official Fedora 8 and Ubuntu 7.xx install disc is having troubles detecting the samsung drive when an GPT/EFI setup is used. Other drives dont seem to have this problem.

Use the updated distros, they have the newer kernel drivers.
(Ubuntu) "Hardy alpha-4" http://cdimage.ubuntu.com/releases/hardy/alpha-4/
or
(Fedora 8) "Unity Re-Spin F8 20071218" http://spins.fedoraunity.org/unity/fedora-unity-re-spin-f8-20071218

I tested them both, and confirmed working with this drive, using GPT MBR (and EFI partition) and also tried using MS-DOS MBR (but that was allready working as stated above).

I'm now running Leopard OSX 10.5.1 and Fedora 8 Unity Re-Spin 20071218 using a GPT setup (meaning I still have the EFI partition, followed by the HFS partition, ext3 /boot partition and LVM).

Ricky Campbell (cyberdork33) wrote :

We just got another user in the forum that installed one of these drives. I will attempt to get him to test Hardy Alpha4, and post back here.

Henk Koster (h-a-j-koster) wrote :

Well, that would be me...

I just installed Hardy Alpha4 on an original CD MacBook upgraded with the above Samsung 160GB
HD, in a dual-boot arrangement with Mac OS X (10.4.11), using the desktop distro. Using DiskUtil
in Mac OS X, I had left a 30GB Unix partition on the drive as a placeholder for GNU/Linux. The Hardy
installer recognized the drive OK, I selected manual partitioning and then (a) deleted the placeholder
partition and (b) made a JFS root (/) partition /dev/sda3 and a swap partition /dev/sda4. A little later
I confirmed that GRUB be installed to the MBR of (hd0), and upon rebooting there was a GNU/Linux
boot option in the rEFIt menu. After synching GPT and the MBR partition table, Hardy could be started
without any problem whatsoever. Love that cracked-leather-couch look!

Henk,

Thank you so much for testing and providing feedback. I'm going to go ahead and mark this report as "Fix Released" against the Hardy kernel. It's unlikely that a fix will be backported to the 2.6.22 kernel so I'm going to close that task as well. Thanks.

Changed in linux:
status: Incomplete → Fix Released
Changed in linux-source-2.6.22:
status: Confirmed → Won't Fix

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

Thomas Hotz (thotz) wrote :

Your Ubuntu version is EOL. Can you still reproduce this with a supported Ubuntu version? Thank you!

Changed in parted (Ubuntu):
status: Confirmed → Incomplete
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers