Exception during partitioning whilst utopic server installations

Bug #1352252 reported by Para Siva on 2014-08-04
30
This bug affects 6 people
Affects Status Importance Assigned to Milestone
parted (Ubuntu)
Critical
Colin Watson

Bug Description

Starting from 20140801 utopic server installations fail with the following:

Aug 1 07:06:31 debconf: --> GET partman/default_filesystem
Aug 1 07:06:31 debconf: <-- 0 ext4
Aug 1 07:06:31 debconf: --> PROGRESS STEP 1
Aug 1 07:06:31 debconf: <-- 0 OK
Aug 1 07:06:31 debconf: --> SUBST partman/exception_handler TYPE ERROR!!!
Aug 1 07:06:31 debconf: Adding [TYPE] -> [ERROR!!!]
Aug 1 07:06:31 debconf: <-- 0
Aug 1 07:06:31 debconf: --> SUBST partman/exception_handler DESCRIPTION Can't have the end before the start! (start sector=15728579 length=0)
Aug 1 07:06:31 debconf: Adding [DESCRIPTION] -> [Can't have the end before the start! (start sector=15728579 length=0)]
Aug 1 07:06:31 debconf: <-- 0
Aug 1 07:06:31 debconf: --> SUBST partman/exception_handler CHOICES Cancel
Aug 1 07:06:31 debconf: Adding [CHOICES] -> [Cancel]
Aug 1 07:06:31 debconf: <-- 0
Aug 1 07:06:31 debconf: --> SUBST partman/exception_handler_note TYPE ERROR!!!
Aug 1 07:06:31 debconf: Adding [TYPE] -> [ERROR!!!]
Aug 1 07:06:31 debconf: <-- 0
Aug 1 07:06:31 debconf: --> SUBST partman/exception_handler_note DESCRIPTION Can't have the end before the start! (start sector=15728579 length=0)
Aug 1 07:06:31 debconf: Adding [DESCRIPTION] -> [Can't have the end before the start! (start sector=15728579 length=0)]
Aug 1 07:06:31 debconf: <-- 0
Aug 1 07:06:31 debconf: --> FSET partman/exception_handler_note seen false
Aug 1 07:06:31 debconf: <-- 0 false
Aug 1 07:06:31 debconf: --> INPUT critical partman/exception_handler_note
Aug 1 07:06:31 debconf: <-- 0 question will be asked
Aug 1 07:06:31 debconf: --> GO

Occurs on both preseeded and manual install of both amd64 & i386 images:

The impacted jobs are:
https://jenkins.qa.ubuntu.com/job/utopic-desktop-amd64-smoke-default/94/
https://jenkins.qa.ubuntu.com/job/utopic-server-i386-smoke-default/97/

Installer syslog is attached.

Para Siva (psivaa) wrote :
Para Siva (psivaa) on 2014-08-04
description: updated
Brad Figg (brad-figg) on 2014-08-04
Changed in parted (Ubuntu):
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in parted (Ubuntu):
status: New → Confirmed
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1352252

tags: added: iso-testing
Para Siva (psivaa) wrote :

partman log is attached here. This was from a manual vm install with 8G disk space and 1024MB RAM.

Colin Watson (cjwatson) on 2014-08-05
Changed in parted (Ubuntu):
status: Confirmed → In Progress
importance: High → Critical
assignee: nobody → Colin Watson (cjwatson)
ek0892 (kranich) wrote :

can't have the end before the start! (start sector=30408267 length=0)

Colin Watson (cjwatson) on 2014-08-06
Changed in parted (Ubuntu):
status: In Progress → Fix Committed
Walter Lapchynski (wxl) wrote :

where is said fix? i can't find it in the bzr repo or anywhere else ;)

The bzr repository has been dead for some time.
http://anonscm.debian.org/cgit/parted/debian/parted.git/commit/?id=11ccc7136ada703a3dcf932609023392c5bbf95f
is the fix, or at least reasonable workaround; I uploaded that to Debian
in 3.2-2, which will be auto-synced into utopic shortly.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package parted - 3.2-2

---------------
parted (3.2-2) unstable; urgency=high

  * Fix gptsync.patch not to try to perform pointer arithmetic on void *
    values.
  * Remove unused label from udevadm-settle.patch.
  * Configure with --disable-gcc-warnings, even when building from git.
    Making the build work with -Werror is too painful at the moment.
  * Align new partitions created on fresh disks (LP: #1352252).

 -- Colin Watson <email address hidden> Wed, 06 Aug 2014 15:21:03 +0100

Changed in parted (Ubuntu):
status: Fix Committed → Fix Released
Robert Finley (finley-rob) wrote :

I am testing the new iso's now. This problem seems fixed. Great work!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers