gpartedbin crashed with SIGSEGV in _int_free()

Bug #1302762 reported by cliff tinker on 2014-04-04
58
This bug affects 4 people
Affects Status Importance Assigned to Milestone
parted (Debian)
Fix Released
Unknown
parted (Ubuntu)
Critical
Phillip Susi
Trusty
Critical
Phillip Susi

Bug Description

crashes as soon as it appears followins password entry

ProblemType: Crash
DistroRelease: Ubuntu 14.04
Package: gparted 0.18.0-1
ProcVersionSignature: Ubuntu 3.13.0-23.45-generic 3.13.8
Uname: Linux 3.13.0-23-generic x86_64
ApportVersion: 2.14-0ubuntu1
Architecture: amd64
Date: Fri Apr 4 19:23:15 2014
ExecutablePath: /usr/sbin/gpartedbin
InstallationDate: Installed on 2014-04-04 (0 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64 (20140115)
ProcCmdline: /usr/sbin/gpartedbin
SegvAnalysis:
 Segfault happened at: 0x7f3d389b1f6f <_int_free+527>: cmp 0x18(%rax),%r13
 PC (0x7f3d389b1f6f) ok
 source "0x18(%rax)" (0xbcd08e1000b912) not located in a known VMA region (needed readable region)!
 destination "%r13" ok
 Stack memory exhausted (SP below stack segment)
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: gparted
StacktraceTop:
 _int_free (av=0x7f3d1c000020, p=<optimised out>, have_lock=0) at malloc.c:3996
 ped_exception_catch () from /lib/x86_64-linux-gnu/libparted.so.0
 ped_exception_throw () from /lib/x86_64-linux-gnu/libparted.so.0
 fat_boot_sector_read () from /lib/x86_64-linux-gnu/libparted.so.0
 fat_probe () from /lib/x86_64-linux-gnu/libparted.so.0
Title: gpartedbin crashed with SIGSEGV in _int_free()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

cliff tinker (cliff5555) wrote :

StacktraceTop:
 _int_free (av=0x7f3d1c000020, p=<optimized out>, have_lock=0) at malloc.c:3996
 ped_exception_catch () at ../../libparted/exception.c:191
 ped_exception_throw (ex_type=ex_type@entry=PED_EXCEPTION_ERROR, ex_opts=ex_opts@entry=PED_EXCEPTION_CANCEL, message=0x7f3d3b94a970 "File system has an invalid number of FATs.") at ../../libparted/exception.c:236
 fat_boot_sector_read (bs=bs@entry=0x7f3d1c0075d0, geom=geom@entry=0x7f3d1c003e90) at ../../../../libparted/fs/fat/bootsector.c:84
 fat_probe (geom=geom@entry=0x7f3d1c003e90, fat_type=fat_type@entry=0x7f3d239797ac) at ../../../../libparted/fs/fat/fat.c:124

Changed in gparted (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Phillip Susi (psusi) wrote :

Can you run sudo parted -l and post the output?

It looks like you have a broken, or at least very unusual fat partition somewhere.

information type: Private → Public
cliff tinker (cliff5555) wrote :

merlin@gallahad:~$ sudo parted -l
[sudo] password for merlin:
Model: ATA M4-CT128M4SSD2 (scsi)
Disk /dev/sda: 128GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number Start End Size Type File system Flags
 1 1049kB 111GB 111GB primary ext4 boot
 2 111GB 128GB 17.1GB extended
 5 111GB 128GB 17.1GB logical linux-swap(v1)

Model: ATA WDC WD20EZRX-00D (scsi)
Disk /dev/sdb: 2000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt

Number Start End Size File system Name Flags
 1 1049kB 2000GB 2000GB ext4

Model: ATA ST3000DM001-1CH1 (scsi)
Disk /dev/sdc: 3001GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt

Number Start End Size File system Name Flags
 1 1049kB 3001GB 3001GB ext4

Model: ATA ST500DM002-1BD14 (scsi)
Disk /dev/sdd: 500GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt

Number Start End Size File system Name Flags
 1 1049kB 100GB 100GB ext4
 2 100GB 500GB 400GB ext4

*** Error in `parted': free(): invalid pointer: 0x0000000002609000 ***
*** Error in `parted': malloc(): memory corruption: 0x0000000002608550 ***

You found a bug in GNU Parted! Here's what you have to do:

Don't panic! The bug has most likely not affected any of your data.
Help us to fix this bug by doing the following:

Check whether the bug has already been fixed by checking
the last version of GNU Parted that you can find at:

 http://ftp.gnu.org/gnu/parted/

Please check this version prior to bug reporting.

If this has not been fixed yet or if you don't know how to check,
please visit the GNU Parted website:

 http://www.gnu.org/software/parted

for further information.

Your report should contain the version of this release (2.3)
along with the error message below, the output of

 parted DEVICE unit co print unit s print

and the following history of commands you entered.
Also include any additional information about your setup you
consider important.

Phillip Susi (psusi) wrote :

Interesting... how about fdisk -l?

cliff tinker (cliff5555) wrote :

the fault appears to be caused by my hitachi external 2tb drive.as soon as i powered off the drive gparted is working normally again.
if this drive is running when the system boots it reports bad secor size (i have tried formating this drive in different filesystem's but it seems not to cure the problem. grub also reports this whenever i run update-grub :
merlin@gallahad:~$ sudo update-grub
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-3.13.0-23-generic
Found initrd image: /boot/initrd.img-3.13.0-23-generic
Found linux image: /boot/vmlinuz-3.13.0-22-generic
Found initrd image: /boot/initrd.img-3.13.0-22-generic
Found linux image: /boot/vmlinuz-3.13.0-3-generic
Found initrd image: /boot/initrd.img-3.13.0-3-generic
Found memtest86+ image: /boot/memtest86+.elf
Found memtest86+ image: /boot/memtest86+.bin
ERROR: unsupported sector size 4096 on /dev/sdf.
ERROR: unsupported sector size 4096 on /dev/sdf.
ERROR: unsupported sector size 4096 on /dev/sdf.
ERROR: unsupported sector size 4096 on /dev/sdf.
ERROR: unsupported sector size 4096 on /dev/sdf.
ERROR: unsupported sector size 4096 on /dev/sdf.
ERROR: unsupported sector size 4096 on /dev/sdf.
grub-probe: error: unknown filesystem.
done
merlin@gallahad:~$

Phillip Susi (psusi) wrote :

Can you run fdisk -l with this drive plugged in?

Download full text (4.7 KiB)

Disk /dev/sda: 128.0 GB, 128035676160 bytes
255 heads, 63 sectors/track, 15566 cylinders, total 250069680 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00079235

   Device Boot Start End Blocks Id System
/dev/sda1 * 2048 216590335 108294144 83 Linux
/dev/sda2 216592382 250068991 16738305 5 Extended
/dev/sda5 216592384 250068991 16738304 82 Linux swap / Solaris

WARNING: GPT (GUID Partition Table) detected on '/dev/sdb'! The util fdisk
doesn't support GPT. Use GNU Parted.

Disk /dev/sdb: 2000.4 GB, 2000398934016 bytes
255 heads, 63 sectors/track, 243201 cylinders, total 3907029168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0x00000000

   Device Boot Start End Blocks Id System
/dev/sdb1 1 3907029167 1953514583+ ee GPT
Partition 1 does not start on physical sector boundary.

WARNING: GPT (GUID Partition Table) detected on '/dev/sdc'! The util fdisk
doesn't support GPT. Use GNU Parted.

Disk /dev/sdc: 3000.6 GB, 3000592982016 bytes
255 heads, 63 sectors/track, 364801 cylinders, total 5860533168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0x00000000

   Device Boot Start End Blocks Id System
/dev/sdc1 1 4294967295 2147483647+ ee GPT
Partition 1 does not start on physical sector boundary.

WARNING: GPT (GUID Partition Table) detected on '/dev/sdd'! The util fdisk
doesn't support GPT. Use GNU Parted.

Disk /dev/sdd: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders, total 976773168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0x00000000

   Device Boot Start End Blocks Id System
/dev/sdd1 1 976773167 488386583+ ee GPT
Partition 1 does not start on physical sector boundary.
Note: sector size is 4096 (not 512)

Disk /dev/sde: 2000.4 GB, 2000398839808 bytes
255 heads, 63 sectors/track, 30400 cylinders, total 488378623 sectors
Units = sectors of 1 * 4096 = 4096 bytes
Sector size (logical/physical): 4096 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0x0002e0a8

   Device Boot Start End Blocks Id System
/dev/sde1 63 488378622 1953514240 7 HPFS/NTFS/exFAT
merlin@gallahad:~$

On 4 April 2014 21:40, Phillip Susi <email address hidden> wrote:

> Interesting... how about fdisk -l?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1302762
>
> Title:
> gpartedbin crashed with SIGSEGV in _int_free()
>
> Status in "gparted" package in Ubuntu:
> New
>
> Bug description:
> crashes as soon as it appears ...

Read more...

cliff tinker (cliff5555) wrote :

i already did it device sde in the previous message

On 4 April 2014 21:57, Phillip Susi <email address hidden> wrote:

> Can you run fdisk -l with this drive plugged in?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1302762
>
> Title:
> gpartedbin crashed with SIGSEGV in _int_free()
>
> Status in "gparted" package in Ubuntu:
> New
>
> Bug description:
> crashes as soon as it appears followins password entry
>
> ProblemType: Crash
> DistroRelease: Ubuntu 14.04
> Package: gparted 0.18.0-1
> ProcVersionSignature: Ubuntu 3.13.0-23.45-generic 3.13.8
> Uname: Linux 3.13.0-23-generic x86_64
> ApportVersion: 2.14-0ubuntu1
> Architecture: amd64
> Date: Fri Apr 4 19:23:15 2014
> ExecutablePath: /usr/sbin/gpartedbin
> InstallationDate: Installed on 2014-04-04 (0 days ago)
> InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64
> (20140115)
> ProcCmdline: /usr/sbin/gpartedbin
> SegvAnalysis:
> Segfault happened at: 0x7f3d389b1f6f <_int_free+527>: cmp
> 0x18(%rax),%r13
> PC (0x7f3d389b1f6f) ok
> source "0x18(%rax)" (0xbcd08e1000b912) not located in a known VMA
> region (needed readable region)!
> destination "%r13" ok
> Stack memory exhausted (SP below stack segment)
> SegvReason: reading unknown VMA
> Signal: 11
> SourcePackage: gparted
> StacktraceTop:
> _int_free (av=0x7f3d1c000020, p=<optimised out>, have_lock=0) at
> malloc.c:3996
> ped_exception_catch () from /lib/x86_64-linux-gnu/libparted.so.0
> ped_exception_throw () from /lib/x86_64-linux-gnu/libparted.so.0
> fat_boot_sector_read () from /lib/x86_64-linux-gnu/libparted.so.0
> fat_probe () from /lib/x86_64-linux-gnu/libparted.so.0
> Title: gpartedbin crashed with SIGSEGV in _int_free()
> UpgradeStatus: No upgrade log present (probably fresh install)
> UserGroups:
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/gparted/+bug/1302762/+subscriptions
>

--
Cliff Tinker

Phillip Susi (psusi) wrote :

Please run sudo dd if=/dev/sde1 count=1 2>/dev/null | xxd

cliff tinker (cliff5555) wrote :
Download full text (4.2 KiB)

merlin@gallahad:~$ sudo dd if=/dev/sde1 count=1 2>/dev/null | xxd
0000000: eb52 904e 5446 5320 2020 2000 1001 0000 .R.NTFS .....
0000010: 0000 0000 00f8 0000 3f00 ff00 f801 0000 ........?.......
0000020: 0000 0000 8000 8000 bf10 1c1d 0000 0000 ................
0000030: 0400 0000 0000 0000 5f08 8e0e 0000 0000 ........_.......
0000040: 0100 0000 0100 0000 9357 ba5a e11c d302 .........W.Z....
0000050: 0000 0000 fa33 c08e d0bc 007c fb68 c007 .....3.....|.h..
0000060: 1f1e 6866 00cb 8816 0e00 6681 3e03 004e ..hf......f.>..N
0000070: 5446 5375 15b4 41bb aa55 cd13 720c 81fb TFSu..A..U..r...
0000080: 55aa 7506 f7c1 0100 7503 e9d2 001e 83ec U.u.....u.......
0000090: 1868 1a00 b448 8a16 0e00 8bf4 161f cd13 .h...H..........
00000a0: 9f83 c418 9e58 1f72 e13b 060b 0075 dba3 .....X.r.;...u..
00000b0: 0f00 c12e 0f00 041e 5a33 dbb9 0020 2bc8 ........Z3... +.
00000c0: 66ff 0611 0003 160f 008e c2ff 0616 00e8 f...............
00000d0: 4000 2bc8 77ef b800 bbcd 1a66 23c0 752d @.+.w......f#.u-
00000e0: 6681 fb54 4350 4175 2481 f902 0172 1e16 f..TCPAu$....r..
00000f0: 6807 bb16 6870 0e16 6809 0066 5366 5366 h...hp..h..fSfSf
0000100: 5516 1616 68b8 0166 610e 07cd 1ae9 6a01 U...h..fa.....j.
0000110: 9090 6660 1e06 66a1 1100 6603 061c 001e ..f`..f...f.....
0000120: 6668 0000 0000 6650 0653 6801 0068 1000 fh....fP.Sh..h..
0000130: b442 8a16 0e00 161f 8bf4 cd13 6659 5b5a .B..........fY[Z
0000140: 6659 6659 1f0f 8216 0066 ff06 1100 0316 fYfY.....f......
0000150: 0f00 8ec2 ff0e 1600 75bc 071f 6661 c3a0 ........u...fa..
0000160: f801 e808 00a0 fb01 e802 00eb feb4 018b ................
0000170: f0ac 3c00 7409 b40e bb07 00cd 10eb f2c3 ..<.t...........
0000180: 0d0a 4120 6469 736b 2072 6561 6420 6572 ..A disk read er
0000190: 726f 7220 6f63 6375 7272 6564 000d 0a42 ror occurred...B
00001a0: 4f4f 544d 4752 2069 7320 6d69 7373 696e OOTMGR is missin
00001b0: 6700 0d0a 424f 4f54 4d47 5220 6973 2063 g...BOOTMGR is c
00001c0: 6f6d 7072 6573 7365 6400 0d0a 5072 6573 ompressed...Pres
00001d0: 7320 4374 726c 2b41 6c74 2b44 656c 2074 s Ctrl+Alt+Del t
00001e0: 6f20 7265 7374 6172 740d 0a00 0000 0000 o restart.......
00001f0: 0000 0000 0000 0000 809d b2ca 0000 55aa ..............U.
merlin@gallahad:~$

On 4 April 2014 23:21, Phillip Susi <email address hidden> wrote:

> Please run sudo dd if=/dev/sde1 count=1 2>/dev/null | xxd
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1302762
>
> Title:
> gpartedbin crashed with SIGSEGV in _int_free()
>
> Status in "gparted" package in Ubuntu:
> New
>
> Bug description:
> crashes as soon as it appears followins password entry
>
> ProblemType: Crash
> DistroRelease: Ubuntu 14.04
> Package: gparted 0.18.0-1
> ProcVersionSignature: Ubuntu 3.13.0-23.45-generic 3.13.8
> Uname: Linux 3.13.0-23-generic x86_64
> ApportVersion: 2.14-0ubuntu1
> Architecture: amd64
> Date: Fri Apr 4 19:23:15 2014
> ExecutablePath: /usr/sbin/gpartedbin
> InstallationDate: Installed on 2014-04-04 (0 days ago)
> InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64
> (20140115)
> ProcCmdline: /usr/sbin/gpartedbin
> SegvAnalysis:...

Read more...

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gparted (Ubuntu):
status: New → Confirmed
Phillip Susi (psusi) wrote :

Strange, are you sure that is the correct disk? It looks like that is an ntfs partition, not fat, which is what parted was complaining about. I did notice that it says that disk uses 4k sectors. I thought that dd was supposed to default to the sector size of the drive so it should have given 4k, but only gave 512 bytes. Can you get the full sector by running sudo dd if=/dev/sde1 count=1 bs=4096 2>/dev/null | xxd?

Come to think of it, parted only even detects filesystems on 512 byte sector disks. It must have been another disk.

Phillip Susi (psusi) on 2014-04-06
affects: gparted (Ubuntu) → parted (Ubuntu)
Changed in parted (Ubuntu):
assignee: nobody → Phillip Susi (psusi)
status: Confirmed → In Progress
no longer affects: parted
Changed in parted (Debian):
status: Unknown → New
Changed in parted (Ubuntu):
importance: Medium → Critical
Myriam Schweingruber (myriam) wrote :

Please also see the information in bug #1303693, marked as dupplicate of this one

Changed in parted (Debian):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package parted - 2.3-19

---------------
parted (2.3-19) unstable; urgency=medium

  [ Phillip Susi ]
  * fat-ntfs-large-sectors.patch: Fix fat and ntfs detection on non 512 byte
    sectors (closes: #743816, LP: #1302762).

 -- Colin Watson <email address hidden> Tue, 08 Apr 2014 12:55:59 +0100

Changed in parted (Ubuntu Trusty):
status: In Progress → Fix Released
Myriam Schweingruber (myriam) wrote :

Fix released, but there is nothing in the Trusty repos so far?

Phillip Susi (psusi) wrote :

It can take a few hours to replicate to all of the mirrors.

Myriam Schweingruber (myriam) wrote :

I am not trying to get it from a mirror, but from the main archive...

Myriam Schweingruber (myriam) wrote :

Never mind, now I see it, thanks for the quick fix.

Yu Ning (yuningdodo) wrote :

parted 2.3-19 will crash in my env:

# /dev/sdc is device name of my usb stick
sudo dd if=/dev/zero of=/dev/sdc
sudo parted -s /dev/sdc mklabel gpt
sudo parted -a minimal -s /dev/sdc mkpartfs 'EFI' fat32 0 50

please find the details in the attached crash report

Yu Ning (yuningdodo) wrote :

The crash can also be reproduced even without an real device, replace /dev/sdc with a normal file name, such as './block', can also reproduce it.

Here is the crash output from parted:

WARNING: you are attempting to use parted to operate on (mkpartfs) a file system.
parted's file system manipulation code is not as robust as what you'll find in
dedicated, file-system-specific packages like e2fsprogs. We recommend
you use parted only to manipulate partition tables, whenever possible.
Support for performing most operations on most types of file systems
will be removed in an upcoming release.
Backtrace has 9 calls on stack:
  9: /lib/x86_64-linux-gnu/libparted.so.0(ped_assert+0x31) [0x7f9823b0b4b1]
  8: /lib/x86_64-linux-gnu/libparted.so.0(+0x25cc3) [0x7f9823b21cc3]
  7: /lib/x86_64-linux-gnu/libparted.so.0(fat_create+0x189) [0x7f9823b24f49]
  6: /lib/x86_64-linux-gnu/libparted.so.0(ped_file_system_create+0x51) [0x7f9823b0cef1]
  5: parted() [0x409cbc]
  4: parted(non_interactive_mode+0x8f) [0x40dc5f]
  3: parted(main+0x146d) [0x4064ed]
  2: /lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf5) [0x7f98232e8ec5]
  1: parted() [0x406617]

You found a bug in GNU Parted! Here's what you have to do:

Don't panic! The bug has most likely not affected any of your data.
Help us to fix this bug by doing the following:

Check whether the bug has already been fixed by checking
the last version of GNU Parted that you can find at:

 http://ftp.gnu.org/gnu/parted/

Please check this version prior to bug reporting.

If this has not been fixed yet or if you don't know how to check,
please visit the GNU Parted website:

 http://www.gnu.org/software/parted

for further information.

Your report should contain the version of this release (2.3)
along with the error message below, the output of

 parted DEVICE unit co print unit s print

and the following history of commands you entered.
Also include any additional information about your setup you
consider important.

Assertion (bs != NULL) at ../../../../libparted/fs/fat/bootsector.c:282 in function fat_boot_sector_set_boot_code() failed.

Myriam Schweingruber (myriam) wrote :

oh well, blame parted for screwing up big time by removing the possibility to create filesystems post 2.4.
Upstream is many versions ahead and I guess those bugs have been fixed upstream since quite some time, but backporting all this to a version that is usable by distributions is almost impossible...

Phillip Susi (psusi) wrote :

Yes, don't use mkpartfs, that's unrelated to this bug.

Yu Ning (yuningdodo) wrote :

OK, I see, I'll use mkfs.msdos instead. Thanks.

Hardware: Asus U56E
Upgrade from Xubuntu 13.10 64-bit to 14.04 64-bit

I just upgraded to 14.04 and I also have this problem. During the upgrade, I received the above error multiple times. Here is an excerpt from /var/log/apt/term.log:

--------------------------------------------------------------------------------------------------------------------
Found memtest86+ image: /boot/memtest86+.bin
ERROR: unsupported sector size 4096 on /dev/sdb.
ERROR: unsupported sector size 4096 on /dev/sdb.
ERROR: unsupported sector size 4096 on /dev/sdb.
ERROR: unsupported sector size 4096 on /dev/sdb.
ERROR: unsupported sector size 4096 on /dev/sdb.
ERROR: unsupported sector size 4096 on /dev/sdb.
ERROR: unsupported sector size 4096 on /dev/sdb.
ERROR: unsupported sector size 4096 on /dev/sdb.
grub-probe: error: unknown filesystem
Found Windows Recovery Environment (loader) on /dev/sda1
Found Windows 7 (loader) on /dev/sda2
--------------------------------------------------------------------------------------------------------------------

/dev/sdb is an external USB-attached 3TB Seagate Backup Plus disk that has been attached to 13.10 since it was upgrade, and has caused no problems.

The upgrade acted as though there were unrecoverable errors and that the upgrade would be backed out, but it continued and finished the upgrade to 14.04. There were a few minor configuration problems with the upgrade, but it appear to work properly. However, now, every time I reboot, I get a blank screen with the message:

ERROR: unsupported sector size 4096 on /dev/sdb.

Then the system hangs for about 30 seconds or so before continuing with the boot into xfce4. Once up, the Thunar file manager sees the Seagate disk and is able to mount and navigate it without problem.

The Seagate disk is being used as formatted from the factory. gparted-pkexec/gnome-disks show an initial 8.0/8.4Mb unallocated partition followed by /dev/sdb1 with 2.73/3.0Tb NTFS filesystem and then another unallocated 4.46/4.7Mb partition.

From this information and the fact that this message is not logged in any system file, I would assume the the problem is with the grub loader.

While this problem is investigated further, is there any way to stop the boot delay when this message is displayed?

Phillip Susi (psusi) wrote :

Jeffery, your issue is completely unrelated to this bug or to gparted.

Phillip: OK, I'll file another bug report on this issue. However, because of the identical error message showing up, I thought you would be interested in seeing this report. I hoped that it would throw some additional light onto what might actually be the source of the problem. Regards.

Phillip Susi (psusi) wrote :

It isn't the same error message at all... there is nothing in what you posted that is at all similar to previous comments in this thread.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.