LVM installation fails - regression with parted 2.3-17

Bug #1300072 reported by Jean-Baptiste Lallement on 2014-03-31
84
This bug affects 12 people
Affects Status Importance Assigned to Milestone
parted (Ubuntu)
Critical
Colin Watson
Trusty
Critical
Colin Watson

Bug Description

Ubuntu Desktop [1] and Server [2] 20140330

LVM installation fails with:
"Autopartitioning using LVM failed because an error occurred while creating the volume group."

From syslog:
Mar 31 08:03:05 ubuntu ubiquity[3029]: switched to page partman
Mar 31 08:07:43 ubuntu kernel: [ 606.972515] atkbd serio0: Spurious NAK on isa0060/serio0. Some program might be trying to access hardware directly.
Mar 31 08:08:31 ubuntu ubiquity: /var/lib/partman/devices/=dev=sda
Mar 31 08:08:31 ubuntu ubiquity: stat:
Mar 31 08:08:31 ubuntu ubiquity: cannot stat ‘/dev/ubuntu-vg’
Mar 31 08:08:31 ubuntu ubiquity: : No such file or directory
Mar 31 08:08:31 ubuntu ubiquity:
Mar 31 08:08:31 ubuntu partman-lvm:
Mar 31 08:08:31 ubuntu partman-lvm: Device /dev/sda not found (or ignored by filtering).
Mar 31 08:08:31 ubuntu partman-lvm:

Downgrading parted to 2.3-16ubuntu3 fixes the issue.

TEST CASE:
1. Install Ubuntu Desktop 20140330 adnd keep the defaults
2. At step "Installation Type" select:
  - Erase disk and install Ubuntu
  - Use LVM
and proceed

ACTUAL RESULT
This failure

EXPECTED RESULT
LVM partitions are created.

[1] https://jenkins.qa.ubuntu.com//job/ubiquity_ap-ubuntu_devel_daily-test_english_lvm/124/
[2] https://jenkins.qa.ubuntu.com/job/trusty-server-amd64-smoke-lvm/139/

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: ubiquity 2.17.10 [modified: lib/partman/automatically_partition/question]
ProcVersionSignature: Ubuntu 3.13.0-20.42-generic 3.13.7
Uname: Linux 3.13.0-20-generic x86_64
ApportVersion: 2.13.3-0ubuntu1
Architecture: amd64
CasperVersion: 1.339
CurrentDesktop: Unity
Date: Mon Mar 31 08:03:42 2014
InstallCmdLine: file=/cdrom/preseed/ubuntu.seed boot=casper initrd=/casper/initrd.lz quiet splash -- keyboard-configuration/layoutcode=fr keyboard-configuration/variantcode=oss
LiveMediaBuild: Ubuntu 14.04 LTS "Trusty Tahr" - Daily amd64 (20140330)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Jean-Baptiste Lallement (jibel) wrote :
description: updated
Changed in ubiquity (Ubuntu Trusty):
assignee: nobody → Ubuntu Installer Team (ubuntu-installer)
tags: added: testcase
Colin Watson (cjwatson) wrote :

Phillip, could you please look at this? It seems to be a regression caused by your loop device patch.

affects: ubiquity (Ubuntu Trusty) → parted (Ubuntu Trusty)
Changed in parted (Ubuntu Trusty):
assignee: Ubuntu Installer Team (ubuntu-installer) → Dimitri John Ledkov (xnox)
assignee: Dimitri John Ledkov (xnox) → Ubuntu Installer Team (ubuntu-installer)
Ryan Beisner (1chb1n) wrote :

FWIW: I ran into this today, was able to use F4 Minimal Installation as a workaround.

Phillip Susi (psusi) wrote :

That is really weird; I'm pretty sure that option is completely ignored on the desktop cd.

Colin Watson (cjwatson) on 2014-04-01
Changed in parted (Ubuntu Trusty):
status: Confirmed → Fix Committed
assignee: Ubuntu Installer Team (ubuntu-installer) → Colin Watson (cjwatson)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package parted - 2.3-18

---------------
parted (2.3-18) unstable; urgency=medium

  * Fix LVM handling regressions caused by fix-loop-labels.patch
    (LP: #1300072):
    - Initialise dev->loop in ped_disk_new_fresh rather than ped_disk_new.
    - Temporarily set disk->dev->loop to 0 while removing partitions, so
      that we can remove previously-existing non-loop partitions (thanks,
      Phillip Susi).

 -- Colin Watson <email address hidden> Wed, 02 Apr 2014 00:01:13 +0100

Changed in parted (Ubuntu Trusty):
status: Fix Committed → Fix Released
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1300072

tags: added: iso-testing
Ryan Beisner (1chb1n) wrote :

FYI
Confirmed resolved on 2014-APR-07 Trusty daily ISO, parted 2.3-18.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers