Parole crashes when choosing to open a file if MPRIS2 plugin is deactivated

Bug #1698540 reported by FurretUber on 2017-06-17
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
parole (Ubuntu)
Undecided
Unassigned

Bug Description

Hello

I have noticed that, if the MPRIS2 plugin is deactivated and I choose the option to open a file, parole will crash with a segmentation fault.

On dmesg the following message appears:

[ 1360.591587] parole[6684]: segfault at 2d ip 000055f120077cba sp 00007ffc032c88c8 error 6 in parole[55f12004c000+5b000]

OS: Xubuntu 17.04 amd64
Parole version: 0.9.1-0ubuntu1

Expected behavior: the window to open a file would appear and I would be able to choose a file;

Observed behavior: the borders of the open file window appear, then parole crashes.

ProblemType: Bug
DistroRelease: Ubuntu 17.04
Package: parole 0.9.1-0ubuntu1
ProcVersionSignature: Ubuntu 4.10.0-22.24-generic 4.10.15
Uname: Linux 4.10.0-22-generic x86_64
ApportVersion: 2.20.4-0ubuntu4.1
Architecture: amd64
CurrentDesktop: XFCE
Date: Sat Jun 17 09:36:17 2017
InstallationDate: Installed on 2017-06-13 (3 days ago)
InstallationMedia: Xubuntu 17.04 "Zesty Zapus" - Release amd64 (20170412)
SourcePackage: parole
UpgradeStatus: No upgrade log present (probably fresh install)

FurretUber (furretuber) wrote :
Sean Davis (bluesabre) wrote :

I am unable to reproduce this with the latest release (1.0.1). Can you attempt to reproduce this bug?

Changed in parole (Ubuntu):
status: New → Incomplete
FurretUber (furretuber) wrote :
Download full text (3.3 KiB)

I'm using now Xubuntu version 18.04 that has parole version 1.0.1 and its still happening. Using gdb, it shows the following backtrace when it crashes:

(gdb) bt
Python Exception <class 'NameError'> Installation error: gdb.execute_unwinders function is missing:
Python Exception <class 'ModuleNotFoundError'> No module named 'gdb':
#0 0x00007ffff5ebb0a6 in g_dbus_connection_emit_signal () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#1 0x00007fffe1004594 in ?? () from /usr/lib/x86_64-linux-gnu/parole-0/parole-mpris2.so
Python Exception <class 'NameError'> Installation error: gdb.execute_unwinders function is missing:
#2 0x00007fffe100480c in ?? () from /usr/lib/x86_64-linux-gnu/parole-0/parole-mpris2.so
Python Exception <class 'NameError'> Installation error: gdb.execute_unwinders function is missing:
#3 0x00007ffff6bfe15b in ?? () from /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
Python Exception <class 'NameError'> Installation error: gdb.execute_unwinders function is missing:
#4 0x00007ffff4d4af6d in g_closure_invoke () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
Python Exception <class 'NameError'> Installation error: gdb.execute_unwinders function is missing:
#5 0x00007ffff4d5dd3e in ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
Python Exception <class 'NameError'> Installation error: gdb.execute_unwinders function is missing:
#6 0x00007ffff4d65d8f in g_signal_emit_valist () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
Python Exception <class 'NameError'> Installation error: gdb.execute_unwinders function is missing:
#7 0x00007ffff4d66e0f in g_signal_emit () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
Python Exception <class 'NameError'> Installation error: gdb.execute_unwinders function is missing:
#8 0x00007ffff6d45b04 in ?? () from /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
Python Exception <class 'NameError'> Installation error: gdb.execute_unwinders function is missing:
#9 0x00007ffff6bfd22e in gtk_main_do_event () from /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
Python Exception <class 'NameError'> Installation error: gdb.execute_unwinders function is missing:
#10 0x00007ffff670e765 in ?? () from /usr/lib/x86_64-linux-gnu/libgdk-3.so.0
Python Exception <class 'NameError'> Installation error: gdb.execute_unwinders function is missing:
#11 0x00007ffff673ef82 in ?? () from /usr/lib/x86_64-linux-gnu/libgdk-3.so.0
Python Exception <class 'NameError'> Installation error: gdb.execute_unwinders function is missing:
#12 0x00007ffff4a71287 in g_main_context_dispatch () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
Python Exception <class 'NameError'> Installation error: gdb.execute_unwinders function is missing:
#13 0x00007ffff4a714c0 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
Python Exception <class 'NameError'> Installation error: gdb.execute_unwinders function is missing:
#14 0x00007ffff4a717d2 in g_main_loop_run () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
Python Exception <class 'NameError'> Installation error: gdb.execute_unwinders function is missing:
#15 0x00007ffff6bfc385 in gtk_main () from /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
Python Exception <class 'NameError'>...

Read more...

FurretUber (furretuber) wrote :

Here is it more readable: http://termbin.com/xhbo

FurretUber (furretuber) on 2018-08-27
Changed in parole (Ubuntu):
status: Incomplete → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in parole (Ubuntu):
status: New → Confirmed
Kev Bowring (flocculant) wrote :

Confirm this on a clean install.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package parole - 1.0.2-0ubuntu1

---------------
parole (1.0.2-0ubuntu1) disco; urgency=medium

  * New upstream bugfix release.
    - Fix crash when disabling plugins (LP: #1698540)
    - Fix play button when adding items to the playlist (LP: #1705243)

 -- Sean Davis <email address hidden> Thu, 04 Apr 2019 19:40:49 -0400

Changed in parole (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers