Parole media player segfaults when seeking forward in a video file

Bug #1550444 reported by mikewhatever
This bug affects 8 people
Affects Status Importance Assigned to Milestone
parole (Ubuntu)

Bug Description

Parole starts playing video, but the second I click or drag the slider to seek forward, playback stops, and the window closes.
If launched from a terminal window, it looks like this:
$ parole test.mp4

** (parole:3145): WARNING **: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-ELwoGajH7L: Connection refused

(parole:3145): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:2149:29: Expected a valid selector
Protocol error: bad 3 (Window); Sequence Number 5
 Opcode (20, 0) = GetProperty
 Bad resource 930383683 (0x37748743)
 at -e line 15.
Segmentation fault (core dumped)

The machine is a Pentium 4 with Nvidia Geforce 6200 graphics, with nvidia-304 driver, running Xubuntu 16.04, current updates installed.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: parole 0.8.1-1ubuntu2
ProcVersionSignature: Ubuntu 4.4.0-7.22-generic 4.4.2
Uname: Linux 4.4.0-7-generic i686
NonfreeKernelModules: nvidia
ApportVersion: 2.20-0ubuntu3
Architecture: i386
CurrentDesktop: XFCE
Date: Fri Feb 26 19:49:54 2016
InstallationDate: Installed on 2016-01-23 (33 days ago)
InstallationMedia: Xubuntu 16.04 LTS "Xenial Xerus" - Alpha i386 (20160123)
SourcePackage: parole
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
mikewhatever (mikewhatever) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in parole (Ubuntu):
status: New → Confirmed
Changed in parole (Ubuntu):
importance: Undecided → High
Revision history for this message
Sitsofe Wheeler (sitsofe) wrote :

Attaching partial backtrace.

#0 0xa44e87f4 in seeked_cb (player=0xa4803280, provider=0x2) at mpris2-provider.c:787
#5 0xa6fcb497 in <emit signal 0x7559f6ec "seeked" on instance 0xa4803280 [ParolePluginPlayer]> (instance=0xa4803280, detailed_signal=0x7559f6ec "seeked") at /build/glib2.0-Spm2To/glib2.0-2.48.0/./gobject/gsignal.c:3481
    #1 0xa6fb229c in g_cclosure_marshal_VOID__DOUBLE (closure=0x75a87a60, return_value=0x0, n_param_values=2, param_values=0xafffe610, invocation_hint=0xafffe5b4, marshal_data=0x0) at /build/glib2.0-Spm2To/glib2.0-2.48.0/./gobject/gmarshal.c:1680
    #2 0xa6fafb6b in g_closure_invoke (closure=0x75a87a60, return_value=0x0, n_param_values=2, param_values=0xafffe610, invocation_hint=0xafffe5b4) at /build/glib2.0-Spm2To/glib2.0-2.48.0/./gobject/gclosure.c:804
    #3 0xa6fc1ffc in signal_emit_unlocked_R (node=node@entry=0x759bc5f8, detail=detail@entry=0, instance=instance@entry=0xa4803280, emission_return=0x0, instance_and_params=0xafffe610) at /build/glib2.0-Spm2To/glib2.0-2.48.0/./gobject/gsignal.c:3629
    #4 0xa6fcac96 in g_signal_emit_valist (instance=0xa4803280, signal_id=413, detail=0, var_args=0xafffe800 "\020\350\377\257v\254Wux\341\214ug\030\373\246x\341\214u\200\062\200\244") at /build/glib2.0-Spm2To/glib2.0-2.48.0/./gobject/gsignal.c:3385
#6 0x7557ac99 in parole_plugin_player_media_seeked_cb (gst=0x758ce178 [ParoleGst], player=0xa4803280 [ParolePluginPlayer]) at parole-plugin-player.c:290

Revision history for this message
Sylvain Viart (sylvain-viart) wrote :

it happens every time on a up to date xubuntu 16.04.

Any hint?

Revision history for this message
daniel CURTIS (anoda) wrote :

Hello. I'm having similar problem, but in my case it's about playing an audio CD. (Trying to move a song time forward for a few seconds via manually moving time bar, Parole is closing immediately.) Here's my bug report: <>

Best regards.

Revision history for this message
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:

tags: added: iso-testing
Revision history for this message
Fixitman Arizona (fixitmanarizona) wrote :

Seems fixed in later version 0.9.1
I installed on Xubuntu 16.04.3 32-bit via .deb download and software center (because I forgot I had
gdebi package manager)
You can install from links on following page OR ppa;O=A

for Xubuntu or Ubuntu 16.10 or 17.04 version 0.9.2 is also available
Parole 0.9.2 requires GTK >= 3.20 Ubuntu 16.04 won’t be able to update to this release with the default GTK+3 libraries.


Revision history for this message
daniel CURTIS (anoda) wrote :


Because 'Parole' is a part of an Universe section, it will be - probably - not updated by Developers in Xenial/16.04 (please see rules about updating packages, because I can be wrong). Of course, your method Fixitman Arizona is okay.

By the way: please notice Gimp situation [1]: there are multiple security issues fixed in various Gimp versions and Releases - even in 14.04/Trusty, which is older than Xenial, right? Never mind. I have no idea why there is no security update for Gimp in Xenial.

Anyway, I solved problem with segfaults described by mikewhatever - an original poster by using AppArmor. Because in the past I've created a profile for Gimp, I decided to check what will happen when `` library will be blocked. And it worked!

,----[ AppArmor rule ]
| deny /usr/lib/@{multiarch}/parole-0/ mr,

With above rule in use, I can play any supported file/video and as Original Poster wrote: "click or drag the slider to seek forward (...)" and so on.

Thanks, best regards.


To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.