Gtk applications start with blank screen (Clutter 1.22.4 and GtkClutter 1.6.2)

Bug #1462445 reported by Elfy
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Clutter
Confirmed
High
Mugshot
Confirmed
Medium
Unassigned
parole
Confirmed
Medium
clutter-1.0 (Ubuntu)
Medium
Unassigned
parole (Ubuntu)
Medium
Unassigned
xubuntu-default-settings (Ubuntu)
Undecided
Sean Davis

Bug Description

Start parole - get blank 'grey' screen.

(also apparent with version in https://launchpad.net/~xubuntu-dev/+archive/ubuntu/ppa/?field.series_filter=wily -currently 0.8.0+git-0~898~ubuntu15.10.1 )

ProblemType: Bug
DistroRelease: Ubuntu 15.10
Package: parole 0.8.0-2ubuntu1
ProcVersionSignature: Ubuntu 3.19.0-20.20-generic 3.19.8
Uname: Linux 3.19.0-20-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.17.3-0ubuntu4
Architecture: amd64
CurrentDesktop: XFCE
Date: Fri Jun 5 17:38:06 2015
InstallationDate: Installed on 2015-05-12 (23 days ago)
InstallationMedia: Xubuntu 15.10 "Wily Werewolf" - Alpha amd64 (20150512)
SourcePackage: parole
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
In , ToZ (toz) wrote :
Download full text (5.0 KiB)

Since a recent update in Arch Linux to gtk3/clutter/cogl, parole (built from git) segfaults when the clutter backend is enabled. Not using the "--enable-clutter" configuration parameter makes parole work again. This is probably related to clutter migration to gdk backend (from x11)- see: https://blogs.gnome.org/clutter/

configure script results:

        Parole Media Player 0.8.0git.6eecaeb
        ====================================

        Installation:
        =============
        prefix: /usr
        pixmapsdir: /usr/share/parole/pixmaps
        Debug: no
        Building plugin api docs: yes
        GStreamer API version: 1.0
        GTK+ version: GTK+-3

        Optional dependencies:
        ======================
        Clutter Backend: yes
        Taglib: yes

        Plugins to build:
        =================
        Notify: yes
        System Tray icon: yes
        MPRIS2: yes

CLI output:
 (parole:16161): Clutter-CRITICAL **: Unable to check features. Have you initialized Clutter?

 (parole:16161): Clutter-CRITICAL **: Unable to check features. Have you initialized Clutter?

 (parole:16161): Clutter-WARNING **: Missing Cogl context: was Clutter correctly initialized?

STRACE output (last bit):
 write(2, "\n(parole:16388): Clutter-CRITICA"..., 94
 (parole:16388): Clutter-CRITICAL **: Unable to check features. Have you initialized Clutter?
 ) = 94
 futex(0x7faa52f62568, FUTEX_WAKE_PRIVATE, 2147483647) = 0
 write(2, "\n(parole:16388): Clutter-CRITICA"..., 94
 (parole:16388): Clutter-CRITICAL **: Unable to check features. Have you initialized Clutter?
 ) = 94
 write(2, "\n(parole:16388): Clutter-WARNING"..., 94
 (parole:16388): Clutter-WARNING **: Missing Cogl context: was Clutter correctly initialized?
 ) = 94
 futex(0x7faa52f62568, FUTEX_WAKE_PRIVATE, 2147483647) = 0
 futex(0x7faa52f62568, FUTEX_WAKE_PRIVATE, 2147483647) = 0
 futex(0x7faa52f62568, FUTEX_WAKE_PRIVATE, 2147483647) = 0
 futex(0x7faa52f62568, FUTEX_WAKE_PRIVATE, 2147483647) = 0
 futex(0x7faa52f62568, FUTEX_WAKE_PRIVATE, 2147483647) = 0
 --- SIGSEGV {si_signo=SIGSEGV, si_code=SEGV_MAPERR, si_addr=0xd8} ---
 +++ killed by SIGSEGV (core dumped) +++
 Segmentation fault (core dumped)

GDB output:
 (parole:16947): Clutter-CRITICAL **: Unable to check features. Have you initialized Clutter?

 (parole:16947): Clutter-CRITICAL **: Unable to check features. Have you initialized Clutter?

 (parole:16947): Clutter-WARNING **: Missing Cogl context: was Clutter correctly initialized?
 [New Thread 0x7fffe6d7b700 (LWP 16957)]
 [New Thread 0x7fffe8393700 (LWP 16956)]

 Program received signal SIGSEGV, Segmentation fault.
 0x00007ffff4eafa71 in cogl_pipeline_new () from /usr/lib/libcogl.so.20

GDB Backtrace:
 #0 0x00007ffff4eafa71 in cogl_pipeline_new () from /usr/lib/libcogl.so.20
 #1 0x00007ffff56113f5 in ?? () from /usr/lib/libclutter-1.0.so.0
 #2 0x00007ffff0ae6f49 in g_type_create_instance ()
    from /usr/lib/libgobject-2.0.so.0
 #3 0x00007ffff0aca2d8 in ?? () from /u...

Read more...

Revision history for this message
Elfy (elfy) wrote :
Revision history for this message
In , Elfy (elfy) wrote :

seen with 0.8.0-2ubuntu1 and 0.8.0+git-0~898~ubuntu15.10.1

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in parole (Ubuntu):
status: New → Confirmed
Revision history for this message
Paul White (paulw2u) wrote :

Additional problem - can't seem to close parole using either the close button or from the menu.

Changed in parole:
importance: Unknown → Medium
status: Unknown → Confirmed
Revision history for this message
Ubuntu QA Website (ubuntuqa) wrote : Re: Parole starts with blank screen

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1462445

tags: added: iso-testing
Changed in parole (Ubuntu):
importance: Undecided → Low
Revision history for this message
Paul White (paulw2u) wrote :

For what it's worth, parole *does* start and works as it should in an Ubuntu live session using daily build 20150606.

tags: added: xubuntu
Revision history for this message
Elfy (elfy) wrote :

@Alberto - Low?

When we've marked the upstream one Medium?

If you're not sure how Xubuntu wants bugs marked - could you either ask or leave them alone. Thanks

Revision history for this message
Jackson Doak (noskcaj) wrote :

IMO this should be medium at least, since it fits the guideline of "A usability issue that does not limit the functionality of a core application" given files cannot be opened from parole, but have to be opened via the file manager.

Just checking, the inability to play/pause and skip is also from this bug?

Changed in parole (Ubuntu):
importance: Low → Medium
Revision history for this message
In , Simon Steinbeiß (ochosi) wrote :

*** Bug 11965 has been marked as a duplicate of this bug. ***

Changed in parole:
importance: Medium → Unknown
status: Confirmed → Unknown
Revision history for this message
Simon Steinbeiß (ochosi) wrote :

Just so everybody is on the same page: this is a bug in clutter, even totem doesn't start in 15.10. We can relink the bugreport against clutter, when we have found some upstream report that reflects this problem.

Changed in parole:
importance: Unknown → Medium
status: Unknown → Confirmed
Revision history for this message
In , Jackson Doak (noskcaj) wrote :

Reverting to the old backends fixes this, see https://bugzilla.gnome.org/show_bug.cgi?id=743085

Changed in clutter-1.0 (Ubuntu):
status: New → Confirmed
Jackson Doak (noskcaj)
Changed in clutter-1.0 (Ubuntu):
importance: Undecided → Medium
Changed in clutter:
importance: Unknown → Critical
status: Unknown → Confirmed
Revision history for this message
In , ToZ (toz) wrote :

Updates to clutter (1.22.4-1) and clutter-gtk (1.6.2-1) have not fixed the issue for me. Also, I don't have an nvidia card but an Intel one. I'm currently building parole without the --enable-clutter parameter for it to work.

Forcing the x11 clutter backend via "CLUTTER_BACKEND=x11 parole" does not work either.

Changed in clutter:
status: Confirmed → Invalid
Revision history for this message
In , Simon Steinbeiß (ochosi) wrote :

@Toz: What Jackson meant was switching to either the X11 or XV backend in Parole, not clutter itself.

You can do this for instance from the command line (or xfce4-settings-editor):
xfconf-query -c parole -p /video/videosink -s "xv"

Revision history for this message
Simon Steinbeiß (ochosi) wrote : Re: Parole starts with blank screen

We have meanwhile uploaded a workaround to 15.10 in xubuntu-default-settings 15.10.1: http://bazaar.launchpad.net/~xubuntu-dev/xubuntu-default-settings/trunk/revision/576

Revision history for this message
In , Jackson Doak (noskcaj) wrote :

Reverting clutter's backend change will also fix this issue, at least for me

Revision history for this message
Sean Davis (bluesabre) wrote : Re: Parole starts with blank screen

Added Mugshot as affected project. The next release uses a clutter/Cheese based backend to render the webcam video. It works correctly in vivid, but fails in wily in the same way parole is affected.

Launching mugshot with: CLUTTER_BACKEND=x11 resolves the issue.

Relevant library versions:
gir1.2-clutter-1.0:amd64 (1.22.4-1)
gir1.2-gtkclutter-1.0:amd64 (1.6.2-1)

summary: - Parole starts with blank screen
+ Gtk applications start with blank screen (Clutter 1.22.4 and GtkClutter
+ 1.6.2)
Revision history for this message
Sean Davis (bluesabre) wrote :

Previously associated bug was resolved but did the fix did not apply to these applications. Created a new upstream bug.

Changed in clutter:
importance: Critical → Unknown
status: Invalid → Unknown
Changed in clutter:
importance: Unknown → High
status: Unknown → Confirmed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xubuntu-default-settings - 15.10.3

---------------
xubuntu-default-settings (15.10.3) wily; urgency=medium

  * etc/X11/Xsession.d/56xubuntu-session
    - Workaround clutter freezing gtk applications (LP: #1462445)
  * etc/xdg/xdg-xubuntu/xfce4/xfconf/xfce-perchannel-xml/parole.xml
    - Set parole video sink back to clutter

 -- Sean Davis <email address hidden> Sun, 06 Sep 2015 19:30:35 -0400

Changed in xubuntu-default-settings (Ubuntu):
status: New → Fix Released
Pasi Lallinaho (knome)
Changed in xubuntu-default-settings (Ubuntu):
assignee: nobody → Sean Davis (bluesabre)
Sean Davis (bluesabre)
Changed in mugshot:
status: New → Confirmed
importance: Undecided → Medium
Revision history for this message
Sean Davis (bluesabre) wrote :

The Clutter backend has been disabled in Parole since Xenial, and upstream since 0.9.1

parole (0.8.1-1ubuntu3) xenial; urgency=medium

  * Disable clutter backend, broken in xenial.
    - debian/control
    - debian/rules

 -- Sean Davis <email address hidden> Sun, 13 Mar 2016 17:40:18 -0400

Changed in parole (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.